Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: No audio in Youtube

  1. #1

    Default No audio in Youtube

    Ive asked twice already about various audio problems with streamed videos online with no response. So i moved to this forum area and will now narrow it down to just being concerned about gettin my audio back for youtube. Videos play fine, just no audio what so ever. Audio does work in Mplayer though. Just seems to have a problems with the embedded video players...such as youtube. Hopefully someone will respond to me.

  2. #2
    Join Date
    Jun 2008
    Location
    Levin, New Zealand
    Posts
    227

    Default Re: No audio in Youtube

    All I can suggest is use the multimedia troubleshooting guide at the top of that forum. I had audio working fine in everything except flash video. I found I had just one part of vlc that was not from packman. Since then I have disabled the vlc repo.


  3. #3
    Camalen NNTP User

    Default Re: No audio in Youtube

    Dimzamatic wrote:

    > Ive asked twice already about various audio problems with streamed
    > videos online with no response. So i moved to this forum area and will
    > now narrow it down to just being concerned about gettin my audio back
    > for youtube. Videos play fine, just no audio what so ever. Audio does
    > work in Mplayer though. Just seems to have a problems with the embedded
    > video players...such as youtube. Hopefully someone will respond to me.


    Are you running 11.1?

    If yes, try killing "pulseaudio" proccess and check if that works.

    Greetings,

    --
    Camalen

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: No audio in Youtube

    Quote Originally Posted by Dimzamatic View Post
    Ive asked twice already about various audio problems with streamed videos online with no response. So i moved to this forum area and will now narrow it down to just being concerned about gettin my audio back for youtube. Videos play fine, just no audio what so ever. Audio does work in Mplayer though. Just seems to have a problems with the embedded video players...such as youtube. Hopefully someone will respond to me.
    So youtube works ok with MPlayer and mplayer plugin? What is wrong with that player ?

    If you do not like mplayerplug-in, then another option is to simply download the youtube video, and then play it with another player after the video is downloaded. That is also a way to troubleshoot another player. Download the youtube video, and then try to play that video off of your hard drive. You can then possibly narrow in quicker as to what the problem might be (sometimes one needs to change the audio output mode in their player for that to work ). Also sometimes another device has seized the audio driver, and only some sound api's allow multiple devices to share the audio output from different multimedia applications at the same time. Did you check to see if more than one device had seized the audio driver (and did not let go ) ?

  5. #5
    Robert Carlson NNTP User

    Default Re: No audio in Youtube

    Camalen wrote:
    > Dimzamatic wrote:
    >
    >> Ive asked twice already about various audio problems with streamed
    >> videos online with no response. So i moved to this forum area and will
    >> now narrow it down to just being concerned about gettin my audio back
    >> for youtube. Videos play fine, just no audio what so ever. Audio does
    >> work in Mplayer though. Just seems to have a problems with the embedded
    >> video players...such as youtube. Hopefully someone will respond to me.

    >
    > Are you running 11.1?
    >
    > If yes, try killing "pulseaudio" proccess and check if that works.


    After the Kernel and Pulse updates that installed this morning, flash no
    longer worked for me. I had been having difficulties getting it
    started, but usually after several attempts to run the flash test page
    (http://www.musicofnature.com/songsof...est/index.html), it
    would start, but today it would not, no matter how many times I tried.
    So I killed pulse, and bingo, it ran the first try.

    My sound controller is on-board Intel ICH8. I looked at it in Yast but
    don't see how to disable pulse for it. How would I disable pulse?

    Bob Carlson

  6. #6
    Camalen NNTP User

    Default Re: No audio in Youtube

    Robert Carlson wrote:

    > After the Kernel and Pulse updates that installed this morning, flash no
    > longer worked for me. I had been having difficulties getting it
    > started, but usually after several attempts to run the flash test page
    > (http://www.musicofnature.com/songsof...est/index.html), it
    > would start, but today it would not, no matter how many times I tried.
    > So I killed pulse, and bingo, it ran the first try.
    >
    > My sound controller is on-board Intel ICH8. I looked at it in Yast but
    > don't see how to disable pulse for it. How would I disable pulse?


    There is a thread in this forum about this, take a look:

    - How do I completely disable pulseaudio?
    http://forums.opensuse.org/applicati...ulseaudio.html

    Another pages to look are the wiki ones:

    - Disabling Pulseaudio autospawn
    http://en.opensuse.org/PulseAudio

    - Disabling PulseAudio HowTo
    http://en.opensuse.org/Disabling_PulseAudio_HowTo

    Better than removing, try first to disable PA in YaST and check if that
    works.

    Greetings,

    --
    Camalen

  7. #7
    Robert Carlson NNTP User

    Default Re: No audio in Youtube

    Camalen wrote:
    > Robert Carlson wrote:
    >
    >> After the Kernel and Pulse updates that installed this morning, flash no
    >> longer worked for me. I had been having difficulties getting it
    >> started, but usually after several attempts to run the flash test page
    >> (http://www.musicofnature.com/songsof...est/index.html), it
    >> would start, but today it would not, no matter how many times I tried.
    >> So I killed pulse, and bingo, it ran the first try.
    >>
    >> My sound controller is on-board Intel ICH8. I looked at it in Yast but
    >> don't see how to disable pulse for it. How would I disable pulse?

    >
    > There is a thread in this forum about this, take a look:
    >
    > - How do I completely disable pulseaudio?
    > http://forums.opensuse.org/applicati...ulseaudio.html
    >
    > Another pages to look are the wiki ones:
    >
    > - Disabling Pulseaudio autospawn
    > http://en.opensuse.org/PulseAudio
    >
    > - Disabling PulseAudio HowTo
    > http://en.opensuse.org/Disabling_PulseAudio_HowTo
    >
    > Better than removing, try first to disable PA in YaST and check if that
    > works.


    Thanks. Setting autospawn = no in etc/pulse/client.conf seems to have
    done the trick.

    Bob Carlson

  8. #8

    Default Re: No audio in Youtube

    I went to do the autospawn thing and it says permission denied. I don't know how to run in root also. Im assuming its not just terminal then su because that still said permission denied when itried to open the client.config for pulseaudio.

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: No audio in Youtube

    Quote Originally Posted by Dimzamatic View Post
    I went to do the autospawn thing and it says permission denied. I don't know how to run in root also. Im assuming its not just terminal then su because that still said permission denied when itried to open the client.config for pulseaudio.
    To edit a file with root permissions ...
    • If using KDE: kdesu 'kwrite /etc/pulse/client.conf'
    • If using gnome: gnomesu 'gedit /etc/pulse/client.conf'
    enter root password when prompted.

  10. #10

    Default Re: No audio in Youtube

    Thank you. Audio problem is now solved. The culprit was indeed audiopluse.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •