Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Kmix boots muted.

Hybrid View

  1. #1

    Default Kmix boots muted.

    Kmix is always muted when I boot up. I also get a notification pop up that some sound device is not working, so the system is falling back to ?????? The notification flashes by too fast to read properly, but it seems to me that no matter which one I set up as the primary in Configure Desktop -> Multimedia -> Device Preferences.., that is the one that fails.

    I also have Kmix configured to show in the system tray and it doesn't until I go into the application menu and start it or start it from a command line. Once I unmute it everything sounds fine.

    So how can I get Kmix to boot unmuted and show up in the system tray?

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,432

    Default Re: Kmix boots muted.

    I have suddenly started to get the notification about falling back to PulseAudio but the sound is OK.

    Not sure what the problem is with KMix as it appears in the system tray unmuted every time. Have you tried 'Add to Panel' from the menu?

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,490
    Blog Entries
    37

    Default Re: Kmix boots muted.

    Quote Originally Posted by john_hudson View Post
    I have suddenly started to get the notification about falling back to PulseAudio but the sound is OK.
    This was a known bug. I believe a number of users have reported this. There are a more than a fewthreads here, where users have posted solutions that worked for them: I think I've seen other "solutions" as well, but a quick search did not reveal it (I probably had the wrong search parameters).

  4. #4
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Kmix boots muted.

    Quote Originally Posted by thedarpone View Post
    Kmix is always muted when I boot up. I also get a notification pop up that some sound device is not working, so the system is falling back to ?????? The notification flashes by too fast to read properly, but it seems to me that no matter which one I set up as the primary in Configure Desktop -> Multimedia -> Device Preferences.., that is the one that fails.

    I also have Kmix configured to show in the system tray and it doesn't until I go into the application menu and start it or start it from a command line. Once I unmute it everything sounds fine.

    So how can I get Kmix to boot unmuted and show up in the system tray?
    Since applying recent kernel update and a pulseaudio update, I get the problem of kmix muted on reboot. No notifier seen. Kmix in system tray from start, unmuted sound works.

    However on my testing partition of 11.2 milestone2 updated from factory butb different kernel, I had the same problem just with Kmix muted. I made a change to sysconfig, experimenting, reset the change but it's damaged something. Now on that system I get the problem more similar to you but without notifier yet.

    I expect these problems on the factory test system, but on 11.1 kernel update it's just shambolic.

  5. #5
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Kmix boots muted.

    Quote Originally Posted by consused View Post
    Since applying recent kernel update and a pulseaudio update, I get the problem of kmix muted on reboot. No notifier seen. Kmix in system tray from start, unmuted sound works...
    This is very strange! If I select YaST>Hardware>Sound and click on nothing further, the Kmix icon in the system tray is immediately unmuted.

    BTW, I am on KDE 3.5.10 on 11.1, and PulseAudio is not enabled in YaST>Hardware>Sound>Other>PulseAudio_Configuration>

    Please note this is also part of the OP's problem (may have since unwittingly been highjacked)

    I can't explain, can anyone else?

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,490
    Blog Entries
    37

    Default Re: Kmix boots muted.

    Quote Originally Posted by consused View Post
    This is very strange! If I select YaST>Hardware>Sound and click on nothing further, the Kmix icon in the system tray is immediately unmuted.

    BTW, I am on KDE 3.5.10 on 11.1, and PulseAudio is not enabled in YaST>Hardware>Sound>Other>PulseAudio_Configuration>
    I take it that trying to save the "unmuted" settings via kmix did not help?

  7. #7
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Kmix boots muted.

    Just tried saving the KMix settings even though they hadn't changed, and rebooted. No different, KMix still muted on reboot. (11.1 KDE 3.5.10). Also, note the YaST behaviour in amy bove post.

    I don't believe this is a KDE problem because it also appeared first on my Factory updated 11.2 milestone1/2 partition, that is at KDE 4.3beta.

  8. #8
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Kmix boots muted.

    Addendum
    oldcpu, to be clear it was unmuted settings I saved that did not help.

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,490
    Blog Entries
    37

    Default Re: Kmix boots muted.

    Quote Originally Posted by consused View Post
    Just tried saving the KMix settings even though they hadn't changed, and rebooted. No different, KMix still muted on reboot. (11.1 KDE 3.5.10). Also, note the YaST behaviour in amy bove post.

    I don't believe this is a KDE problem because it also appeared first on my Factory updated 11.2 milestone1/2 partition, that is at KDE 4.3beta.
    If you think it might be alsa instead of kde, you could try the guidance here:
    Troubleshooting Linux Audio, Part 3a | Linux Journal
    which is to setup your sound/mixer the way you want and then with root permissions run: alsactl store

    Thats just a very speculative suggestion of something to try on my part.

  10. #10
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Kmix boots muted.

    Ok, I understand your comments. The sound does work for now, it always has OOTB. It's just this KMix mute that is inconvenient, nothing really broken yet.

    I can't be sure its not KDE. On 11.2 since I interfered in sysconfig, I suddenly got long delays before KMix started and lockups, even though I reset the boot parameter I changed. I wish I had left it with just the inconvenient mute. It appear like Development have brought the 11.2 problem to 11.1 either with kernel or pulseaudio change.

    Two things changed here on 11.1, kernel update and pulseaudio update. I am not sure what config files get changed with such updates, but I am going to search logs and files that may have changed before I attempt to re-configure anything. Then I will investigate your suggestion - it will be useful experience even with no fix.

    That may take a while, so if you hit upon anything else, please post it here.

    Thanks oldcpu.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •