Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: yast not starting properly

  1. #1

    Default yast not starting properly

    Yast was not starting up properly so I killed all Yast processes (graceful kill) and now when I go to Yast{2}-> Software -> Software Management, the Software Management interface don't come up properly - it start the refresh and goes back to the Yast screen.

    in /var/log/messages I can see kernel: rpmmd2solv[9959]: segfault at b7c429d1 ip b7e8095d sp bfcdb8b8 error 4 in libc-2.9.so[b7e0d000+155000] - this message comes two times when I click Software Management from Yast.

    How can I resolve this issue?

    Thanks.

  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: yast not starting properly

    As root, try a "rpm --rebuilddb" and see if this changes anything.

    Uwe

  3. #3

    Default Re: yast not starting properly

    Hi there, here's my two cents worth..
    I am receiving the same error message, and I tried to rebuild the rpm --rebuilddb command, and still no resolve.

    I had found in google that the pacman repo has caused issues, but being production servers, I had not setup the pacman or the videolan repos, just the standard four repos.
    OSS, Update, Source, and Non-OSS repos... I disabled them all and still to no avail did it work correctly.

    Any ideas from someone who is less baffled than myself.
    (BTW I did have auto update enabled on my two servers and both are experiencing the same issues)

    Thanks for your help.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: yast not starting properly

    Try booting to level 3
    Login at the prompt as user
    Then go su and do:

    Code:
    zypper ref
    Code:
    zypper up
    If it's going to fails it will probably fail on the first one

    If zypper fails it's unlikely the other option to start yast will work:
    Code:
    yast
    Also check this, see if changing this package helps: http://forums.opensuse.org/applicati...ml#post1955079
    Let us know what happens
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: yast not starting properly

    I have not tried the suggested link, however I received the following when running "zypper ref"

    paris:~ # zypper ref
    Repository 'openSUSE-11.1-Update' is up to date.
    Building repository 'openSUSE-11.1-Update' cache [done]
    Error building the cache:
    'repo2solv.sh' '-o' '/var/cache/zypp/solv/repo-update/solv' '/var/cache/zypp/raw
    /repo-update'
    /usr/bin/repo2solv.sh: line 325: 4253 Broken pipe ( echo '<rpmmd>';
    for i in primary.xml* susedata.xml*;
    do
    test -s "$i" || continue; case $i in
    *.gz)
    gzip -dc "$i"
    ;;
    *.bz2)
    bzip2 -dc "$i"
    ;;
    *)
    cat "$i"
    ;;
    esac; echo; break;
    done; for i in susedata.xml*;
    do
    test -s "$i" || continue; case $i in
    *.gz)
    gzip -dc "$i"
    ;;
    *.bz2)
    bzip2 -dc "$i"
    ;;
    *)
    cat "$i"
    ;;
    esac; break;
    done; echo '</rpmmd>' )
    4254 | grep -v '\?xml'
    4256 | sed '1i\<?xml version="1.0" encoding="UTF-8"? >'
    4257 Segmentation fault | rpmmd2solv $parser_options > $primfile

    Skipping repository 'openSUSE-11.1-Update' because of the above error.
    Could not refresh the repositories because of errors.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: yast not starting properly

    I can tell that today there is a solver update in the update repo, let me post you the info:
    2009-06-11 03:57:32|install|satsolver-tools|0.13.7-0.1.1|i586|root@linux-khq3|repo-update|42ad2dbdf32b315354c4bc2a3836f4ae12ec2b5f
    2009-06-11 03:57:38|install|libzypp|5.30.3-0.1.1|i586||repo-update|2465a430882001f8a8de6eb0e9c827417c957e07
    Things to try:
    Manually download those and rpm install them

    or
    Rename the folders _old at /var/cache/zypp
    try again
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: yast not starting properly

    I should also note, after reading the post about yast2-qt-pkg ... that's for the GUI interface, and I'm not having an issue with the gui really; in the fact I generally just SSH without X-Server forwarding, and just use the console mode.

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: yast not starting properly

    Quote Originally Posted by chubbsdahorse View Post
    I should also note, after reading the post about yast2-qt-pkg ... that's for the GUI interface, and I'm not having an issue with the gui really; in the fact I generally just SSH without X-Server forwarding, and just use the console mode.
    Fine. I just put it there for your ref:
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: yast not starting properly

    Okay... I know I'm not the originator of the thread, but she's working again.

    Here's my steps:
    1.) Downloaded
    http://download.opensuse.org/update/...0.1.1.i586.rpm
    http://download.opensuse.org/update/...0.1.1.i586.rpm

    2.) Copied to my /root folder
    3.) Entered a console as root
    4.) ran the commands:
    Code:
    rpm -i --force ./satsolver-tools-0.13.7-0.1.1.i586.rpm
    Code:
    rpm -i --force ./libzypp-5.30.3-0.1.1.i586.rpm
    5.) Ran Yast, entered software management... worked.

    Thanks alot everyone for your help!
    Much appreciated!

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: yast not starting properly

    Great - Happy we sorted it for you
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •