Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Compositing problems

  1. #1
    Join Date
    Jun 2008
    Location
    Cluj, Romania
    Posts
    77

    Default Compositing problems

    A recent update broke KWin compositing. I can't remember exactly what packages were updated(kernel and pulseaudio are certain). I have an nvidia card. I update-ed the nvidia packages in yast, and still nothing.
    When I try to enable compositing in System Settings I get the following:

    Code:
    Failed to activate desktop effects using the given configuration options. Settings will be reverted to their previous values.
    
    Check your X configuration. You may also consider changing advanced options, especially changing the compositing type.
    How do I fix this?
    Respect the penguin!

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Compositing problems

    Have you logged out and back in since re-installing nvidia?
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Cluj, Romania
    Posts
    77

    Default Re: Compositing problems

    Quote Originally Posted by caf4926 View Post
    Have you logged out and back in since re-installing nvidia?
    Of course...
    Respect the penguin!

  4. #4
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Compositing problems

    Hi,

    Would you please post a copy of your xorg.conf located at /etc/X11

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  5. #5
    Join Date
    Jun 2008
    Location
    Cluj, Romania
    Posts
    77

    Default Re: Compositing problems

    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Wed May 27 03:15:36 PDT 2009                                                                              
    
    # /.../
    # SaX generated X11 config file
    # Created on: 2009-05-06T04:30:48+0300.
    #                                      
    # Version: 8.1                         
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #                                                                             
    # Automatically generated by [ISaX] (8.1)                                     
    # PLEASE DO NOT EDIT THIS FILE!                                               
    #                                                                             
    
    Section "ServerLayout"
        Identifier     "Layout[all]"
        Screen         "Screen[0]" 0 0
        InputDevice    "Keyboard[0]" "CoreKeyboard"
        InputDevice    "Mouse[1]" "CorePointer"    
        InputDevice    "Mouse[3]" "SendCoreEvents" 
        Option         "Clone" "off"               
        Option         "Xinerama" "off"            
    EndSection                                     
    
    Section "Files"
        InputDevices      "/dev/gpmdata"
        InputDevices      "/dev/input/mice"
        FontPath        "/usr/share/fonts/misc:unscaled"
        FontPath        "/usr/share/fonts/local"        
        FontPath        "/usr/share/fonts/75dpi:unscaled"
        FontPath        "/usr/share/fonts/100dpi:unscaled"
        FontPath        "/usr/share/fonts/Type1"          
        FontPath        "/usr/share/fonts/URW"            
        FontPath        "/usr/share/fonts/Speedo"         
        FontPath        "/usr/share/fonts/PEX"            
        FontPath        "/usr/share/fonts/cyrillic"       
        FontPath        "/usr/share/fonts/latin2/misc:unscaled"
        FontPath        "/usr/share/fonts/latin2/75dpi:unscaled"
        FontPath        "/usr/share/fonts/latin2/100dpi:unscaled"
        FontPath        "/usr/share/fonts/latin2/Type1"          
        FontPath        "/usr/share/fonts/latin7/75dpi:unscaled" 
        FontPath        "/usr/share/fonts/baekmuk:unscaled"      
        FontPath        "/usr/share/fonts/japanese:unscaled"     
        FontPath        "/usr/share/fonts/kwintv"                
        FontPath        "/usr/share/fonts/truetype"              
        FontPath        "/usr/share/fonts/uni:unscaled"          
        FontPath        "/usr/share/fonts/CID"                   
        FontPath        "/usr/share/fonts/ucs/misc:unscaled"     
        FontPath        "/usr/share/fonts/ucs/75dpi:unscaled"    
        FontPath        "/usr/share/fonts/ucs/100dpi:unscaled"   
        FontPath        "/usr/share/fonts/hellas/misc:unscaled"  
        FontPath        "/usr/share/fonts/hellas/75dpi:unscaled" 
        FontPath        "/usr/share/fonts/hellas/100dpi:unscaled"
        FontPath        "/usr/share/fonts/hellas/Type1"          
        FontPath        "/usr/share/fonts/misc/sgi:unscaled"     
        FontPath        "/usr/share/fonts/xtest"                 
        FontPath        "/opt/kde3/share/fonts"                  
    EndSection                                                   
    
    Section "Module"
        Load           "dbe"
        Load           "freetype"
        Load           "extmod"  
        Load           "glx"     
    EndSection                   
    
    Section "ServerFlags"
        Option         "AllowMouseOpenFail" "on"
        Option         "ZapWarning" "on"        
    EndSection                                  
    
    Section "InputDevice"
        Identifier     "Keyboard[0]"
        Driver         "kbd"        
        Option         "Protocol" "Standard"
        Option         "XkbLayout" "us"     
        Option         "XkbModel" "microsoftpro"
        Option         "XkbRules" "xfree86"     
    EndSection                                  
    
    Section "InputDevice"
        Identifier     "Mouse[1]"
        Driver         "mouse"   
        Option         "Buttons" "7"
        Option         "Device" "/dev/input/mice"
        Option         "Name" "KYE Wireless Mouse"
        Option         "Protocol" "explorerps/2"  
        Option         "Vendor" "Sysp"            
        Option         "ZAxisMapping" "4 5"       
    EndSection                                    
    
    Section "InputDevice"
        Identifier     "Mouse[3]"
        Driver         "synaptics"
        Option         "Buttons" "5"
        Option         "Device" "/dev/input/mice"
        Option         "Emulate3Buttons" "on"    
        Option         "HorizScrollDelta" "0"    
        Option         "InputFashion" "Mouse"    
        Option         "Name" "Synaptics;Touchpad"
        Option         "Protocol" "explorerps/2"  
        Option         "SHMConfig" "on"           
        Option         "Vendor" "Sysp"            
        Option         "ZAxisMapping" "4 5"       
    EndSection                                    
    
    Section "Modes"
        Identifier         "Modes[0]"
    EndSection                       
    
    Section "Monitor"
        Identifier     "Monitor[0]"
        VendorName     "--> LCD"   
        ModelName      "1024X768@60HZ"
        UseModes       "Modes[0]"     
        HorizSync       31.0 - 60.0   
        VertRefresh     30.0 - 60.0   
        Option         "CalcAlgorithm" "XServerPool"
        Option         "DPMS"                       
        Option         "PreferredMode" "1280x800"   
    EndSection                                      
    
    Section "Device"
        Identifier     "Device[0]"
        Driver         "nvidia"   
        VendorName     "NVidia"   
        BoardName      "GeForce 8400M G"
    EndSection                          
    
    Section "Screen"
        Identifier     "Screen[0]"
        Device         "Device[0]"
        Monitor        "Monitor[0]"
        DefaultDepth    24         
        SubSection     "Display"   
            Depth       15         
            Modes      "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"                                                  
        EndSubSection                                                                 
        SubSection     "Display"                                                      
            Depth       16                                                            
            Modes      "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"                                                  
        EndSubSection                                                                 
        SubSection     "Display"                                                      
            Depth       24                                                            
            Modes      "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"                                                  
        EndSubSection                                                                 
        SubSection     "Display"                                                      
            Depth       32
            Modes      "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
        EndSubSection
        SubSection     "Display"
            Depth       8
            Modes      "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
        EndSubSection
    EndSection
    
    Section "Extensions"
        Option         "Composite" "on"
    EndSection
    Respect the penguin!

  6. #6
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Compositing problems

    Try enabling aiglx

    In your xorg.conf file under Section "ServerLayout" add

    Code:
    Option "aiglx" "true"
    Then open a terminal and run these commands.

    Code:
    su
    root password

    Code:
    nvidia-xconfig --composite
    nvidia-xconfig --render-accel
    nvidia-xconfig --add-argb-glx-visuals -d 24Try
    Try that then restart (I think a simple logout then login might work but restart to be safe), and see where that gets you.

    Good Luck,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,587
    Blog Entries
    14

    Default Re: Compositing problems

    Please, open a terminal and post output of:

    rpm -qa | grep kernel-
    rpm -qa | grep nvidia
    glxinfo | grep direct

    You should be able to get it working without AIGLX. If not through the repos, than the manual way. That seems hard, but I can provide you with the steps to take.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8
    Join Date
    Jun 2008
    Location
    Cluj, Romania
    Posts
    77

    Default Re: Compositing problems

    Quote Originally Posted by ijbreakey View Post
    Try enabling aiglx

    In your xorg.conf file under Section "ServerLayout" add

    Code:
    Option "aiglx" "true"
    Then open a terminal and run these commands.

    Code:
    su
    root password

    Code:
    nvidia-xconfig --composite
    nvidia-xconfig --render-accel
    nvidia-xconfig --add-argb-glx-visuals -d 24Try
    Try that then restart (I think a simple logout then login might work but restart to be safe), and see where that gets you.

    Good Luck,

    Ian
    Thanks man! This fixed it.
    Respect the penguin!

  9. #9
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Compositing problems

    @zolistir87
    Glad I could help out!

    @Knurpht
    Quote Originally Posted by Knurpht View Post
    You should be able to get it working without AIGLX.
    I only have one old NVIDIA card (see my sig) so this is the only way I could ever get it to work with both the repository and manually compiling ways. Is it bad to be telling users to enable AIGLX and run those commands? I remember reading that they're not really necessary but it seems to work sometimes as in this case.

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  10. #10

    Default Re: Compositing problems

    My impression it will default to it with the newer drivers as for bad no superfluous maybe.

    I suspect it may be one of the other ones.

    To be honest I've not even got composite on in mine Xorg went to a hotplugging model recently. In theory you don't need an xorg.conf but practise is a litte different.

    If you look at the modules loaded for your keyboard you'll notice that it doesn't load kbd but evdev.

    grep evdev /var/log/Xorg.0.log

    How the auto config tools are dealing with it I'm not sure and having a problem with my keyboard I can't begin to unravel it.

    Yast uses some system variables for certain bits. Still not quite worked out whether sax2 is actually being honoured. I have managed to force xorg to use kbd but can no longer remember how.
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •