Results 1 to 5 of 5

Thread: Cant Run YaST anymore

  1. #1

    Unhappy Cant Run YaST anymore

    I just switched from Ubuntu to SUSE (Running 11.1). I was doing fine until I installed Kompozer. YaST didn't detect any dependency issues so I thought all was fine. After the installation, the desktop lost its links and icons and the Software Manager no longer run.

    I get the following error messages when I try to run YaST or the software manager:

    /usr/lib/YaST2/bin/y2base: /lib/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6)
    /usr/lib/YaST2/plugin/libpy2gtk.so.2: /lib/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6)
    /usr/lib/YaST2/bin/y2base: /lib/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6)
    Gtk-Message: Failed to load module "gnomebreakpad": /lib/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6)
    Is this one of those situations where I get to retrieve my installation CD and start afresh or is there another way around this?

  2. #2
    Join Date
    Jun 2008
    Location
    Connecticut, USA
    Posts
    2,294
    Blog Entries
    1

    Default Re: Cant Run YaST anymore

    Quote Originally Posted by twohot View Post
    I just switched from Ubuntu to SUSE (Running 11.1). I was doing fine until I installed Kompozer. YaST didn't detect any dependency issues so I thought all was fine. After the installation, the desktop lost its links and icons and the Software Manager no longer run.

    I get the following error messages when I try to run YaST or the software manager:



    Is this one of those situations where I get to retrieve my installation CD and start afresh or is there another way around this?
    Have you tried running Yast from the command line? It works in the terminal console too.

    As root, run "yast2" I believe, and that should produce a terminal-formatted Yast instance which may bypass any gui/gnome dependencies.
    "Linux provides freedom, problem is most users don't know what it is or how to use it." ~me
    Friends don't let Friends wear red shirts on away parties!
    Linux User #477531 | Danbury Area Computer Society (www.dacs.org)

  3. #3

    Default Re: Cant Run YaST anymore

    Issuing yast2 in the terminal only revealed concealed error messages:

    ** (y2controlcenter-gnome:5109): WARNING **: error accessing /desktop/gnome/applications/y2cc-gnome/cc_exit_shell_on_action_start [Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See GConf configuration system for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)]

    the command still opened some gui's (output was not strictly restricted to the terminal)

  4. #4
    Join Date
    Jun 2008
    Location
    Connecticut, USA
    Posts
    2,294
    Blog Entries
    1

    Default Re: Cant Run YaST anymore

    What about doing Cntrl + F2 to go to a terminal session, log in and try it there? There is no X running so no GUI should be launched.

    Otherwise, I am not experienced enough with Yast or Zypper to know what to do next. Maybe the openSUSE CD/DVD contains a "Repair" feature?
    "Linux provides freedom, problem is most users don't know what it is or how to use it." ~me
    Friends don't let Friends wear red shirts on away parties!
    Linux User #477531 | Danbury Area Computer Society (www.dacs.org)

  5. #5

    Default Re: Cant Run YaST anymore

    ...off to try. Will be back with results

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •