I just switched from Ubuntu to SUSE (Running 11.1). I was doing fine until I installed Kompozer. YaST didn't detect any dependency issues so I thought all was fine. After the installation, the desktop lost its links and icons and the Software Manager no longer run.

I get the following error messages when I try to run YaST or the software manager:

/usr/lib/YaST2/bin/y2base: /lib/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6)
/usr/lib/YaST2/plugin/libpy2gtk.so.2: /lib/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6)
/usr/lib/YaST2/bin/y2base: /lib/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6)
Gtk-Message: Failed to load module "gnomebreakpad": /lib/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6)
Is this one of those situations where I get to retrieve my installation CD and start afresh or is there another way around this?