Results 1 to 10 of 10

Thread: hide samba version number

  1. #1

    Default hide samba version number

    When I mount my samba share on XP, I see the version number (eg. marketing on 'Samba 3.0.29-SUSE-SL11.0 (samba.company.tld). How do I hide the version number?

    Thanks.

  2. #2
    Join Date
    Jul 2008
    Location
    Antwerp, Belgium
    Posts
    42

    Default Re: hide samba version number

    You have to set the server string in smb.conf or in yast:

    server string = "whatever you want it to be"

    then restart samba and remount your share
    http://www.philipraets.be
    Hardware: Dell Mini 9, Dell Vostro 1510, Sony Vaio FZ21M, SelfMade PC
    Software: openSUSE, Xen, openLDAP, Samba, Nagios, Apache, MySQL, Oracle, Still no mailserver

  3. #3

    Default Re: hide samba version number

    I did and it didn't resolve the issue. I restarted smb and nmb on the server (/etc/init.d/smb restart && /etc/init.d/nmb restart) and on XP: I right click and disconnected my Samba share, logged off my XP session, logged back on again and mapped the samba drive.

    Here is my smb.conf

    Code:
    [global]
            workgroup = WORKGROUP
    	/var/lib/nobody -s /bin/false %m$
            domain logons = Yes
            domain master = Yes
            local master = Yes
            os level = 65
            preferred master = Yes
            security = user
            server string = "test"
    
    [chris]
            comment = All users
            path = /home/chirs/
            read only = No
            browseable = Yes
            inherit acls = Yes
            veto files = /aquota.user/groups/shares/
    
    [tmp]  
            comment = All users
            path = /tmp
            read only = No
            browseable = Yes
    Thanks.

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: hide samba version number

    We found that idiotic Windows caches the identifier string. We upgraded one server from Samba 3.0 to 3.3 and it's still showing the old string. You may have to delete the cached login credentials from Windows. Sorry no idea how to do that, we didn't do anything about it.

  5. #5

    Default Re: hide samba version number

    Quote Originally Posted by ken_yap View Post
    We found that idiotic Windows caches the identifier string. We upgraded one server from Samba 3.0 to 3.3 and it's still showing the old string. You may have to delete the cached login credentials from Windows. Sorry no idea how to do that, we didn't do anything about it.
    Yes, you are spot on. I found and deleted the cache and that resolved the issue. Thanks.

  6. #6
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: hide samba version number

    Can you post how you did that? It would be helpful to others.
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  7. #7
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: hide samba version number

    +1

    I'd like to know too, it might be useful.

  8. #8

    Default Re: hide samba version number

    The version number for the Samba server is cached in the Windows registry. To delete this information, run the Windows Registry Editor (Start > Run > Regedit) and open the following key:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\ComputerDescriptions

    Then delete the entry for for the samba server.

  9. #9
    Join Date
    Jul 2008
    Location
    Munich, Germany
    Posts
    116

    Default Re: hide samba version number

    Quote Originally Posted by ken_yap View Post
    We found that idiotic Windows caches the identifier string. We upgraded one server from Samba 3.0 to 3.3 and it's still showing the old string. You may have to delete the cached login credentials from Windows. Sorry no idea how to do that, we didn't do anything about it.
    I too had the very same problem. Actually I had two problems after making some changes to my Samba server:
    Windows XP cached the old Samba server description AND it cached the old credentials too...
    • Tho get rid of the cached server description, the solution is as described by pgriffith: Delete or change the appropriate registry entry in HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\ComputerDescriptions
    • To get rid of the cached credentials, one must call "rundll32.exe keymgr.dll, KRShowKeyMgr" from a command prompt which will open a litte dialog which allows for editing/deleting existing credentials in the cache.

  10. #10
    Join Date
    Jun 2008
    Location
    Mallow, Ireland
    Posts
    1,031
    Blog Entries
    1

    Default Re: hide samba version number

    Maybe these scripts might help? Get, Set, and Clear Computer Discriptions With Ease
    Think I might have to make use of it as well to make 'Idiotic Windows' see my new server string!
    "To err is human... to really foul up requires the root password."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •