Results 1 to 8 of 8

Thread: Amarok problems

  1. #1

    Default Amarok problems

    I have several problems with the latest amarok. I'm running amarok2.1 on kde4.3 beta. I can not edit tags anymore. When I choose to edit a tag I only get a cancel button. When I try to sync music to my mp3tunes locker, amarok crashes. Anyone elso having problems with the latest amarok package?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Amarok problems

    Edit is working for me


    Done use devices.

    see my sig for sys spec
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,841
    Blog Entries
    14

    Default Re: Amarok problems

    Everything works here. But.......you might be stuck with the remains of previous versions. I let Amarok create a new database and config on every major KDE change. To do so, issue the following commands:
    rm -rf ~/.kde4/share/apps/amarok
    rm ~/.kde4/share/config/amarok*
    Now you can start the new Amarok and have it creating it's new config and database.
    Take care: to get the scripts working you need qt4-qtscript to be installed.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: Amarok problems

    I already treid removing the amarok config files but that didn't help. The problems started when I switched to kde4.3 beta.

  5. #5
    Join Date
    Mar 2008
    Location
    Vsters, Sweden ex. Highbury London UK
    Posts
    1,245

    Default Re: Amarok problems

    Try rolling back the version. I have 2.1-2.1 and everything is working as it should
    Core 2 Duo 3.16GHz, 8GB DDR2, 3.5TB, GeForce 9600 GT, Amilo LCD 26", OS 11.1 x86_64, KDE4.2.4 (2)
    My wine tips & tricks

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Amarok problems

    Mine: 2.1-14.3
    Working

    Try starting it in a terminal, see if any errors stand out
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: Amarok problems

    Ran amarok in debug mode from terminal and got this error.
    [TagDialog] [WARNING!] NOT-IMPLEMENTED:QStringList Dialog::getCommonLabels()

    The problem appers to be related to Qt4.

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Amarok problems

    In Yast Software Management search for:

    kde4-kdialog
    libqdialogsolver1
    taglib-extras

    add if missing
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •