Results 1 to 7 of 7

Thread: How to selectively prohibit screensaver?

  1. #1
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default How to selectively prohibit screensaver?

    Hi

    There are some apps that when in use (realPlayer, Kaffein, SMPlayer etc), I do not want screensaver to start.
    How to set it?
    Emil Beli
    http://www.beli.ws/blog/
    openSUSE 11.4 x64 KDE, ATI 5600, i7 dell inspire laptop

  2. #2
    Join Date
    Jun 2008
    Location
    Frisco, TX
    Posts
    1,233

    Default Re: How to selectively prohibit screensaver?

    beli0135 wrote:
    > Hi
    >
    > There are some apps that when in use (realPlayer, Kaffein, SMPlayer
    > etc), I do not want screensaver to start.
    > How to set it?
    >
    >


    In KDE 3.5, just setting the power mgmt Active Scheme to
    Presentation will keep the screensaver from kicking in (as a part
    of being idle).

    KDE 4? It lives in a place outside of reason.... I will not attempt
    to predict it.

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,587
    Blog Entries
    14

    Default Re: How to selectively prohibit screensaver?

    @cjcox: How wrong can you be? From the beginning of KDE4 the powermanagement gives you exactly the same option: Presentation. This keeps the screensaver from covering presentations and video.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: How to selectively prohibit screensaver?

    (Forgot to mention, I use kde 4)
    Well, yes. Selecting to presentation(or whatever I configured) will disable screensaver - totally. But, in that case, I need to change schema when I watch video.

    I thought there is a setting where I can make a list of apps where screensaver is disabled when running, or some other solution, but to be selectively, on application level.
    That is because, when I watch video - (any player running), I certainly do not want screensaver, no matter what scheme I choose.
    Emil Beli
    http://www.beli.ws/blog/
    openSUSE 11.4 x64 KDE, ATI 5600, i7 dell inspire laptop

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,587
    Blog Entries
    14

    Default Re: How to selectively prohibit screensaver?

    I know I've seen it somewhere in an application setting: "Do not start screensaver when playing", but don't remember where.
    Also, can you check in Desktop - Screensaver - Advanced if priority is set to Low?
    Which players do you use? Or does the screensaver start with any player?

    Funny thing is, here the screensaver does not start when I play video, not in windowed mode, not in full screen.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: How to selectively prohibit screensaver?

    Starts with any...
    I use RealPlayer, MPlayer and Kaffeine, mostly.
    Emil Beli
    http://www.beli.ws/blog/
    openSUSE 11.4 x64 KDE, ATI 5600, i7 dell inspire laptop

  7. #7
    Join Date
    Jun 2008
    Location
    Frisco, TX
    Posts
    1,233

    Default Re: How to selectively prohibit screensaver?

    On Mon, 2009-06-08 at 09:26 +0000, Knurpht wrote:
    > @cjcox: How wrong can you be? From the beginning of KDE4 the
    > powermanagement gives you exactly the same option: Presentation. This
    > keeps the screensaver from covering presentations and video.


    My point is that KDE4 NEVER intended to preserve KDE3
    functionality... so, you never know what will or what will
    not work with KDE4. That's "right".. not "wrong".




Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •