Results 1 to 7 of 7

Thread: OpenSuse 10.2 + Postfix

  1. #1

    Exclamation OpenSuse 10.2 + Postfix

    Hello, i hope i do post in the right forum (was searching for about 5 minutes) and i need to know if i can run Postfix with an open Suse 10.2 Image. And i need to know if i can use all features of Postfix and specially this feature to create images (i believe its called imagemack)

    i need this information and i hope someone can give me the right answere.

    There is another Question about OpenSuse and GDLIB. gdlib is needed to use that imagemack or i am wrong?

    thanks in advance

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,415

    Default Re: OpenSuse 10.2 + Postfix

    ImageMagick is nothing to do with Postfix; if you have a default installation of 10.2, it should be there already along with Postfix.

    However, 10.2 is no longer supported; you really should be updating to 11.1 where you will find both these programs available.

  3. #3
    Join Date
    Jul 2008
    Location
    Voorhout, Netherlands
    Posts
    262

    Default Re: OpenSuse 10.2 + Postfix

    mischlig wrote:
    > Hello, i hope i do post in the right forum (was searching for about 5
    > minutes) and i need to know if i can run Postfix with an open Suse 10.2
    > Image. And i need to know if i can use all features of Postfix and
    > specially this feature to create images (i believe its called
    > imagemack)


    If you're refering to ImageMagick: this has nothing to do with Postfix.
    $rpm -qi ImageMagick|grep Summary
    Summary : Viewer and Converter for Images

    $rpm -qi postfix|grep Summary
    Summary : A fast, secure, and flexible mailer

    Postfix is supported on 10.2, and runs out of the box.

    > There is another Question about OpenSuse and GDLIB. gdlib is needed to
    > use that imagemack or i am wrong?


    Again, if you're refering to ImageMagick the you are wrong, it doesn't
    need gdlib.

    Theo

  4. #4

    Default Re: OpenSuse 10.2 + Postfix

    Quote Originally Posted by LittleRedRooster View Post
    mischlig wrote:
    > Hello, i hope i do post in the right forum (was searching for about 5
    > minutes) and i need to know if i can run Postfix with an open Suse 10.2
    > Image. And i need to know if i can use all features of Postfix and
    > specially this feature to create images (i believe its called
    > imagemack)


    If you're refering to ImageMagick: this has nothing to do with Postfix.
    $rpm -qi ImageMagick|grep Summary
    Summary : Viewer and Converter for Images

    $rpm -qi postfix|grep Summary
    Summary : A fast, secure, and flexible mailer

    Postfix is supported on 10.2, and runs out of the box.

    > There is another Question about OpenSuse and GDLIB. gdlib is needed to
    > use that imagemack or i am wrong?


    Again, if you're refering to ImageMagick the you are wrong, it doesn't
    need gdlib.

    Theo
    i am wondering, i was sure to have heard this on a HowTo from the web. Imagemagick and gdlib arent needed for postfix. okay, please excuse my further posting, do i need this packages for any other of the following posted one:

    Procmail

    Read User Mail

    WUFTP or PROFTPD?

    really excuse my question but with one provider i can only use this 10.2 image and the actual 11.1 will be added much later 2month or so.

    I know that for Imagecreating "Captcha codes" i need this imagemagick and gdlib. this was an upcoming problem by trying to install phpBB or other "Captcha" using tools

    i hope i can get an further answere.

    thanks.

  5. #5
    Join Date
    Jul 2008
    Location
    Voorhout, Netherlands
    Posts
    262

    Default Re: OpenSuse 10.2 + Postfix

    mischlig wrote:
    > LittleRedRooster;1996278 Wrote:
    >> mischlig wrote:

    [..]
    >>> There is another Question about OpenSuse and GDLIB. gdlib is needed

    >> to
    >>> use that imagemack or i am wrong?

    >> Again, if you're refering to ImageMagick the you are wrong, it doesn't
    >> need gdlib.

    >
    > i am wondering, i was sure to have heard this on a HowTo from the web.
    > Imagemagick and gdlib arent needed for postfix. okay, please excuse my
    > further posting, do i need this packages for any other of the following
    > posted one:
    >
    > Procmail
    >
    > Read User Mail
    >
    > WUFTP or PROFTPD?


    No.

    > really excuse my question but with one provider i can only use this
    > 10.2 image and the actual 11.1 will be added much later 2month or so.


    I have no idea what provider you mean or how and why this provider limits
    your choices.

    > I know that for Imagecreating "Captcha codes" i need this imagemagick
    > and gdlib. this was an upcoming problem by trying to install phpBB or
    > other "Captcha" using tools


    That makes more sense. PHP needs gdlib to generate images.

  6. #6

    Default Re: OpenSuse 10.2 + Postfix

    >> > I know that for Imagecreating "Captcha codes" i need >> this imagemagick
    >> > and gdlib. this was an upcoming problem by trying to >> install phpBB or
    >> > other "Captcha" using tools

    > That makes more sense. PHP needs gdlib to generate images.

    yes thank you. i got trouble with this provider and i am searching for oppurtunities to quit the contract. you say php needs gdlib to generate images. maybe someone can give me an answere. if in the contract php5.2 is listed than it must be possible to use all php features. is fact. i dont want to use php5.2 with only some features. Imagecreating is a part of php. can someone confirm that please?

    Suse v10.2 LAMP + Webmin

    - Openssh v4.4
    - Apache v2.2
    - Mysql v5.0
    - PHP v5.2
    - Perl v5.8
    - Python v2.5
    - Webmin v1.3

    thats was my listing for that Suse 10.2

    and there PHP 5.2 is listed. If Imagecreating is a part of PHP i got luck.

    I hope someone can help me out. I got this package only for a few days and cant quit the contract after i was logging in (its a part of contract)

    thanks

  7. #7
    Join Date
    Jul 2008
    Location
    Voorhout, Netherlands
    Posts
    262

    Default Re: OpenSuse 10.2 + Postfix

    mischlig wrote:
    >>>> I know that for Imagecreating "Captcha codes" i need >> this

    > imagemagick
    >>>> and gdlib. this was an upcoming problem by trying to >> install

    > phpBB or
    >>>> other "Captcha" using tools

    >
    >> That makes more sense. PHP needs gdlib to generate images.

    >
    > yes thank you. i got trouble with this provider and i am searching for
    > oppurtunities to quit the contract. you say php needs gdlib to generate
    > images. maybe someone can give me an answere. if in the contract php5.2
    > is listed than it must be possible to use all php features. is fact. i
    > dont want to use php5.2 with only some features. Imagecreating is a part
    > of php. can someone confirm that please?


    You'd probably be better off asking this on a PHP devel channel but
    afaik, PHP doesn't have native image manipulation support, so it needs
    a 3th party lib like e.g. gdlib for that.

    >
    > Suse v10.2 LAMP + Webmin
    >
    > - Openssh v4.4
    > - Apache v2.2
    > - Mysql v5.0
    > - PHP v5.2
    > - Perl v5.8
    > - Python v2.5
    > - Webmin v1.3
    >
    > thats was my listing for that Suse 10.2


    If they do not provide any newer versions then I would suggest to look
    for another provider.

    > and there PHP 5.2 is listed. If Imagecreating is a part of PHP i got
    > luck.


    Not as far as I know.

    Theo

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •