Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: gstreamer crashes apps...

Hybrid View

  1. #1
    Join Date
    Jul 2008
    Location
    Loutraki-Bologna
    Posts
    63

    Default gstreamer crashes apps...

    Hi everyone...I have a problem with pidgin,elisa and brasero...
    Every time I try to start them ,they crashe with the following error:
    ERROR: Caught a segmentation fault while loading plugin file:
    /usr/lib/gstreamer-0.10/libgstladspa.so

    Please either:
    - remove it and restart.
    - run with --gst-disable-segtrap and debug.
    I reinstalled gstreamer but nothing changed.
    Is there any way to baypass this problem??
    Google didnt help me find something...
    I'm using opensuse 11.1...
    Thanks for your help...

  2. #2
    Join Date
    Jun 2008
    Location
    Glasgow, Scotland
    Posts
    184

    Default Re: gstreamer crashes apps...

    What version of Pidgin are you using?

    I had a similar problem recently with Pidgin and Gstreamer. My particular problem was caused by the priority number of the update repo being set to 20 (live CD install of 11.1 KDE 4.2.3). I overcame the problem by setting the priority number to 99 and then I did an update all, which pulled in some updated Gstreamer packages from Packman. After that, everything worked just fine.

  3. #3
    Join Date
    Jul 2008
    Location
    Loutraki-Bologna
    Posts
    63

    Default Re: gstreamer crashes apps...

    Thanks for your reply...
    Pidgin is 2.5.6 and gstreamer-bad-plugin is installed from the packman repo..
    Do you have any other suggestion?

  4. #4
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: gstreamer crashes apps...

    rpm -qa | grep -i gstreamer

    Post the results here. Alternative just remove the -bad package.

  5. #5
    Join Date
    Jul 2008
    Location
    Loutraki-Bologna
    Posts
    63

    Default Re: gstreamer crashes apps...

    rpm gives me this:
    gstreamer-0_10-java-1.1-42.pm.1
    gstreamer-0_10-fluendo-mp3-0.10.10-42.pm.1
    gstreamer-0_10-plugins-base-devel-0.10.23-42.pm.1
    banshee-1-backend-engine-gstreamer-1.4.3-1.2.1
    gstreamer-0_10-0.10.23-42.pm.1
    gstreamer-0_10-devel-0.10.23-42.pm.1
    gstreamer-0_10-utils-0.10.23-42.pm.1
    phonon-backend-gstreamer-0_10-4.3.1-4.1
    gstreamer-0_10-plugins-farsight-0.12.11-0.pm.5
    gstreamer-0_10-plugins-ugly-0.10.11-42.pm.1
    gstreamer-0_10-fluendo-mpegdemux-0.10.23-42.pm.1
    libgstreamer-0_10-0-0.10.23-42.pm.1
    gstreamer-0_10-plugins-bad-0.10.12-42.pm.1
    gstreamer-utils-0.10.23-42.pm.1
    gstreamer-0_10-plugins-base-lang-0.10.23-42.pm.1
    gstreamer-0_10-plugins-bad-lang-0.10.12-42.pm.1
    python-gstreamer-0_10-0.10.15-42.pm.1
    gstreamer-0_10-plugins-ugly-lang-0.10.11-42.pm.1
    gstreamer-0_10-plugins-good-extra-0.10.10-3.21.1
    gstreamer-0_10-schroedinger-1.0.5-42.pm.4
    kaffeine-gstreamer-0.8.8-0.pm.1
    gstreamer-0_10-lang-0.10.23-42.pm.1
    cuberok-gstreamer-0.0.10-2.2
    bluez-gstreamer-4.22-6.1.1
    gstreamer-0_10-ffmpeg-0.10.7-42.pm.1
    gstreamer-0_10-fluendo-mpegmux-0.10.4-42.pm.1
    gstreamer-0_10-doc-0.10.23-42.pm.1
    kde3-kaffeine-gstreamer-0.8.7-49.1
    gstreamer-0_10-plugins-base-0.10.23-42.pm.1
    gstreamer-0_10-plugins-good-0.10.10-3.21.1


    if i try to remove gstreamer-bad,it gives me dependecies problems and i have to remove all the programs related to gstreamer-bad like elisa and brasero...

  6. #6
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: gstreamer crashes apps...

    Yep, you have mixed packages - for example the good should have .pm in it (packman) and so forth.

    You could go to YAST, Package Management there, search for gstreamer and install the pm versions for those that have them available in the Versions tab.

    You could also try (as root or with root privileges through su - ):

    zypper ref
    zypper up
    zypper ve


    also
    zypper in gstreamer-0_10-plugins-good
    should pull the .pm version (and other dependencies)

  7. #7
    Join Date
    Jul 2008
    Location
    Loutraki-Bologna
    Posts
    63

    Default Re: gstreamer crashes apps...

    I update all gstreamer packages to pm version..
    But still same error at pidgin ,brasero , exaile...

  8. #8
    Join Date
    Jun 2008
    Location
    Glasgow, Scotland
    Posts
    184

    Default Re: gstreamer crashes apps...

    As you can see, my plugins are all from the same vendor - Packman. I'm not saying having different plugins from different vendors is the problem, but it might be.

    rpm -qa | grep -i gstreamer


    colin@linux-bx5d:~> rpm -qa | grep -i gstreamer
    libgstreamer-0_10-0-0.10.23-42.pm.1
    gstreamer-0_10-0.10.23-42.pm.1
    gstreamer-0_10-plugins-bad-lang-0.10.12-42.pm.1
    gstreamer-0_10-lang-0.10.23-42.pm.1
    gstreamer-0_10-plugins-base-0.10.23-42.pm.1
    gstreamer-0_10-plugins-good-0.10.15-42.pm.1
    phonon-backend-gstreamer-0_10-4.3.1-28.32
    gstreamer-0_10-utils-0.10.23-42.pm.1
    gstreamer-utils-0.10.23-42.pm.1
    gstreamer-0_10-plugins-base-lang-0.10.23-42.pm.1
    gstreamer-0_10-plugins-good-lang-0.10.15-42.pm.1
    gstreamer-0_10-plugins-bad-0.10.12-42.pm.1
    gstreamer-0_10-fluendo-mp3-0.10.10-42.pm.1
    gstreamer-0_10-schroedinger-1.0.5-42.pm.4

  9. #9
    Join Date
    Jul 2008
    Location
    Loutraki-Bologna
    Posts
    63

    Default Re: gstreamer crashes apps...

    yes i can see but after your advice mine also looks like this:
    rpm -qa | grep -i gstreamer
    gstreamer-0_10-java-1.1-42.pm.1
    gstreamer-0_10-fluendo-mp3-0.10.10-42.pm.1
    gstreamer-0_10-plugins-base-devel-0.10.23-42.pm.1
    gstreamer-0_10-plugins-good-0.10.15-42.pm.1
    gstreamer-0_10-0.10.23-42.pm.1
    gstreamer-0_10-devel-0.10.23-42.pm.1
    gstreamer-0_10-utils-0.10.23-42.pm.1
    gstreamer-0_10-plugins-good-lang-0.10.15-42.pm.1
    gstreamer-0_10-plugins-farsight-0.12.11-0.pm.5
    gstreamer-0_10-plugins-ugly-0.10.11-42.pm.1
    gstreamer-0_10-fluendo-mpegdemux-0.10.23-42.pm.1
    libgstreamer-0_10-0-0.10.23-42.pm.1
    gstreamer-0_10-plugins-bad-0.10.12-42.pm.1
    gstreamer-utils-0.10.23-42.pm.1
    gstreamer-0_10-plugins-base-lang-0.10.23-42.pm.1
    gstreamer-0_10-plugins-bad-lang-0.10.12-42.pm.1
    gstreamer-0_10-plugins-ugly-lang-0.10.11-42.pm.1
    gstreamer-0_10-schroedinger-1.0.5-42.pm.4
    kaffeine-gstreamer-0.8.8-0.pm.1
    gstreamer-0_10-lang-0.10.23-42.pm.1
    gstreamer-0_10-plugins-good-extra-0.10.15-42.pm.1
    gstreamer-0_10-ffmpeg-0.10.7-42.pm.1
    gstreamer-0_10-fluendo-mpegmux-0.10.4-42.pm.1
    gstreamer-0_10-doc-0.10.23-42.pm.1
    gstreamer-0_10-plugins-base-0.10.23-42.pm.1
    Everything from packman repo...

  10. #10
    Join Date
    Jul 2008
    Location
    Loutraki-Bologna
    Posts
    63

    Default Re: gstreamer crashes apps...

    The only way to run these pros is deleting gstreamer-plugins-bad ignoring the dependecies problem that create this unistall.
    Dont know if that is safe but is the only way i found..
    Thanks for you replies...

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •