Results 1 to 9 of 9

Thread: screensaver locking is unstoppable?

  1. #1
    tom millican NNTP User

    Default screensaver locking is unstoppable?

    I've tried everything that I could think of and everything that came up
    by googling the problem. After a few minutes, whether the screensaver is
    on or not, whether the power management is enabled or not, whether the
    require password button is checked or not, the screensaver will start and
    require a password to log back in. Surprisingly, it does select the
    screensaver that was last checked, even when it's not set to come on.
    It's getting a little bit annoying. Are there any suggestions?
    Thanks,
    -Tom


  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,181
    Blog Entries
    1

    Default Re: screensaver locking is unstoppable?

    What DE are you using? I'm assuming KDE 4.X...

  3. #3

    Default Re: screensaver locking is unstoppable?

    I had a pain in the neck experience with mnaing OpenSuse behave the way I wanted it to, from editing power settings, to screensaver to monitor...
    KDE4 is not that intuitive in this area right now.

  4. #4
    tom millican NNTP User

    Default Re: screensaver locking is unstoppable?

    I completely forgot to mention that. Thanks for the reminder.
    It's KDE 4.2 on Opensuse 11.1 (64bit).
    Thanks.

    deano ferrari wrote:

    >
    > What DE are you using? I'm assuming KDE 4.X...
    >
    >




  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,726
    Blog Entries
    20

    Default Re: screensaver locking is unstoppable?

    Go to Configure Desktop - Display - Power Control

    Uncheck the box there 'Enable Display Power Management'

    Then obviously in Configure Desktop -Advanced Tab - Power Management
    make sure all your settings are to not lock screen.

    If that does not work, go to hidden files in /home/username
    and rename the file .kde4/share/config/powerdevilrc

    to powerdevilrc_old

    logout
    login

    start customizing your power settings again
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: screensaver locking is unstoppable?

    Quote Originally Posted by tom millican View Post
    I've tried everything that I could think of and everything that came up
    by googling the problem. After a few minutes, whether the screensaver is
    on or not, whether the power management is enabled or not, whether the
    require password button is checked or not, the screensaver will start and
    require a password to log back in. Surprisingly, it does select the
    screensaver that was last checked, even when it's not set to come on.
    It's getting a little bit annoying. Are there any suggestions?
    Thanks,
    -Tom
    I've seen this behaviour on a fresh 11.1 32-bit install with all updates applied. When I downgraded to plain 11.1 everything was working like expected. This must be a bug introduced with one of the updates.

  7. #7
    Join Date
    Jul 2008
    Location
    Arizona, USA
    Posts
    48

    Default Re: screensaver locking is unstoppable?

    This was driving me nuts too, tried the personal settings application under general - display - power control and under advanced - power management and no combination of settings helped keep my screen powered up.

    I clicked on the Kpowersave managemnet icon in the system tray and noticed power managemnet settings there too. Changing them from the icon seems to have done the trick.

    No idea why there are three places to manage this that don't seem to share settings and two of them don't seem to work.

  8. #8
    JosephKK NNTP User

    Default Re: screensaver locking is unstoppable?

    On Thu, 11 Jun 2009 19:56:02 GMT, stan qaz
    <stan_qaz@no-mx.forums.opensuse.org> wrote:

    >
    >This was driving me nuts too, tried the personal settings application
    >under general - display - power control and under advanced - power
    >management and no combination of settings helped keep my screen powered
    >up.
    >
    >I clicked on the Kpowersave managemnet icon in the system tray and
    >noticed power managemnet settings there too. Changing them from the icon
    >seems to have done the trick.
    >
    >No idea why there are three places to manage this that don't seem to
    >share settings and two of them don't seem to work.


    That signals not ready for prime time to me.

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,181
    Blog Entries
    1

    Default Re: screensaver locking is unstoppable?

    I clicked on the Kpowersave managemnet icon in the system tray and noticed power managemnet settings there too. Changing them from the icon seems to have done the trick.

    No idea why there are three places to manage this that don't seem to share settings and two of them don't seem to work.
    This happens if you have the powersaved daemon and kpowersave (KDE3 power management) running. Then PowerDevil (the new power management system) will not work.

    Another thread dealing with this topic:

    Powerdevil does not want to start - openSUSE Forums

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •