Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Ugly login screen?

  1. #1

    Default Ugly login screen?

    For some reason my login screen is looking very much unthemed. Just an old fashioned grey box and some text like: "linux-t7wg".

    If I go to the KDE Login Manager everything is greyed out.

    Looks like something somewhere is messing with my login configuration. Can anyone help me to unpick it?

    I'm running 11.1 with KDE 4.3 (installed from a "KDE Four Live" CD).

    Thanks in advance.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Ugly login screen?

    I didn't even know there was a live cd with kde4.3, unless it's of your own making.

    Boot to level 3 and as root do

    Code:
    sax2 -r -m 0=vesa
    That may help, it will load a basic graphics. From there you can look at installing the correct driver. Depending what it is?
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Ugly login screen?

    Go to sysconfig->Desktop->Display Manager-> DISPLAYMANAGER_KDM_THEME and write oxygen

    Also set kdm4 as DISPLAYMANAGER at the same group of Display Manager in sysconfig.
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  4. #4

    Default Re: Ugly login screen?

    @Bender: Thanks for that. I have about 20 "DISPLAYMANAGER_..." items listed, but none refer to KDM or anything like it. Maybe that is my issue? I have set "DISPLAYMANAGER" to KDE4.

    @caf4926: Thanks for the advice, but my issue is not having a clue about what driver I might need to install, if any. For info, the KDE 4.3 live CD comes through here: "KDE Four Live" CD

  5. #5

    Default Re: Ugly login screen?

    I know that you can't set many system wide settings using the KDE system settings, instead you need to use YaST to change system wide settings. I was quite specific as to what and where to change

    DISPLAYMANAGER_KDM_THEME = oxygen
    DISPLAYMANAGER = kdm4

    That should do it.

    P.S. Of course you can set other kdm themes but those you need download from kde-look.org and save them somewhere at /home/<user/.kde4 or /usr/share, can't remember where right now.

    To help a bit here's an image of what to set

    P.S.2 It should be KDM_THEME not LOCAL, sorry for that
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  6. #6

    Default Re: Ugly login screen?

    I hear you Bender, I hear you, but as I said before: the "DISPLAYMANAGER_KDM..." things are simply not there. Something I need to install, perhaps?

    Image here, to show I'm not making this up ;-)


    Thanks for helping me out.

  7. #7

    Default Re: Ugly login screen?

    Try to install some kdm themes, they should pull necessary packages.
    Perhaps installing kde4-kdm will help?
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  8. #8

    Default Re: Ugly login screen?

    Well, I've tried everything I can think of with this. Hardly a massive problem, but a bit of a shame.

    I have discovered that the login options are always greyed out unless you call them up via the console as root, using "systemsettings". Doesn't matter what I change there though, I always get the old style theme.

    I've installed everything with KDM in its name through Yast2, including upstream/OpenSuse branding. I've also installed KDM themes from kde-look, including reinstalling the Oxygen theme.

    Shall I just give up and leave you all in peace ..?

  9. #9
    Join Date
    Oct 2008
    Location
    Chicago
    Posts
    40

    Default Re: Ugly login screen?

    Just a shot in the dark, but if you found the config options Bender pointed out in post #6, be advised they are case sensitive. I had a similar issue a few months back which was fixed when I changed the KDM THEME from "Oxygen" to "oxygen."

  10. #10

    Default Re: Ugly login screen?

    Well bguger me heinrich, you were dead right. Do you know where the theme files are kept? The log in screen is now KDE styled, but it's at the wrong resolution I think (background image is distorted) and I'd like to use a different theme so need to work out where to put it.

    In an unexpected turn of events this simultaneously resolved my inability to shut down properly.

    Hurrah! Thanks for the input.

    Quick recap just in case it helps anyone :

    1) I had to create the sysconfig variable by adding:
    Code:
    DISPLAYMANAGER_KDM_THEME="oxygen"
    to the last line of my /etc/sysconfig/displaymanager file USING THE CORRECT CaSe!

    2) I can edit my login options only via alt-F2,
    Code:
    kdesu systemsettings
    then going to "advanced"/"login manager". Only some settings make a difference under KDE 4.3 it would seem. I can't change the theme here, for example.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •