Results 1 to 6 of 6

Thread: Unable to switch from Gnome to KDE desktop

  1. #1
    Join Date
    May 2009
    Location
    US
    Posts
    867

    Default Unable to switch from Gnome to KDE desktop

    I have been using Gnome and just installed KDE4. I can't figure out how to switch to the KDE environment.

    From what I've read on this forum, I'm supposed to have an option on the login screen where I can choose my DE but I don't have that option.

    What now?
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Unable to switch from Gnome to KDE desktop

    Disable auto-login via Yast - Security And Users - User group management
    Expert options
    you may need to reboot

    Check this re;kde4
    http://forums.opensuse.org/how-faq-r...ml#post1986169
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    May 2009
    Location
    US
    Posts
    867

    Default Re: Unable to switch from Gnome to KDE desktop

    Auto user login in is already disabled.

    I also have the kde/42 repo added to YAST. It was added by the one click install. Do you think something didn't go right with the install of KDE?
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,395
    Blog Entries
    1

    Default Re: Unable to switch from Gnome to KDE desktop

    Some users seem to experience problems at the login window if using gdm. If I was you, I would login to Gnome as normal. Then use YaST /etc/sysconfig editor to change display manager from gdm to kdm. Navigate to Desktop --> Display manager --> DISPLAYMANAGER

    Alternatively, you can edit /etc/sysconfig/displaymanager directly (as root) and change this line

    DISPLAYMANAGER="gdm"
    to

    DISPLAYMANAGER="kdm"
    Now when you login you can change session to KDE as required.

  5. #5
    Join Date
    May 2009
    Location
    US
    Posts
    867

    Default Re: Unable to switch from Gnome to KDE desktop

    Thanks. That worked.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,395
    Blog Entries
    1

    Default Re: Unable to switch from Gnome to KDE desktop

    You're welcome Make sure you have a look around this forum re KDE 4.2. (Don't use the earlier KDE 4.1.X version). Lots of posts discussing this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •