Results 1 to 7 of 7

Thread: Sound only working from headphones

  1. #1
    Naatis NNTP User

    Default Sound only working from headphones

    I have a Gateway P-6831FX laptop. My sound seems to work fine through my headphones, but I can't seem to get sound through my speakers. I've been playing with my mixer settings and I can't find anything that seems to fix it. I've been looking at a lot of the other threads regarding sound problems, so i'll just post what I think will be asked for.

    http://www.alsa-project.org/db/?f=6c...059a1f5e3ce4bb


    i ran these commands:

    Code:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound
    and got this output:
    Code:
    peter@linux-dclo:~> rpm -qa | grep alsa
    alsa-1.0.18-8.9                        
    alsa-utils-1.0.18-6.4                  
    alsa-oss-32bit-1.0.17-1.37             
    alsa-firmware-1.0.17-1.51              
    alsa-plugins-pulse-1.0.18-6.13         
    alsa-plugins-1.0.18-6.13               
    alsa-oss-1.0.17-1.43                   
    peter@linux-dclo:~> rpm -qa | grep pulse
    pulseaudio-utils-0.9.12-9.5             
    pulseaudio-esound-compat-0.9.12-9.5     
    pulseaudio-module-x11-0.9.12-9.5        
    libpulse0-0.9.12-9.5                    
    pulseaudio-0.9.12-9.5                   
    pulseaudio-module-lirc-0.9.12-9.5       
    libpulse-browse0-0.9.12-9.5             
    libpulse-mainloop-glib0-0.9.12-9.5
    alsa-plugins-pulse-1.0.18-6.13
    pulseaudio-module-bluetooth-0.9.12-9.5
    libxine1-pulse-1.1.16.3-0.pm.2
    libpulsecore4-0.9.12-9.5
    pulseaudio-module-zeroconf-0.9.12-9.5
    pulseaudio-module-jack-0.9.12-9.5
    peter@linux-dclo:~> rpm -q libasound2
    libasound2-1.0.18-8.9
    peter@linux-dclo:~> uname -a
    Linux linux-dclo 2.6.27.21-0.1-trace #1 SMP 2009-03-31 14:50:44 +0200 x86_64 x86_64 x86_64 GNU/Linux
    peter@linux-dclo:~> cat /etc/modprobe.d/sound
    alias snd-card-0 snd-hda-intel
    alias sound-slot-0 snd-hda-intel
    options snd-hda-intel model=auto enable_msi=1
    peter@linux-dclo:~>
    Contents of /etc/modprobe.d/sound
    Code:
    alias snd-card-0 snd-hda-intel
    alias sound-slot-0 snd-hda-intel
    options snd-hda-intel model=auto enable_msi=1
    I appreciate any help that might be given.

  2. #2
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    27,116
    Blog Entries
    34

    Default Re: Sound only working from headphones

    Quote Originally Posted by Naatis View Post
    I have a Gateway P-6831FX laptop. My sound seems to work fine through my headphones, but I can't seem to get sound through my speakers. I've been playing with my mixer settings and I can't find anything that seems to fix it. I've been looking at a lot of the other threads regarding sound problems, so i'll just post what I think will be asked for.

    http://www.alsa-project.org/db/?f=6c...059a1f5e3ce4bb
    Well done in getting this far.

    I note a 64-bit openSUSE-11.1 with the latest SuSE-GmbH packaged (for 11.1) kernel 2.6.21.27-trace with a mix of 1.0.17 and 1.0.18 alsa. I note also an IDT 92HD71B8X hardware audio codec.

    If you stick with the 2.6.21.27-trace kernel then I am not confident that I can help you. I recommend you switch back to the 2.6.21.27-default kernel. Why are you using the trace?

    The next thing I noted is the model option "auto" that you have selected. That is NOT an option for the IDT 92HD71B8X for 1.0.17/1.0.18 of alsa, ... or if it is an option, then it is not a documented option.

    Glad to read your sound works in your headphones, but according to the alsa-configuration.txt file for 1.0.18 of alsa, the model options for the IDT 92HD71Bx are:
    Code:
    	STAC92HD71B*
    	  ref		Reference board
    	  dell-m4-1	Dell desktops
    	  dell-m4-2	Dell desktops
    Try each of those, one at a time, in place of "auto" in the /etc/modprobe.d/sound file (restart your alsa sound driver with su -c 'rcalsasound restart' - enter root passward, and restart your mixer and test your sound . ie replace "auto" with "ref" ... restart alsa, restart mixer, test sound. Then replace "ref" with "dell-m4-1" , restart alsa, restart mixer, test sound. Then replace "dell-m4-1" with "dell-m4-2", restart alsa, restart mixer, and test sound.

    If that does not work, try updating alsa. You can do that with your PC connected to the internet by opening a terminal or a konsole and copy and pasting and executing, in sequence, one at a time, the following six zypper commands to update alsa to 1.0.20 (I typed the command under the assumption that you reverted to the "default" kernel from the "trace" kernel):
    Code:
    zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.1/ multimedia
    Code:
    zypper install alsa-oss alsa-oss-32bit alsa-utils alsa-tools alsa-firmware alsa-plugins alsa-plugins-pulse
    Code:
    zypper rr multimedia
    Code:
    zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.1_Update/ multimedia
    Code:
    zypper install alsa-driver-kmp-default
    Code:
    zypper rr multimedia
    The 5th command is different if using the trace kernel.

    Again, after the update is complete restart and test your audio.

    Note version 1.0.20 of alsa, in the HDA-Audio-Models.txt file has the following list of model options for the 92HD71B* hardware audio codec:
    Code:
    STAC92HD71B*
    ============
      ref		Reference board
      dell-m4-1	Dell desktops
      dell-m4-2	Dell desktops
      dell-m4-3	Dell desktops
      hp-m4		HP mini 1000
      hp-dv5	HP dv series
      hp-hdx	HP HDX series
      auto		BIOS setup (default)
    I note in this case, the model "auto" is an option.

    Good luck. It took some time to type the above, so I hope this works.

  3. #3
    Naatis NNTP User

    Default Re: Sound only working from headphones

    After changing the mode in the /etc/modprobe.d/sound like you suggested, my sound works perfectly. Thanks!

    As for why I'm using the -trace kernel, I'm not really sure. I don't know what the difference is between the default and trace. Grub selected this kernel after I installed the nvidia drivers. When I choose to boot in to the default kernel, X won't start. Is it important for me to be using the default kernel? If so, is there a way to switch back to the default kernel? I'm sorry about asking for more help, but if it's an easy fix and I'd be better off with the default kernel, I'd like to do that.

  4. #4
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    27,116
    Blog Entries
    34

    Default Re: Sound only working from headphones

    Quote Originally Posted by Naatis View Post
    After changing the mode in the /etc/modprobe.d/sound like you suggested, my sound works perfectly.
    Super! Glad to read its working. In case anyone one else reading this thread has same PC as you, what model option works best for you?

    Quote Originally Posted by Naatis View Post
    Grub selected this kernel after I installed the nvidia drivers.
    Grub selected it when the nvidia drivers were installed? Thats strange. I have not heard of that. Did you install a nVidia driver version that was built specifically for the "trace" kernel, which caused a kernel change due to dependency checking (as part of the driver installation process) ?

  5. #5
    Naatis NNTP User

    Default Re: Sound only working from headphones

    Sorry, disregard the changing the kernel stuff, i figured that out. No problems now. Thanks for the help.

  6. #6
    Tiffanygopal102 NNTP User

    Default Re: Sound only working from headphones

    If your sound is not working from your latop but the headphones will work with the sound only if your having trouble with the sound working with your headphones only here's what you can do

    1. Start On The Menu Section
    2. On The Right Side Of The Menu Go To Control Panel
    3. (Click) On Smart Audio
    4. Once you click on smart Audio
    5. Click On Audio Director
    6. Under Test 1 & 2 Click On Classic Mode To Check It Off.
    7.Once the classic mode is checked off make sure you restart Your Latop
    8. Once Your Latop Is Restarted Then Go To Windows MEdia Player Click On Any Song you want,and then click on the song and then your sound will be working again.
    Hope This Works Bye.

  7. #7
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    27,116
    Blog Entries
    34

    Default Re: Sound only working from headphones

    Quote Originally Posted by Tiffanygopal102 View Post
    8. Once Your Latop Is Restarted Then Go To Windows MEdia Player Click On Any Song you want,and then click on the song and then your sound will be working again.
    Hope This Works Bye.
    Thanks for your efforts to contribute.

    I guess you did not realize, openSUSE forums are a Linux operating system forum, and not for the MS-Windows operating systems. The solution you gave is presumably for MS-Windows computers.

    But please give Linux a try sometime.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •