Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: openSuSE 11.1 dazuko load module FATAL

  1. #1
    reroi_novell NNTP User

    Default openSuSE 11.1 dazuko load module FATAL

    Hi all,

    I'm configuring the antivir solution with on-demand scan in my openSuSE 11.1, but I have some problems/errors with dazuko module. The status is:

    - Kernel 2.6.27.21-0.1-default #1 SMP 2009-03-31 14:50:44 +0200 x86_64 x86_64 x86_64 GNU/Linux
    - antivir-2.1.10.15-52.4
    - antivir-gui-2.1.10.15-1.117
    - antivir-avguard-2.1.10.15-52.4
    - dazuko-kmp-default-2.3.6_2.6.27.19_3.2-1.49.6
    - dazuko-2.3.6-7.1


    When I try to load the dazuko module I receive an error:

    cal0024:~ # /etc/init.d/boot.dazuko start
    Loading dazuko on-access scanner interface failed

    or

    cal0024:~ # modprobe dazuko
    FATAL: Module dazuko not found.

    The AppArmor is completely uninstalled.
    Any idea?

    Fabio Sambugaro
    Last edited by reroi_novell; 02-Jun-2009 at 23:51. Reason: Title error

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: openSuSE 11.1 dazuko load module FATAL

    To be honest I'm not sure what the problem is. I have never bothered with this application. It's just not required in Linux.
    Someone may be able to advise though, just wait it out.
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    reroi_novell NNTP User

    Default Re: openSuSE 11.1 dazuko load module FATAL

    ok It's just not required in Linux, but I'm configuring in the same host an external ftp server, and I would add a security scan layer on uploaded files.
    Thanks. I wait for further suggestions.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,587
    Blog Entries
    14

    Default Re: openSuSE 11.1 dazuko load module FATAL

    Found it !! You upgraded the kernel to 2.6.27.21 while your dazuko module is built for 2.6.27.19 There's the problem. You should have dazuko compiled for the running kernel.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    reroi_novell NNTP User

    Default Re: openSuSE 11.1 dazuko load module FATAL

    Where can I find the right package, compiled for my kernel?
    Thanks.

  6. #6

    Default Re: openSuSE 11.1 dazuko load module FATAL

    Quote Originally Posted by Knurpht View Post
    Found it !! You upgraded the kernel to 2.6.27.21 while your dazuko module is built for 2.6.27.19 There's the problem. You should have dazuko compiled for the running kernel.
    Nope:

    Code:
    # uname -r
    2.6.27.21-0.1-pae
    # zypper in dazuko-kmp-pae
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following NEW package is going to be installed:
      dazuko-kmp-pae
    
    
    Overall download size: 293.0 K. After the operation, additional 1.3 M will be used.
    Continue? [YES/no]:
    Retrieving package dazuko-kmp-pae-2.3.6_2.6.27.19_3.2-1.49.6.i586 (1/1), 293.0 K (1.3 M unpacked)
    Retrieving: dazuko-kmp-pae-2.3.6_2.6.27.19_3.2-1.49.6.i586.rpm [done]
    Installing: dazuko-kmp-pae-2.3.6_2.6.27.19_3.2-1.49.6 [done]
    Additional rpm output:
    24475 blocks
    
    
    # modprobe -v dazuko
    insmod /lib/modules/2.6.27.21-0.1-pae/weak-updates/updates/redirfs/redirfs.ko
    insmod /lib/modules/2.6.27.21-0.1-pae/weak-updates/updates/dazuko/dazuko.ko
    # lsmod |grep dazuko
    dazuko                 31144  1
    redirfs                40808  1 dazuko,[permanent]
    Works for me™

  7. #7
    reroi_novell NNTP User

    Default Re: openSuSE 11.1 dazuko load module FATAL

    Hello Akoellh,

    you installed dazuko-kmp-pae, while I installed the dazuko-kmp-default: they are different.
    Other suggestions?

  8. #8

    Default Re: openSuSE 11.1 dazuko load module FATAL

    Somehow I knew what the answer would be.

    I had to, because I use kernel-pae, but to show you that it's not because of that (1 reboot later):

    Code:
    # uname -r
    2.6.27.21-0.1-default
    
    # zypper in dazuko-kmp-default
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following NEW package is going to be installed:
      dazuko-kmp-default
    
    
    Overall download size: 283.0 K. After the operation, additional 1.9 M will be used.
    Continue? [YES/no]:
    Retrieving package dazuko-kmp-default-2.3.6_2.6.27.19_3.2-1.49.6.x86_64 (1/1), 283.0 K (1.9 M unpacked)
    Installing: dazuko-kmp-default-2.3.6_2.6.27.19_3.2-1.49.6 [done]
    Additional rpm output:
    26870 blocks
    
    # modprobe -v dazuko
    insmod /lib/modules/2.6.27.21-0.1-default/weak-updates/updates/redirfs/redirfs.ko
    insmod /lib/modules/2.6.27.21-0.1-default/weak-updates/updates/dazuko/dazuko.ko
    
    # lsmod |grep dazuko
    dazuko                 36752  1
    redirfs                51176  1 dazuko,[permanent]
    Works for me™ (Part 2)

    So you are obviously doing something wrong here.

  9. #9
    reroi_novell NNTP User

    Default Re: openSuSE 11.1 dazuko load module FATAL

    Hello,

    I haven't these links:
    /lib/modules/2.6.27.21-0.1-default/weak-updates/updates/redirfs/redirfs.ko
    /lib/modules/2.6.27.21-0.1-default/weak-updates/updates/dazuko/dazuko.ko


    Why? I have installed the packages by Yast. ???

  10. #10

    Default Re: openSuSE 11.1 dazuko load module FATAL

    Code:
    rpm -qa "*kernel*" "*dazuko*"
    
    uname -r
    ?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •