Results 1 to 7 of 7

Thread: plasmoid compilation error

  1. #1

    Default plasmoid compilation error

    Dear all

    when I try to compile plasmoids from source or other things for kde4 i always get the following errors:

    -- Found Qt-Version 4.4.3 (using /usr/bin/qmake)
    -- Found X11: /usr/lib64/libX11.so
    CMake Error at /usr/share/kde4/apps/cmake/modules/FindKDE4Internal.cmake:1060 (message):
    Qt compiled without support for -fvisibility=hidden. This will break
    plugins and linking of some applications. Please fix your Qt installation.
    Call Stack (most recent call first):
    /usr/share/cmake/Modules/FindKDE4.cmake:81 (FIND_PACKAGE)
    CMakeLists.txt:3 (find_package)

    Does anybody know how to solve this?

    I am running 11.1 kde4 reloaded using all of the kde4 repositories installed by default

    Thanks a lot

  2. #2
    Join Date
    Jun 2008
    Location
    /dev/belgium
    Posts
    1,946

    Default Re: plasmoid compilation error

    try with the QT 4.5.x libraries Index of /repositories/KDE:/Qt45

  3. #3

    Default Re: plasmoid compilation error

    Quote Originally Posted by microchip8 View Post
    try with the QT 4.5.x libraries Index of /repositories/KDE:/Qt45
    Are you using qt 4.5 with kde 4.2 and having a stable system?

  4. #4
    Join Date
    Jun 2008
    Location
    /dev/belgium
    Posts
    1,946

    Default Re: plasmoid compilation error

    Quote Originally Posted by algarues View Post
    Are you using qt 4.5 with kde 4.2 and having a stable system?
    Yes....

  5. #5

    Default Re: plasmoid compilation error

    Quote Originally Posted by microchip8 View Post
    Yes....
    ok, will make a backup of my system and then give it a try
    Thanks

  6. #6

    Default Re: plasmoid compilation error

    actually all of it was due to the fact that I was not compiling in my home directory.
    After moving the sources in my home everything went fine

  7. #7

    Cool Re: plasmoid compilation error

    Quote Originally Posted by microchip8 View Post
    Yes....
    after upgrading qt to 4.5 the system tray in my panel stopped from getting garbled all the time and it is now always nice twenty for seven

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •