Results 1 to 4 of 4

Thread: smb and nmb start on opensuse 10.3

Hybrid View

  1. #1

    Default smb and nmb start on opensuse 10.3

    Is there any way to start both of them with a single script?
    I don't want to write my own custom script.

    Starting smb (/etc/init.d/smb start), only starts smb (not nmb), althought the smb script says it should start nmb as well.

    thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: smb and nmb start on opensuse 10.3

    Just enable nmb to start at boot. Use YaST or

    Code:
    chkconfig --set nmb on

  3. #3

    Default Re: smb and nmb start on opensuse 10.3

    Quote Originally Posted by ken_yap View Post
    Just enable nmb to start at boot. Use YaST or

    Code:
    chkconfig --set nmb on
    Code:
     bash# chkconfig --set nmb on && /etc/init.d/smb stop && /etc/init.d/smb start && pgrep nmb
    shows nothing.

    Code:
     bash# /etc/init.d/nmb start && pgrep nmb
    shows nmb started.

    Yast is not an option. I am taking this cannot be from CLI on SUSE. Thanks.

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: smb and nmb start on opensuse 10.3

    The two services are separate. I only showed you how to enable nmb to start at boot. That's all that is necessary. Starting smb at boot doesn't start nmb. Either the comment is wrong, or it's a bug you should report. But making nmb start at boot is all you really need, not to link the two services.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •