Results 1 to 5 of 5

Thread: KDE 4.2.3 latest DUP result strange error while loging in X

  1. #1

    Default KDE 4.2.3 latest DUP result strange error while loging in X

    Hi,
    I installed latest dependency update (zypper dup) to the opensuse 11.1 64 bit. After post installation restart, I cannot login to sytem and X says in a window:
    Code:
    Logging in UserName...
    Authentication failed 
    Do you have the same issue or it's something about that I changed with yast at login Manager. Regards.

  2. #2
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: KDE 4.2.3 latest DUP result strange error while loging i

    Do you have anything other than English enabled?
    If that is the case, try to type in the login name (do not click and select) and then type in the password.
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  3. #3

    Default Re: KDE 4.2.3 latest DUP result strange error while loging i

    Quote Originally Posted by syampillai View Post
    Do you have anything other than English enabled?
    If that is the case, try to type in the login name (do not click and select) and then type in the password.
    No, everything in english. Actually, automatically login in enabled, so I don't enter any username or password while the X is starting.

    I tried to start it in FailSafe mode, then entered my username&passowrd to the console, then tried to start x (with startx command). It turned to black screen at the end of loading the things to start X (for kde interface, as you know it start with a small hdd image than continue until a big kde logo, my system failed at that kde logo).

    By the way. that DUP was included some Compviz updates. Before the updates I disabled the compiz because it was failed on my system.

  4. #4

    Default Re: KDE 4.2.3 latest DUP result strange error while loging i

    I also tried to remove all compiz components at failsafe console, but didn't work.

    Isn't it a good method to use "zypper dup", cause it sometimes results this kind of problems for me. I think I should just use "zypper up".

    For this type of login problems, is there a way to recover to a stable state like Windows does?

  5. #5
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: KDE 4.2.3 latest DUP result strange error while loging i

    "zypper dup" is generally bad with the current version of KDE. There are too many badly connected dependencies. You should have done only "zypper up".

    You may log in with out GUI (just type 3 when the boot menu comes up and press Enter) and try to delete the .kde4 directory. Warnings: This will delete your earlier desktop settings, mail settings etc.
    Code:
    rm -fr .kde4
    At this point, you can do "zypper" commands if you want to remove anything further.
    After that, reboot.
    Code:
    su
    poweroff
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •