Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Java-1_6_0 u13 + Firefox + chat room problem

  1. #1
    Join Date
    Jun 2008
    Location
    Glasgow, Scotland
    Posts
    184

    Default Java-1_6_0 u13 + Firefox + chat room problem

    For quite some time now I've been unable to get one of my favourite chat rooms to load in Firefox. The strange thing is, this all works perfectly in Windows.

    The company who develops the chat software provided me with the following link to a demo chat room, to test the software and help them to find out what's causing the problem. So far, nothing I've tried seems to work.

    Here is the link:

    Chat Forum Pro Demo Forum 1

    I would very much appreciate it if someone could try to connect to the demo room and report back their findings.

    Stats:

    openSuSE 11.1 x86
    KDE 4.2.3
    Firefox 3.0.10
    Java-1_6_0 u13

  2. #2
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: Java-1_6_0 u13 + Firefox + chat room problem

    Quote Originally Posted by chyrania View Post
    For quite some time now I've been unable to get one of my favourite chat rooms to load in Firefox. The strange thing is, this all works perfectly in Windows.

    The company who develops the chat software provided me with the following link to a demo chat room, to test the software and help them to find out what's causing the problem. So far, nothing I've tried seems to work.

    Here is the link:

    Chat Forum Pro Demo Forum 1

    I would very much appreciate it if someone could try to connect to the demo room and report back their findings.

    Stats:

    openSuSE 11.1 x86
    KDE 4.2.3
    Firefox 3.0.10
    Java-1_6_0 u13
    This Java applet is loading fine for me. They say that no password needed so I typed something and clicked to the ENTER button. The applet is working and the progress bar stops at the Logging in status (maybe because there is no real authentication).
    Can you reach this state?
    Have you installed the java browser plugin for firefox?
    If not then type this in Konsole ( gnome-terminal in GNOME, terminal in XFCE):
    Code:
    sudo zypper in java-1_6_0-sun-plugin
    .
    Hope that helps.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  3. #3
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Java-1_6_0 u13 + Firefox + chat room problem

    You'll also need to create a symbolic link so that firefox can use java.

    It's explained here

    Installing 32-bit Java the Yast way - openSUSE Forums

    If you do the zypper part as ram88 has told you then you can just go directly to the part that says to create a symbolic link. Make sure your java is up to date too. It woulnd't hurt to go through the whole tutorial to make sure everything is installed correctly.

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  4. #4
    Join Date
    Jun 2008
    Location
    Glasgow, Scotland
    Posts
    184

    Default Re: Java-1_6_0 u13 + Firefox + chat room problem

    Quote Originally Posted by ram88 View Post
    This Java applet is loading fine for me. They say that no password needed so I typed something and clicked to the ENTER button. The applet is working and the progress bar stops at the Logging in status (maybe because there is no real authentication).
    Can you reach this state?
    Have you installed the java browser plugin for firefox?
    If not then type this in Konsole ( gnome-terminal in GNOME, terminal in XFCE):
    Code:
    sudo zypper in java-1_6_0-sun-plugin
    .
    Hope that helps.
    The progress bar stops at "logging in" for me, too. The question is, why doesn't java for Firefox Linux work the way it works in Windows?

    I verified my Java and it appears to be functioning correctly. I just don't know why it doesn't work for me with these chatrooms.

  5. #5
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: Java-1_6_0 u13 + Firefox + chat room problem

    Quote Originally Posted by chyrania View Post
    The progress bar stops at "logging in" for me, too. The question is, why doesn't java for Firefox Linux work the way it works in Windows?

    I verified my Java and it appears to be functioning correctly. I just don't know why it doesn't work for me with these chatrooms.
    So on Windows you can login in the demo chatroom too?
    I can imagine that the firewall is blocking some port what your chat program want to use.
    Why don't you install a Windows to VirtualBox and try to reach the chat from there. If it fails then it's caused by your firewall. If it's working then it's a platform compatibility problem what should be discussed with the chat room developers.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  6. #6
    Join Date
    Jun 2008
    Location
    Glasgow, Scotland
    Posts
    184

    Default Re: Java-1_6_0 u13 + Firefox + chat room problem

    Quote Originally Posted by ram88 View Post
    So on Windows you can login in the demo chatroom too?
    I can imagine that the firewall is blocking some port what your chat program want to use.
    Why don't you install a Windows to VirtualBox and try to reach the chat from there. If it fails then it's caused by your firewall. If it's working then it's a platform compatibility problem what should be discussed with the chat room developers.
    I installed xp in virtualbox and logged in to chat just fine. Interestingly, Ubuntu in VirtualBox can't connect to a chat room either.

    The openSuSE firewall doesn't appear to be responsible, as turning it off doesn't make any difference at all.

  7. #7

    Question Re: Java-1_6_0 u13 + Firefox + chat room problem

    I operate a similar Java-based chat room and have seen this problem before, so I thought I'd check this out on the OpenSUSE side. Virtually the same OpenSUSE configuration as chyrania. I hit the stonewall at "Connected/Logging In" with Firefox and Seamonkey. No such problems in daily use with my existing no-banners commercial-level chat room. So obvious Java and browser configuration issues probably aren't involved.

    Suspecting the Banner Ads, I tested turning off blocking in both browsers completely, to no avail. For comparison, I use my existing vendor's demo site Java Chat Software - AddonChat Live Demo and jump right into a demo chat room.

    I added their free chat to my own website. Access failed in a similar manner using the administrator's passworded account.

    I am doubtful that client-side Java or browser/Firefox issues are the problem. That Windows works, and Linux doesn't is important. The fact that the chat-forums stuff doesn't work, but the addonchat does, suggests some Linux-specific configuration issue, maybe on the vendor side.

    If you already have an operational chat-forum site with Linux-access, we can try to log in. That would be useful to eliminate their demo room as the problem.

    More later after I tinker some more.

  8. #8

    Default Re: Java-1_6_0 u13 + Firefox + chat room problem

    Update ===>

    Further testing of OpenSUSE Linux access at ChatShack.net has shown the same roadblock at the point of " Connected: Logging In" to exist in the Gold version and the Full version. So it is some across-the-board issue.

    Ubuntu was mentioned as also having problems. Is this a general Linux issue ?

  9. #9
    Join Date
    Jun 2008
    Location
    Glasgow, Scotland
    Posts
    184

    Default Re: Java-1_6_0 u13 + Firefox + chat room problem

    Quote Originally Posted by durgin View Post
    Update ===>

    Further testing of OpenSUSE Linux access at ChatShack.net has shown the same roadblock at the point of " Connected: Logging In" to exist in the Gold version and the Full version. So it is some across-the-board issue.

    Ubuntu was mentioned as also having problems. Is this a general Linux issue ?

    We would have to do extensive testing or invite input from the wider community to find that out if the problem affects other distributions. That said, I can tell you I experienced the same problem when I attempted connection using Ubuntu in a virtual machine.

  10. #10
    Join Date
    Jun 2008
    Location
    Glasgow, Scotland
    Posts
    184

    Default Re: Java-1_6_0 u13 + Firefox + chat room problem

    The chat software developers got back to me today and suggested the following course of action, which hasn't made the slightest bit of difference. Maybe some else will have better luck:

    Hi,

    I have been asked to ask you the following questions..

    1) Do you have support for .au files, these are standard format for sound
    files in java applets but require local system support for the file type to
    function.

    2) What happens when selecting the following link
    http://pro.chat-forum.com/pro4/pro4demo1/snd2.au

    3) Can you load the demo chat room but prior to entering your username can
    you select the options tab and check the "disable all sounds", then enter
    the forum.

    Best regards

    Sue
    Chat-Forum.Com Support
    ASCII Software Ltd

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •