Results 1 to 4 of 4

Thread: Update System gives error "Failed to update package lists"

  1. #1
    sparke16 NNTP User

    Default Update System gives error "Failed to update package lists"

    I used to be able to run the system updates but I haven't been able to in awhile. I'm running 11.1 on VMWorkstation. Here's the specific error:

    failed to get a TID: Rejected send message, 1 matched rules; type="method_call", sender=":1.100" (uid=1000 pid=25160 comm="gpk-update-viewer ") interface="org.freedesktop.PackageKit.Transaction" member="SetLocale" error name="(unset)" requested_reply=0 destination="org.freedesktop.PackageKit" (uid=0 pid=25712 comm="/usr/sbin/packagekitd ")) (0)

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Update System gives error "Failed to update package list

    Boot to CLI level3 by pausing the boot, selecting default boot, then backspace out all the boot arguments and just type the number: 3 (hit enter)

    at the login prompt, login with your username and password
    now type: su (enter)
    now enter your root password.......

    Now type:

    Code:
    zypper ref
    wait for it to refresh all the repos

    now type
    Code:
    zypper up
    (this should update the system)

    reboot to reboot
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    sparke16 NNTP User

    Default Re: Update System gives error "Failed to update package list

    Hmm, I may need your statement broken down to a bit of layman's terms

    I'm studying unix and linux books right now i'm just not well versed enough to fully understand what I need to do

    enter the command line, then gain super user privileges, then enter those commands or do I need to hit cntrl+1 to get to another screen or do I need to do something when loading linux to prevent it from loading?

    Thanks,
    Stu

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Update System gives error "Failed to update package list

    From the grub boot screen, edit the kernel arguments out and just type the number: 3

    follow my earlier advice
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •