Results 1 to 9 of 9

Thread: Virtualbox 2.2.2 USB devices grayed out

  1. #1

    Default Virtualbox 2.2.2 USB devices grayed out

    Hi. I've got opensuse 11.1 with KDE 4.2.3 and VirtualBox 2.2.2 (non-ose of course)

    I followed this thread:

    Virtual Box USB tips - openSUSE Forums

    With one exception. The GID of vboxusers was 113, not 112 (checked it in some system file)

    I've got one question about that thread, there is something like this:
    Code:
    and add following line to /etc/init.d/boot.local
    mount -a Reboot.
    So I should add "mount -a" to "/etc/init.d/boot.local" right?

    I did so and rebooted. I enabled USB devices i VirtualBox and I have Guest Additions installed (seamless mode with no problem), but my USB devices are all grayed out. I tried setting the USB filter in Guest options to all deivces, but still no luck.


    Any ideas?

  2. #2
    Join Date
    Jun 2008
    Location
    Moses Lake, WA. USA
    Posts
    474

    Default Re: Virtualbox 2.2.2 USB devices grayed out

    warnec wrote:

    >
    > Hi. I've got opensuse 11.1 with KDE 4.2.3 and VirtualBox 2.2.2 (non-ose
    > of course)
    >
    > I followed this thread:
    >
    > 'Virtual Box USB tips - openSUSE Forums' (http://tinyurl.com/d9cjhp)
    >
    > With one exception. The GID of vboxusers was 113, not 112 (checked it
    > in some system file)
    >
    > I've got one question about that thread, there is something like this:
    >
    > Code:
    > --------------------
    >
    > and add following line to /etc/init.d/boot.local
    > mount -a Reboot.
    >
    > --------------------
    >
    >
    > So I should add "mount -a" to "/etc/init.d/boot.local" right?
    >
    > I did so and rebooted. I enabled USB devices i VirtualBox and I have
    > Guest Additions installed (seamless mode with no problem), but my USB
    > devices are all grayed out. I tried setting the USB filter in Guest
    > options to all deivces, but still no luck.
    >
    >
    > Any ideas?
    >

    Take a look at this thread of forum:
    http://forums.opensuse.org/applicati...-usb-grey.html

    Solution four works good unless you are running Iscan and virtualbox. I
    found that they don't play well together, One needs rule 50-udev-
    default.rules
    # libusb device nodes
    #SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device",
    NAME="bus/usb/$env{BUSNUM}/$env{DEVNUM}", MODE="0664"

    enabled, other wants it disabled.

    I'm stll looking for final solution.

    --
    Russ
    openSUSE 11.1 (2.6.27.21-0.1-default [x86_64) KDE 4.2 release 106, Intel
    DX48BT2 Core 2 Dual E7200. 4 GB DDR III GeForce 8400 GS, 320GB Disc (2)



  3. #3
    Join Date
    Jun 2008
    Location
    Inzago, Italy
    Posts
    108

    Default Re: Virtualbox 2.2.2 USB devices grayed out

    For me this discussion VirtualBox USB grey - Page 2 - openSUSE Forums gave the right solution.
    OpenSuse 13.1 with KDE 4.11 on Intel I7 930 motherboard Asus P6T SE - RAM 6 Gb
    - video card NVIDIA GT220 1GB - TV card Hauppauge WinTV Nova T stick

  4. #4

    Default Re: Virtualbox 2.2.2 USB devices grayed out

    Erm.. I tried the solution of renaming the 'xx-vboxdrv.rules' file, and it didn't help.

    And about the 12-page thread - I don't really where I should look, the user with Popeye in his avatar (I didn't remember your name sorry !) made a lot of tests and different settings, I don't really know what I should do to get it working.

  5. #5
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Virtualbox 2.2.2 USB devices grayed out

    @warnec
    For Solution #4 you need to look at Page 8 about 4th post down by me. Make sure you read all of that post before you start. You will have to undo some of your previous mods first, such as renaming back to 10-vboxdrv.rules if you haven't already. If you not sure of anything there, post back here with a question. Let us know how it goes, and also what devices you are trying to enable.

  6. #6

    Default Re: Virtualbox 2.2.2 USB devices grayed out

    It helped! Thanks a lot All my devices are now 'tickable'

  7. #7
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Virtualbox 2.2.2 USB devices grayed out

    @warnec
    You're very welcome. Glad it worked, and thanks to @upscope (popeye) for the vote of confidence and persevering with all the tests.

    You should bear in mind that this workaround is for 11.1. Keep an eye out for any official openSUSE updates involving the original 50- default rules file in lib/udev/rules.d, and bear in mind that change will come with 11.2 ...

  8. #8
    Join Date
    Jun 2008
    Location
    Moses Lake, WA. USA
    Posts
    474

    Default Re: Virtualbox 2.2.2 USB devices grayed out

    consused wrote:

    >
    > @warnec
    > For Solution #4 you need to look at Page 8 about 4th post down by me.
    > Make sure you read all of that post before you start. You will have to
    > undo some of your previous mods first, such as renaming back to
    > 10-vboxdrv.rules if you haven't already. If you not sure of anything
    > there, post back here with a question. Let us know how it goes, and also
    > what devices you are trying to enable.
    >
    >

    Just fixed my USB - Iscan problems. I installed VirtualBox 2.2.4 (on
    openSuSE 11.1) and now I can run with rule 50-udev-default.rules (usb part
    enabled) and see all my usb devices in guest XP and when I shutdown vbox
    (since it captures the Epson CX6600 scanner), Iscan works fine. It appears
    the problem may have been related to the udev fixes that were made to
    VirtualBox ?

    Will try same on milestone 2 later today. Will post results.
    --
    Russ
    openSUSE 11.1 (2.6.27.21-0.1-default [x86_64) KDE 4.2.3 release 1, Intel
    DX48BT2 Core 2 Dual E7200. 4 GB DDR III GeForce 8400 GS, 320GB Disc (2)



  9. #9
    Join Date
    Jun 2008
    Location
    Moses Lake, WA. USA
    Posts
    474

    Default Re: Virtualbox 2.2.2 USB devices grayed out

    consused wrote:

    >
    > @warnec
    > For Solution #4 you need to look at Page 8 about 4th post down by me.
    > Make sure you read all of that post before you start. You will have to
    > undo some of your previous mods first, such as renaming back to
    > 10-vboxdrv.rules if you haven't already. If you not sure of anything
    > there, post back here with a question. Let us know how it goes, and also
    > what devices you are trying to enable.
    >
    >

    Iscan - VirtualBox conflict on openSuSe 11.1 appears solved by installing
    VirtualBox 2.2.4. I now have the USB section of rule /etc/udev/rules.d/50-
    udev-default.rules enabled (no # sign). Iscan works fine, starting
    VirtualBox all usb devices come up (none greyed out). Iscan will not work
    with Virtual box running but I assume its because Vbox captures the CX6600
    (all-in-one [scanner].

    Thanks for your help on this.

    I will test openSuSe 11.2 with VirtualBox 11.2 milestone 2 later today.


    --
    Russ
    openSUSE 11.1 (2.6.27.21-0.1-default [x86_64) KDE 4.2.3 release 1, Intel
    DX48BT2 Core 2 Dual E7200. 4 GB DDR III GeForce 8400 GS, 320GB Disc (2)



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •