Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Xorg + Plasma high CPU usage.

  1. #1

    Default Xorg + Plasma high CPU usage.

    I am having an issue with KDE4 where Xorg and Plasma are both eating up the CPU. They are both together eating up average 40-50%, so combine my CPU is maxed out. I have no clue to why or what occured to have caused this as there have been no changes to the system the past few days prior. This issue is isolated to just my one account. If I log into another account it runs fine.This is isolated just to my account under KDE, Gnome runs fine.

    So I imagine there must be some file or config screwed up or missing in my profile folder. Where should I begin to look?

    Log files by the way show nothing of interest, or out of the ordinary I should say.

  2. #2
    Join Date
    Sep 2008
    Location
    Earl Shilton UK
    Posts
    298

    Default Re: Xorg + Plasma high CPU usage.

    Things I'd have a look at are:

    Plasmoids. Are you running any, some of them have 'issues'. I believe YaWP (yet another weather plasmoid) did this. Try removing them & see what happens to cpu usage. The bubble monitor plasmoids were a bit hungry (for me anyway) as well.

    vsync for desktop effects. For some reason this got turned on for me (don't know how or why really). It's in the advanced tab where you configure the desktop effects. Turning this option OFF took my cpu usage from ~50% to ~7% (plasma & xorg were eating a whole core!)

    HTH
    Happily using Linux since 1998
    Share & Enjoy

  3. #3

    Default Re: Xorg + Plasma high CPU usage.

    I am seeing high CPU usage (99%) after the machine is brought back from being locked overnight.. I am only running one plasmoid - stdin, which isnt set to update update. It only runs once and stays static. For some reason if I lock my screen and unlock it the next day, I will see the cpu at 99% for plasma-desktop. I can logout and back in and it will be back to the 20-30% range..

    OS: Linux 2.6.27.23-0.1-pae i686
    Current user: monty@groucho
    System: openSUSE 11.1 (i586)
    KDE: 4.2.90 (KDE 4.2.90 (KDE 4.3 Beta2)) "release 138"

  4. #4

    Default Re: Xorg + Plasma high CPU usage.

    Quote Originally Posted by weighty_foe View Post
    Things I'd have a look at are:

    Plasmoids. Are you running any, some of them have 'issues'. I believe YaWP (yet another weather plasmoid) did this. Try removing them & see what happens to cpu usage. The bubble monitor plasmoids were a bit hungry (for me anyway) as well.

    vsync for desktop effects. For some reason this got turned on for me (don't know how or why really). It's in the advanced tab where you configure the desktop effects. Turning this option OFF took my cpu usage from ~50% to ~7% (plasma & xorg were eating a whole core!)

    HTH
    You nailed the issue.. I have been noticing some issues (plasma desktop crashing overnight).. it was determined to be the stdin plasmoid.. I had been running two instances of the plasmoid - one that ran a command and updated every 30 seconds.. the other one just ran once and never updated again.. The overnight crashes were determined to be the stdin plasmoid.. I removed the updating instance, but left the static instance.. I havent had the crashes anymore.. but occasionally I have seen the high cpu issue reported here.. I closed the one remaining stding plasmoid instance and voila! the cpu usage came down to normal..

    I hope this info helps anyone else seeing high cpu usage from plasma-desktop

  5. #5

    Default Re: Xorg + Plasma high CPU usage.

    I don't mean to bump this, but this thread is the first google result for "plasma-desktop xorg cpu"

    I found in debian sid that just having big scaled shortcut icons on your plasma desktop can chew up 100% of a core. Remove those plasmoids and it drops back to 0-1%

    again sorry for bumping

  6. #6
    ende NNTP User

    Default Re: Xorg + Plasma high CPU usage.

    Hello,

    I have the same problem. Plasma-desktop takes almost 60 % and Xorg takes almost 50 % (because I have core2duo). I have removed all plasmoids and nothing has happened. Please where is the problem?

    Thank you for your hints.

    Xorg.log.* are fine, no errors, just missing some fonts. After I log out of system every think turn to be allright.

  7. #7

    Default Re: Xorg + Plasma high CPU usage.

    This thread is even the first google result for "plasma-desktop cpu" :-)
    For me the high CPU usage disappeared, after I changed in my "Desktop Settings" under "Activity" from "Type: Folder View" to "Type: Desktop" and back.

  8. #8
    Join Date
    Jun 2008
    Location
    Harare Zimbabwe
    Posts
    104

    Default Re: Xorg + Plasma high CPU usage.

    have been having this issue, but notice it is made worst when i run the spideroak backup program, as soon as i exit this, then cpu usage goes from 45-50% down to 1-2%, anyone else that has spideroak have this problem?
    Freedom is power, all i have to do is know how to use it.

  9. #9
    Join Date
    Nov 2010
    Location
    BEIJING,CHINA; SHANGHAI,CHINA
    Posts
    664

    Default Re: Xorg + Plasma high CPU usage.

    maybe nepomuk and strigi. try disable desktop index or endure the lag for a full indexing. then it'll rarely lag.
    Last edited by MargueriteSu; 02-Mar-2012 at 17:49.

  10. #10

    Default Re: Xorg + Plasma high CPU usage.

    If you found out which plasmoid is buggy you should report it at bugs.kde.org in order to get it fixed.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •