Results 1 to 6 of 6

Thread: Eclipse launch...

Hybrid View

  1. #1
    chussenot NNTP User

    Red face Eclipse launch...

    Hi !!

    when i run eclipse i've got error with my user...
    but it's work with superuser...

    i need to edit java.policy ? other file ?



    !SESSION 2009-05-25 18:27:48.556 -----------------------------------------------
    eclipse.buildId=I20080617-2000
    java.version=1.6.0_0
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=fr_FR
    Framework arguments: -vm /usr/lib/jvm/java/bin/java
    Command-line arguments: -os linux -ws gtk -arch x86 -vm /usr/lib/jvm/java/bin/java

    !ENTRY org.eclipse.core.runtime 4 0 2009-05-25 18:27:51.487
    !MESSAGE
    !STACK 0
    org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.core.jobs; bundle-version="[3.2.0,4.0.0)"
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:305)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:355)
    at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1074)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:616)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:508)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:299)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:489)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:211)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:321)

    !ENTRY org.eclipse.osgi 4 0 2009-05-25 18:27:51.494
    !MESSAGE Bundle initial@reference:file<img src="imag....v20080512.jar/ was not resolved.

    !ENTRY org.eclipse.osgi 4 0 2009-05-25 18:27:51.500
    !MESSAGE Application error
    !STACK 1
    java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:74)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:382)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:616)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1236)

    !ENTRY org.eclipse.osgi 2 0 2009-05-25 18:27:51.513
    !MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
    !SUBENTRY 1 org.eclipse.osgi 2 0 2009-05-25 18:27:51.513
    !MESSAGE Bundle initial@reference:file<img src="imag....v20080512.jar/ [3] was not resolved.
    !SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-05-25 18:27:51.513
    !MESSAGE Missing imported package org.eclipse.core.internal.runtime.auth_0.0.0.

  2. #2

    Default Re: Eclipse launch...

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Has this always happened? Where did you get Eclipse and how did you
    install it? Is it just your user or all users on the system (create a new
    one to test, for example)? Did you verify the download's hash to ensure a
    proper download if you downloaded and installed manually? Which version
    of Linux?

    Good luck.





    chussenot wrote:
    > Hi !!
    >
    > when i run eclipse i've got error with my user...
    > but it's work with superuser...
    >
    > i need to edit java.policy ? other file ?
    >
    >
    >
    > !SESSION 2009-05-25 18:27:48.556
    > -----------------------------------------------
    > eclipse.buildId=I20080617-2000
    > java.version=1.6.0_0
    > java.vendor=Sun Microsystems Inc.
    > BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=fr_FR
    > Framework arguments: -vm /usr/lib/jvm/java/bin/java
    > Command-line arguments: -os linux -ws gtk -arch x86 -vm
    > /usr/lib/jvm/java/bin/java
    >
    > !ENTRY org.eclipse.core.runtime 4 0 2009-05-25 18:27:51.487
    > !MESSAGE
    > !STACK 0
    > org.osgi.framework.BundleException: The bundle could not be resolved.
    > Reason: Missing Constraint: Require-Bundle: org.eclipse.core.jobs;
    > bundle-version="[3.2.0,4.0.0)"
    > at
    > org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:305)
    > at
    > org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:355)
    > at
    > org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1074)
    > at
    > org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:616)
    > at
    > org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:508)
    > at
    > org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:299)
    > at
    > org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:489)
    > at
    > org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:211)
    > at
    > org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:321)
    >
    > !ENTRY org.eclipse.osgi 4 0 2009-05-25 18:27:51.494
    > !MESSAGE Bundle
    > initial@reference:file<img src="imag....v20080512.jar/
    > was not resolved.
    >
    > !ENTRY org.eclipse.osgi 4 0 2009-05-25 18:27:51.500
    > !MESSAGE Application error
    > !STACK 1
    > java.lang.IllegalStateException: Unable to acquire application service.
    > Ensure that the org.eclipse.core.runtime bundle is resolved and started
    > (see config.ini).
    > at
    > org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:74)
    > at
    > org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:382)
    > at
    > org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    > at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    > at
    > sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    > at
    > sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    > at java.lang.reflect.Method.invoke(Method.java:616)
    > at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
    > at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
    > at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
    >
    > !ENTRY org.eclipse.osgi 2 0 2009-05-25 18:27:51.513
    > !MESSAGE The following is a complete list of bundles which are not
    > resolved, see the prior log entry for the root cause if it exists:
    > !SUBENTRY 1 org.eclipse.osgi 2 0 2009-05-25 18:27:51.513
    > !MESSAGE Bundle
    > initial@reference:file<img src="imag....v20080512.jar/
    > [3] was not resolved.
    > !SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-05-25 18:27:51.513
    > !MESSAGE Missing imported package
    > org.eclipse.core.internal.runtime.auth_0.0.0.
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.9 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iQIcBAEBAgAGBQJKGtitAAoJEF+XTK08PnB5xvEP/j0u/Qx1OxgV8QbOG49z+vHY
    fWkXsX2297gYunCJxffpkl3wulFpThRRaJCjR1p13S+uwlnC6hr6WiwhVz4NrjJ9
    D2w+llm0rtA3LJ1ZfMbgvDeAwv9apASCHivJErd2Lks9HTCdngkbynR3FqUva4u3
    BFLn61IPrwDxm8ZaAFdJrmyULXpU9PkS+X9dx3xAGSPgXHnwG1/KmTCkcSkmwRnI
    fIziiXQdNOx2LPah38+ZV+6I1D2zysrUwYbinhLiuDsGCGacvQ5TqKeJoqAiLWfM
    bbZ9PzloiqXE737Rd10d/AU+Z8F4ceJgYalrAU61XTwjkP+gqv6yBSCR53pCa9ig
    /dTGA2iICcu601tj+V4nmJn1xXZsTvZ5d2KBeiflYsSmvUXYoOlpYhMmVpQ9nB+4
    zslhB4w/uCeH1hVjMx438Oinx3uzoB0h0e1rLun7zPq2mNOSzXwIrurBpo6V+uW1
    HNVIPlLdhCxoJUi6O8zAMsNI4KJM1AtEhefDYvX7eWIfbq0vviziUaGd/MXM8RNb
    wqX2nq3iWhlSc6vvB0a5bkz7z8+PIJ/1AtENE61eprT1a7zb8p0x+BlALXoIYSgA
    KzfLSE4/Lmx8Y7AHYL02i1bUjtDpkACqxsuyAXZIdOnIeVRIs2Lm7R01iN5R1/RW
    /4h9OcCbzD8uVJxppGvX
    =GVJY
    -----END PGP SIGNATURE-----

  3. #3
    chussenot NNTP User

    Default Re: Eclipse launch...

    i use Opensuse 11.1
    i've only one user...

    this error happen just after i try to install eclipse plugin (classic site procedure)

    please read this...
    Installing Aptana Studio on Linux - Aptana

    i need to change /usr/lib/eclipse with root right ?
    do you know how to make it ?


    i need to change jre ?
    i've got install java-1.6.0

    lrwxrwxrwx 1 root root 26 avril 9 10:06 java -> /etc/alternatives/java_sdk
    drwxr-xr-x 3 root root 4096 avril 1 21:14 java-1.5.0-gcj-4.3-1.5.0.0
    lrwxrwxrwx 1 root root 32 avril 9 10:06 java-1.6.0 -> /etc/alternatives/java_sdk_1.6.0
    drwxr-xr-x 3 root root 4096 avril 1 21:13 java-1.6.0-openjdk-1.2_b11
    lrwxrwxrwx 1 root root 20 avril 9 10:06 java-1.6.0-sun -> java-1.6.0-sun-1.6.0
    drwxr-xr-x 6 root root 4096 avril 9 10:06 java-1.6.0-sun-1.6.0
    lrwxrwxrwx 1 root root 30 avril 9 10:06 java-sun -> /etc/alternatives/java_sdk_sun
    lrwxrwxrwx 1 root root 21 avril 1 21:13 jre -> /etc/alternatives/jre
    lrwxrwxrwx 1 root root 27 avril 1 21:14 jre-1.5.0 -> /etc/alternatives/jre_1.5.0
    lrwxrwxrwx 1 root root 30 avril 1 21:14 jre-1.5.0-gcj -> java-1.5.0-gcj-4.3-1.5.0.0/jre
    lrwxrwxrwx 1 root root 27 avril 1 21:13 jre-1.6.0 -> /etc/alternatives/jre_1.6.0
    lrwxrwxrwx 1 root root 30 avril 1 21:13 jre-1.6.0-openjdk -> java-1.6.0-openjdk-1.2_b11/jre
    lrwxrwxrwx 1 root root 24 avril 9 10:06 jre-1.6.0-sun -> java-1.6.0-sun-1.6.0/jre
    lrwxrwxrwx 1 root root 25 avril 1 21:14 jre-gcj -> /etc/alternatives/jre_gcj
    lrwxrwxrwx 1 root root 29 avril 1 21:13 jre-openjdk -> /etc/alternatives/jre_openjdk
    lrwxrwxrwx 1 root root 25 avril 9 10:06 jre-sun -> /etc/alternatives/jre_sun

  4. #4

    Default Re: Eclipse launch...

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    My Eclipse install isn't a system-wide installation so I guess I can't
    help much there. I downloaded Ganymede and extracted it just for my user,
    and I believe I'm using a 1.6 JRE (not 1.7). Maybe that will help a
    little. Also to install Apatana in my install I just added it an Aptana
    source in Eclipse and it installed nicely and I even get updates. Perhaps
    you did the same and if so it should work. In the meantime try creating a
    new test user and see if Eclipse still starts for it. If it does then try
    finding which files were modified by adding Aptana and see if it can be
    undone. Reinstalling Eclipse may also be an option in case something that
    changed cause the problems.

    Good luck.





    chussenot wrote:
    > i use Opensuse 11.1
    > i've only one user...
    >
    > this error happen just after i try to install eclipse plugin (classic
    > site procedure)
    >
    > please read this...
    > 'Installing Aptana Studio on Linux - Aptana'
    > (http://www.aptana.com/docs/index.php...ptana_on_Linux)
    >
    > i need to change /usr/lib/eclipse with root right ?
    > do you know how to make it ?
    >
    >
    > i need to change jre ?
    > i've got install java-1.6.0
    >
    > lrwxrwxrwx 1 root root 26 avril 9 10:06 java ->
    > /etc/alternatives/java_sdk
    > drwxr-xr-x 3 root root 4096 avril 1 21:14 java-1.5.0-gcj-4.3-1.5.0.0
    > lrwxrwxrwx 1 root root 32 avril 9 10:06 java-1.6.0 ->
    > /etc/alternatives/java_sdk_1.6.0
    > drwxr-xr-x 3 root root 4096 avril 1 21:13 java-1.6.0-openjdk-1.2_b11
    > lrwxrwxrwx 1 root root 20 avril 9 10:06 java-1.6.0-sun ->
    > java-1.6.0-sun-1.6.0
    > drwxr-xr-x 6 root root 4096 avril 9 10:06 java-1.6.0-sun-1.6.0
    > lrwxrwxrwx 1 root root 30 avril 9 10:06 java-sun ->
    > /etc/alternatives/java_sdk_sun
    > lrwxrwxrwx 1 root root 21 avril 1 21:13 jre ->
    > /etc/alternatives/jre
    > lrwxrwxrwx 1 root root 27 avril 1 21:14 jre-1.5.0 ->
    > /etc/alternatives/jre_1.5.0
    > lrwxrwxrwx 1 root root 30 avril 1 21:14 jre-1.5.0-gcj ->
    > java-1.5.0-gcj-4.3-1.5.0.0/jre
    > lrwxrwxrwx 1 root root 27 avril 1 21:13 jre-1.6.0 ->
    > /etc/alternatives/jre_1.6.0
    > lrwxrwxrwx 1 root root 30 avril 1 21:13 jre-1.6.0-openjdk ->
    > java-1.6.0-openjdk-1.2_b11/jre
    > lrwxrwxrwx 1 root root 24 avril 9 10:06 jre-1.6.0-sun ->
    > java-1.6.0-sun-1.6.0/jre
    > lrwxrwxrwx 1 root root 25 avril 1 21:14 jre-gcj ->
    > /etc/alternatives/jre_gcj
    > lrwxrwxrwx 1 root root 29 avril 1 21:13 jre-openjdk ->
    > /etc/alternatives/jre_openjdk
    > lrwxrwxrwx 1 root root 25 avril 9 10:06 jre-sun ->
    > /etc/alternatives/jre_sun
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.9 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iQIcBAEBAgAGBQJKG0lCAAoJEF+XTK08PnB5DTMP/2xQJJFO7fH/qLSIpleOAavv
    et0xNPGGvE8kQ3YTlYV9ee0YxOfBzllKsW//T9g6y2RNnIh/B+PdSSiT5ZSTMpCg
    gscfKJmQ8HX3oO5CjMexFWx0I6PgKrfLh642sVwEbDyCo9A18iF+iBs/ese3bL6k
    7UJVl+9LMzxthNU2FGqtI+9Xd4z3aJUgCMBVUMRlLXOK6RNSR6LCVyQJGKUtdVvY
    qxGa5XBR422P1H4IXydTrJHQBrN/y/b6SsTkq5D2cs6wq8xRf7fRiMfSJUyWpMV9
    fXr2NS6n/4VvePtoZaxxRBEGMHTEls3K9D6y+ZxMHnH8DJXwKH7RggZS5UIJaPDG
    G/BFqKVGpnHXrMEeoRr6jyP1cmhsGtkxBZw/DbudijopBXN5VWS8KucfpddpWkbR
    xVzdtJzFu7SpkTq34YAdTObL9+qvMuVK+3SnB1WhqlmwAEbow1GBnzJadh1aiVkT
    sfSsX8gJ/qlVgEi+MwsxyK+pC0RbBojB4PQjaRfjA/mttsa2VaRPEKVEeCdydSzn
    /dmAqLOHeXaupw9DNQVEOfapw4P0ZCuW+fu8Vqv4GBOJzgZTvvqTCsuFB8T/a/O6
    ap9+B9rGV8qX7XOmuOQTNiWc+qtqUvMezwWE6ggJHv4BWCg5APTWiQh+GheOcE1a
    Ht1Q3OSSpLE502mi1nAW
    =yWsU
    -----END PGP SIGNATURE-----

  5. #5
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: Eclipse launch...

    I suggest you to install eclipse manually to avoid any further error around plugins and permissions.
    Reinstalling it from YaST doesn't solve your problem.
    Good luck.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  6. #6
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: Eclipse launch...

    Actually, I would recommend that you uninstall eclipse, then go to eclipse website, download desired version, unpack, and run.
    No installation needed, and as in my case, proved to run much better then installed one.
    Emil Beli
    http://www.beli.ws/blog/
    openSUSE 11.4 x64 KDE, ATI 5600, i7 dell inspire laptop

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •