I'm running OpenSuSE 11.1 64-bit with all patches applied as of yesterday. I know it is all there, because I deliberately applied all patches before getting ready to perform a full image backup. That's when I found Dolphin has a critical failure.

My USB drive needed to have some old backup images deleted from it before I started another backup, just to be safe. I started nuking them via Dolphin...then realized Dolphin doesn't have an option to nuke without moving to trash. Once the process of moving multiple 4Gig files to trash starts, you are pretty much screwed. I decide to pass the time reading and responding to email in KMail.

The USB drive decided to have a communications hiccup during the move to trash. Dolphin hung the entire system. No problem, I thought, I'll just reboot.

Should have been warned about thinking I guess.

/home wouldn't pass boot fsck. To add insult to injury, I need the emails from this week and this is a Terabyte drive.

I tried booting via the original installation DVD to run FSCK manually as instructed. Lots of trials and failures. Now the / partition can't complete booting. I have even tried SystemRescueCD, but it doesn't play well with whatever OpenSuSE does to partitions.

Any attempt to run fsck on the /home partition just dies. When I use -C -V -y I see it get to 20.8% and just hang. Hard hang. Reset button time.

I am somewhat at my whits end. I seriously need the new emails from the last time I backup up last month. (I normally perform a full image backup each month.) I'm making one last ditch effort using Partition Commander to slide the troubled partitions to their smallest possible size to see if I can get the installation DVD to fix everything at that point.

This entire problem was caused because Dolphin didn't have an option to nuke without moving to trash. It also doesn't have any kind of recovery process built into it for when removable devices decided to disconnect themselves. We used to have this problem constantly with SCSI devices when cables were getting flaky...Why isn't Dolphin handling this situation???

Anyway, if the powers that be here have additional thoughts on getting my system booting again AND salvaging its current / and /home partitions...I'm listening.