Results 1 to 7 of 7

Thread: Kaffeine wont play divx and .avi

  1. #1

    Default Kaffeine wont play divx and .avi

    Does anyone know what I need in order to play divx and .avi with Kaffeine?
    They open with a blank screen and it seems to rush through them.
    DO I need to download something else in order to play them?

    Thanks!

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: Kaffeine wont play divx and .avi

    Quote Originally Posted by megasalex View Post
    Does anyone know what I need in order to play divx and .avi with Kaffeine?
    They open with a blank screen and it seems to rush through them.
    DO I need to download something else in order to play them?
    Please take a read of this post:
    openSUSE Forums - View Single Post - sound problems on Gateway M-6874h
    Note you must add 4 and only 4 repos: OSS, Non-OSS, Update and Packman. READ that URL (please).

    The latest Kaffeine supports both gstreamer sound engine and the xine sound engine. I recommend you use the xine sound engine. The xine engine packaged by Novell/SuSE-GmbH is in essence crippled for divx, so you need to replace it by the xine engine packaged by Packman.

    If you are running openSUSE-11.1 its easy, after setting up the 4 repos I mentioned in the quoted link, then simply replace the Novell/SuSE-GmbH packaged libxine1 and kaffeine by the Packman packaged libxine1 and kaffeine. You can tell the Packman packaged versions by the "pm" in the file name. Also install the Packman packaged libffmpeg0 and w32codec-all, as they (or their dependencies) provide lots of codecs.

    Note avi is a wrapper, and not a codec. Hence saying you can't play avi is rather a broad statement. Stating you can not play divx is more specific.

    Note if you are running SuSE-11.0 or earlier, then the xine package packaged by Novell/SuSE-GmbH is called "xine-lib" instead of "libxine1". So in that case, after setting up the 4 repos (per my recommendation in the URL I provided above) you need to go to YaST > Software > Software management and mark xine-lib for removal. Don't try to remove it yet. Then mark the packman packaged libxine1 for installation. Then apply BOTH at the same time. That will sort the dependency issues you may get. After the Packman packaged libxine1 is installed, go ahead and install the Packman packaged kaffeine, libffmpeg0, and w32codec-all. Again you can tell the Packman packaged versions by the "pm" in the file name.

    Note if you added videolan as a repository, there is an unfortunately probability it will mess up all the above that I typed.

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Kaffeine wont play divx and .avi

    Quote Originally Posted by megasalex View Post
    Does anyone know what I need in order to play divx and .avi with Kaffeine?
    They open with a blank screen and it seems to rush through them.
    DO I need to download something else in order to play them?

    Thanks!
    Multi-media and Restricted Format Installation Guide - openSUSE Forums
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: Kaffeine wont play divx and .avi

    Ty!

    I tried it (on OS 11.3), but trying to install libxine1, it comes up with an error that it requires another version of libxine1...

    P.S.
    never added videoloan as a repo

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Kaffeine wont play divx and .avi

    Quote Originally Posted by megasalex View Post
    Ty!

    I tried it (on OS 11.3), but trying to install libxine1, it comes up with an error that it requires another version of libxine1...
    11.3?

    You probably have to allow vendor change of libxine1 to Packman
    Follow the Guide

    key points: Disable Videolan repo and update all unconditionally in Packman
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: Kaffeine wont play divx and .avi

    sorry, brain fart. I meant 11.1

    I guess I need to figure out how to replace the ones inside with the pacman ones.

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: Kaffeine wont play divx and .avi

    In 11.1 its a simple matter of replacing libxine1 with libxine1 from Packman.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •