Results 1 to 6 of 6

Thread: Adobe Air applications and sound don't mix?

  1. #1

    Default Adobe Air applications and sound don't mix?

    Hi.

    I've tried a couple of Adobe Air applications (adobeair1.0-1.5.1-8210) and whenever one of them plays a sound for the first time, I get a nasty screech through the speakers for half a second, followed by the sound that you were suppose to hear.

    After that, the sound system appears to be locked up (i.e., other applications such as Amarok cannot play) until the Air application is closed.

    Running KDE 3.5.10.

    Any ideas?

    E.

  2. #2
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: Adobe Air applications and sound don't mix?

    Well, runs fine.. Once a friend had same trouble, but somehow, his suse was using OSS and not ALSA driver.
    Just an idea.
    Emil Beli
    http://www.beli.ws/blog/
    openSUSE 11.4 x64 KDE, ATI 5600, i7 dell inspire laptop

  3. #3

    Default Re: Adobe Air applications and sound don't mix?

    Definitely using ALSA. I did notice this morning that if I run the Air app from a terminal prompt, I get the following sound related output:

    Code:
    Server Name: pulseaudio
    Server Version: 0.9.12
    Default Sample Specification: s16le 2ch 44100Hz
    Default Sink: alsa_output.pci_8086_293e_sound_card_0_alsa_playback_0
    Default Source: alsa_input.pci_8086_293e_sound_card_0_alsa_capture_0
    Not sure if that sheds any light on the situation.

  4. #4
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: Adobe Air applications and sound don't mix?

    Just out of curiosity, I have uninstalled it, and reinstalled. No problem whatsoever. I am sorry that I cannot help you. All I can do is speculate.

    However, I am using kernel 2.6.28 which I compiled myself. I had trouble with MySQL on default kernel, now MySQL works swell, and Postgre doesnt.
    Who would know...

    Oh yes.. I am still on openSUSE 11.0
    Emil Beli
    http://www.beli.ws/blog/
    openSUSE 11.4 x64 KDE, ATI 5600, i7 dell inspire laptop

  5. #5

    Default Re: Adobe Air applications and sound don't mix?

    Just a follow-up. It seems the problem was related to pusleaudio. When I killed that most of the sound problems with AA went away.

  6. #6
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Adobe Air applications and sound don't mix?

    @ecognito
    Yes, that screech first appeared with the inclusion of the dread pulseaudio. I have it disabled in Yast.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •