Results 1 to 5 of 5

Thread: Problems with GTK+ installation for Eiffel

  1. #1

    Default Problems with GTK+ installation for Eiffel

    Hi!
    I Instaled Eiffel studio. But for compiling it properly I need to have GTK+2.4 or above. I checked in Yast, that I have 2.14 version installed, but when I try to compile I got

    Code:
    Preparing C compilation
    nice: make: No such file or directory
    GTK version 2.4 or later does not seem to be installed
    Precompilation of EiffelVision skipped.
    comand pkg-config --modversion gtk+-2.0 gives

    Code:
    Package gtk+-2.0 was not found in the pkg-config search path.
    Perhaps you should add the directory containing `gtk+-2.0.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'gtk+-2.0' found
    So need help with that.

  2. #2
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Problems with GTK+ installation for Eiffel

    Be sure you have the gtk2-devel package installed. This has the library and header files needed to compile Eiffel.

  3. #3

    Default Re: Problems with GTK+ installation for Eiffel

    Thanks for help. After installing gtk2-devel, comand --modversion gtk+-2.0 shows, that I have 2.14.4 version. But the problem with compiling is similar.

    Code:
    Preparing C compilation
    nice: make: No such file or directory
    When I compile sample project and try to run it - eiffel studio tells me, that I need tocompile it first. But compiling project tels, that project compiled sucesfully.

  4. #4
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Problems with GTK+ installation for Eiffel

    Do you have the GNU development tools installed? You will need, at least,

    autoconf
    automake
    gcc
    gcc-c++
    make

    To find these, open the Software manager in Yast, and view by patterns. Look for "Base Development" in Development.

  5. #5

    Default Re: Problems with GTK+ installation for Eiffel

    Thanks for the help. I installed those packages and everything works fine. Thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •