Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Yast2 broken

  1. #1

    Default Yast2 broken

    OS 11.0

    I don't know what I've done, but I seem to have broken Yast2. Yast still works and Zypper works.

    What's wrong:
    1) If I try and use the software management, any package install fails saying "can't exec rpm (no such file or directory)"
    2) If I try and run xinetd, I am told it needs installing (although I know it is already installed). Of course, if I allow Yast2 to try and reinstall it, I get problem (1).

    I've tried rebuilding the rpmdb, but it doesn't help. I've also tried uninstalling and reinstalling Yast2, but that doesn't help either.

    Any ideas?

  2. #2
    Join Date
    Sep 2008

    Default Re: Yast2 broken

    Firstly, verify that rpm works by just typing rpm.
    Then, using rpm package, remove the yast package:
    rpm -e yast2-installation
    Then, install that using zypper:
    zypper install yast2-installation
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  3. #3

    Default Re: Yast2 broken

    Sorry for the long post, but I think this might help.

    I tried what you suggested, but I got the following problem:
    linux-1iys:/home/alex # rpm -e yast2-installation
    error: Failed dependencies:
    yast2-installation is needed by (installed) yast2-update-2.16.10-4.1.i58
    yast2-installation is needed by (installed) yast2-add-on-2.16.8-6.1.noar
    yast2-installation is needed by (installed) yast2-metapackage-handler-0.
    yast2-installation >= 2.15.12 is needed by (installed) yast2-packager-2.
    So then I tried more or less what I had tried before:
    linux-1iys:/home/alex # zypper remove yast2
    Downloading repository 'Updates for 11.0' metadata [done]
    Building repository 'Updates for 11.0' cache [done]
    Reading installed packages...

    The following packages are going to be REMOVED:
    yast2-x11 yast2-vm yast2-users yast2-security yast2-scanner yast2-samba-server

    yast2-samba-client yast2-runlevel yast2-restore yast2-repair yast2-registration
    yast2-profile-manager yast2-printer yast2-update-FACTORY yast2-update yast2-tv
    yast2-tune yast2-control-center-qt yast2-control-center yast2-bootloader
    yast2-backup yast2-apparmor yast2-add-on yast2 yast2-tftp-server yast2-sysconfig

    yast2-support yast2-storage yast2-sound yast2-metapackage-handler yast2-mail
    yast2-ldap-client yast2-ldap yast2-kerberos-client yast2-iscsi-client yast2-irda

    yast2-installation yast2-inetd yast2-http-server yast2-ftp-server yast2-firewall

    yast2-dns-server yast2-country yast2-pam yast2-packager
    yast2-online-update-frontend yast2-online-update yast2-ntp-client yast2-nis-clie
    yast2-nfs-server yast2-nfs-client yast2-network yast2-mouse autoyast2-installati

    After the operation, 35.3 M will be freed.
    Continue? [YES/no]:YES
    Removing yast2-nfs-server-2.16.1-6.1 [done]
    Removing yast2-nis-client-2.16.3-6.1 [done]
    Removing yast2-ntp-client-2.16.9-11.1 [done]
    Removing yast2-online-update-frontend-2.16.15-6.1 [done
    Removing yast2-online-update-2.16.15-6.1 [done]
    Removing yast2-firewall-2.16.2-25.1 [done]
    Removing yast2-ftp-server-2.16.11-22.1 [done]
    Removing yast2-http-server-2.16.9-10.1 [done]
    Removing yast2-dns-server-2.16.4-14.1 [done]
    Removing yast2-irda-2.16.1-25.1 [done]
    Removing yast2-iscsi-client-2.16.14-6.1 [done]
    Removing yast2-mail-2.16.6-2.1 [done]
    Removing yast2-metapackage-handler-0.8.5-16.1 [done]
    Removing yast2-support-2.16.1-6.1 [done]
    Removing yast2-sysconfig-2.16.0-28.1 [done]
    Removing yast2-tftp-server-2.16.0-26.1 [done]
    Removing yast2-add-on-2.16.8-6.1 [done]
    Removing yast2-apparmor-2.16.4-4.1 [done]
    Removing yast2-backup-2.16.6-0.1 [done]
    Removing yast2-nfs-client-2.16.1-26.1 [done]
    Removing yast2-control-center-qt-2.16.2-11.1 [done]
    Removing yast2-control-center-2.16.2-11.1 [done]
    Removing yast2-tune-2.16.2-2.1 [done]
    Removing yast2-tv-2.16.6-7.1 [done]
    Removing yast2-sound-2.16.11-6.1 [done]
    Removing yast2-update-FACTORY-2.16.10-4.1 [done]
    Removing yast2-printer-2.16.32-3.1 [done]
    Removing yast2-inetd-2.16.0-27.1 [done]
    Removing yast2-profile-manager-2.16.1-27.1 [done]
    Removing yast2-registration-2.16.7-4.1 [done]
    Removing yast2-repair-2.16.12-4.1 [done]
    Removing yast2-restore-2.16.2-26.1 [done]
    Removing yast2-runlevel-2.16.5-15.1 [done]
    Removing yast2-samba-server-2.16.3-15.1 [done]
    Removing yast2-samba-client-2.16.9-3.1 [done]
    Removing yast2-kerberos-client-2.16.11-9.1 [done]
    Removing yast2-scanner-2.16.10-13.1 [done]
    Removing yast2-users-2.16.33-6.1 [done]
    Removing yast2-ldap-client-2.16.16-6.1 [done]
    Removing yast2-ldap-2.16.0-52.1 [done]
    Removing yast2-network-2.16.48-3.1 [done]
    Removing yast2-packager-2.16.53-3.1 [done]
    Removing yast2-installation-2.16.50-3.1 [done]
    Removing autoyast2-installation-2.16.19-0.1 [done]
    Removing yast2-mouse-2.16.1-26.1 [done]
    Removing yast2-update-2.16.10-4.1 [done]
    Removing yast2-bootloader-2.16.20-0.1 [done]
    Removing yast2-storage-2.16.26-0.1 [done]
    Removing yast2-security-2.16.1-16.1 [done]
    Removing yast2-pam-2.16.2-17.1 [done]
    Removing yast2-country-2.16.26-6.1 [done]
    Removing yast2-vm-2.16.5-7.1 [done]
    Removing yast2-x11-2.15.12-15.1 [done]
    Removing yast2-2.16.71-6.1 [done]
    And then
    linux-1iys:/home/alex # zypper in yast2
    Reading installed packages...

    The following NEW package is going to be installed:

    Overall download size: 588.0 K. After the operation, additional 3.1 M will be us
    Continue? [YES/no]: YES
    Downloading package yast2-2.16.71-6.1.i586 (1/1), 588.0 K (3.1 M unpacked)
    Downloading: yast2-2.16.71-6.1.i586.rpm [done (47.7 K/s)]
    Installing: yast2-2.16.71-6.1 [done]
    and then
    linux-1iys:/home/alex # zypper in yast2-installation
    Reading installed packages...

    The following NEW packages are going to be installed:
    yast2-security yast2-registration yast2-pam yast2-ldap-client yast2-installati
    yast2-firewall yast2-add-on yast2-users yast2-update yast2-storage yast2-network

    yast2-mouse yast2-ldap yast2-country yast2-bootloader yast2-packager
    yast2-online-update autoyast2-installation

    Overall download size: 2.8 M. After the operation, additional 14.5 M will be use
    Continue? [YES/no]: YES
    Downloading package yast2-pam-2.16.2-17.1.noarch (1/18), 29.0 K (128.0 K unpacke
    Downloading: yast2-pam-2.16.2-17.1.noarch.rpm [done]
    Installing: yast2-pam-2.16.2-17.1 [done]
    Downloading package yast2-firewall-2.16.2-25.1.noarch (2/18), 81.0 K (481.0 K un
    Downloading: yast2-firewall-2.16.2-25.1.noarch.rpm [done]
    Installing: yast2-firewall-2.16.2-25.1 [done]
    Downloading package yast2-update-2.16.10-4.1.i586 (3/18), 92.0 K (467.0 K unpack
    Downloading: yast2-update-2.16.10-4.1.i586.rpm [done]
    Installing: yast2-update-2.16.10-4.1 [done]
    Downloading package yast2-storage-2.16.26-0.1.i586 (4/18), 507.0 K (2.7 M unpack
    Downloading: yast2-storage-2.16.26-0.1.i586.rpm [done (45.3 K/s)]
    Installing: yast2-storage-2.16.26-0.1 [done]
    Downloading package yast2-mouse-2.16.1-26.1.i586 (5/18), 26.0 K (91.0 K unpacked
    Downloading: yast2-mouse-2.16.1-26.1.i586.rpm [done]
    Installing: yast2-mouse-2.16.1-26.1 [done]
    Downloading package yast2-ldap-2.16.0-52.1.i586 (6/18), 113.0 K (478.0 K unpacke
    Downloading: yast2-ldap-2.16.0-52.1.i586.rpm [done]
    Installing: yast2-ldap-2.16.0-52.1 [done]
    Downloading package yast2-country-2.16.26-6.1.i586 (7/18), 99.0 K (473.0 K unpac
    Downloading: yast2-country-2.16.26-6.1.i586.rpm [done]
    Installing: yast2-country-2.16.26-6.1 [done]
    Downloading package yast2-security-2.16.1-16.1.noarch (8/18), 41.0 K (192.0 K un
    Downloading: yast2-security-2.16.1-16.1.noarch.rpm [done]
    Installing: yast2-security-2.16.1-16.1 [done]
    Downloading package yast2-bootloader-2.16.20-0.1.i586 (9/18), 297.0 K (2.1 M unp
    Downloading: yast2-bootloader-2.16.20-0.1.i586.rpm [done (49.1 K/s)]
    Installing: yast2-bootloader-2.16.20-0.1 [done]
    Downloading package autoyast2-installation-2.16.19-0.1.noarch (10/18), 175.0 K (
    1.2 M unpacked)
    Downloading: autoyast2-installation-2.16.19-0.1.noarch.rpm [done (52.5 K/s)]
    Installing: autoyast2-installation-2.16.19-0.1 [done]
    Downloading package yast2-installation-2.16.50-3.1.noarch (11/18), 207.0 K (633.
    0 K unpacked)
    Downloading: yast2-installation-2.16.50-3.1.noarch.rpm [done]
    Installing: yast2-installation-2.16.50-3.1 [done]
    Downloading package yast2-packager-2.16.53-3.1.i586 (12/18), 309.0 K (1.5 M unpa
    Downloading: yast2-packager-2.16.53-3.1.i586.rpm [done (48.9 K/s)]
    Installing: yast2-packager-2.16.53-3.1 [done]
    Downloading package yast2-registration-2.16.7-4.1.noarch (13/18), 137.0 K (250.0
    K unpacked)
    Downloading: yast2-registration-2.16.7-4.1.noarch.rpm [done]
    Installing: yast2-registration-2.16.7-4.1 [done]
    Downloading package yast2-add-on-2.16.8-6.1.noarch (14/18), 40.0 K (126.0 K unpa
    Downloading: yast2-add-on-2.16.8-6.1.noarch.rpm [done]
    Installing: yast2-add-on-2.16.8-6.1 [done]
    Downloading package yast2-network-2.16.48-3.1.i586 (15/18), 315.0 K (1.9 M unpac
    Downloading: yast2-network-2.16.48-3.1.i586.rpm [done (39.8 K/s)]
    Installing: yast2-network-2.16.48-3.1 [done]
    Downloading package yast2-online-update-2.16.15-6.1.noarch (16/18), 58.0 K (247.
    0 K unpacked)
    Downloading: yast2-online-update-2.16.15-6.1.noarch.rpm [done (17.9 K/s)]
    Installing: yast2-online-update-2.16.15-6.1 [done]
    Downloading package yast2-ldap-client-2.16.16-6.1.noarch (17/18), 94.0 K (508.0
    K unpacked)
    Downloading: yast2-ldap-client-2.16.16-6.1.noarch.rpm [done (33.3 K/s)]
    Installing: yast2-ldap-client-2.16.16-6.1 [done]
    Downloading package yast2-users-2.16.33-6.1.i586 (18/18), 205.0 K (1.0 M unpacke
    Downloading: yast2-users-2.16.33-6.1.i586.rpm [done (28.7 K/s)]
    Installing: yast2-users-2.16.33-6.1 [done]
    I then started yast2 and installed yast2-xinetd and everything seems to be fine.
    I will now try and install the other yast2 packagaes and see if the problem stays away.
    Thanks for the help.
    I hope this experience is useful to someone else.

  4. #4
    Join Date
    Sep 2008

    Default Re: Yast2 broken

    Good to hear that your problem is solved.
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  5. #5

    Default Re: Yast2 broken

    I thought it was, but a couple of restarts and not much else later and the problem is back exactly as it was. Has anyone any other ideas?

  6. #6
    somebody_else NNTP User

    Default Re: Yast2 broken

    nalexmay wrote:
    > I thought it was, but a couple of restarts and not much else later and
    > the problem is back exactly as it was. Has anyone any other ideas?

    exactly what did you do during that "and not much else"? why did you
    reboot? what did you add? what did you change?

    did you take a backup while it all worked well???

    AND, what repos do you have enabled..


  7. #7

    Default Re: Yast2 broken

    If I thought I had done anything that might have caused it or indeed if I could remember having done anything in particular I would have said so. Do I have to write down everything I do with OpenSuse every time I use the computer? I rebooted because I'm not yet using the server, so I powered it off when I was away.
    What repos you ask. Sorry, but I don't know how to answer that question. Can you explain please.

  8. #8
    somebody_else NNTP User

    Default Re: Yast2 broken

    > What repos you ask. Sorry, but I don't know how to answer that
    > question. Can you explain please.

    read the repository management howto thread that begins here:

    i've not looked at it lately but i THINK it recommends you normally
    use only FOUR repos...

    and, it is my bedtime...maybe someone else will come in and get you
    started with zypper..

    i guess you can/should use zypper to repair yast...and, there are some
    very recent thread on that very thing...see if you find them using the
    forum's search engine...or use google and specify to search in


  9. #9

    Default Re: Yast2 broken

    Thanks for the clarification.
    Here is the answer to the question of repos.
    I don't think I have much more than I should.
    The only one I added was for Open-Xchange, but that's what this server is supposed to be for, so I don't think I can do without it.
    linux-1iys:/home/alex # zypper lr
    # | Alias | Name | Enabled | Refresh
    1 | repo-debug | openSUSE-11.0-Debug | No | No
    2 | repo-oss | openSUSE-11.0-Oss | Yes | No
    3 | OX | OX | Yes | Yes
    4 | openSUSE-11.0-Updates | Updates for 11.0 | Yes | Yes
    5 | repo-non-oss | openSUSE-11.0-Non-Oss | Yes | No
    6 | openSUSE-11.0-FTP 11.0 | openSUSE-11.0-FTP 11.0 | Yes | Yes
    I did some searching and reading on repairing Yast with Zypper. Basically the approach seems to be to refresh the database and reinstall Yast. That's what I did and it solved the problem...
    ...until the problem came right back.
    I guess it is a problem with an update which is happening automatically and breaking yast, but I don't know how to narrow down what is causing the problem.
    So, further ideas would be most welcome.

  10. #10
    Join Date
    Jun 2008
    Groningen, Netherlands
    Blog Entries

    Default Re: Yast2 broken

    Why use 11.0 if 11.1 is available ?
    It might also be an indication of a degrading condition of your harddisk...
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts