Results 1 to 4 of 4

Thread: Repository access problem OpenSuse 10.3

  1. #1
    manotitas NNTP User

    Question Repository access problem OpenSuse 10.3

    Dear all,

    Since a few days (actually almost 2 weeks) I am having trouble to update my distribution. I always get the error "Couldn"t connect to host"

    Here an example when trying to update the OSS repository
    Unable to create repository from URL 'http://download.opensuse.org/distribution/10.3/repo/oss/suse'
    Error trying to read from `http://download.opensuse.org/distribution/10.3/repo/oss/suse`
    History:
    - Curl error for 'http://download.opensuse.org/distribution/10.3/repo/oss/suse/repodata/repomd.xml'.
    Error Code:
    Error messgae: Couldn't connect to host
    However using my browser it is no problem at all to access the repository. Neither it is a problem for a mirror site. Any idea what could be broken here?

    Thanks for your help.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,743
    Blog Entries
    20

    Default Re: Repository access problem OpenSuse 10.3

    Have you tried deleting them. The replacing them?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Sep 2008
    Location
    Deutschland
    Posts
    17

    Default Re: Repository access problem OpenSuse 10.3

    have you an proxy or go you direct to the net?
    block your firewall?
    can you run :
    curl http://download.opensuse.org/distrib...ata/repomd.xml

    or
    wget http://download.opensuse.org/distrib...ata/repomd.xml
    ?

  4. #4
    manotitas NNTP User

    Smile Re: Repository access problem OpenSuse 10.3

    Thanks for your response. I had tried everything - thought about the proxy and FW as well. Yet it was looks like a corrupted entry in the var/lib/zypp/db/patches directory. After renaming the directory (recommendation found through google-ing) and recreating the directory (well and a reboot) everything works now again like a charm.

    Thanks again to all responding to my posting.

    Cheers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •