Results 1 to 10 of 10

Thread: latex

  1. #1

    Default latex

    Hi,

    I have to use latex and I have downloaded texlive from yast and I have:

    hana@linux-4pel:~/Desktop> rpm -qa | grep tex
    perl-gettext-1.05-112.1
    latex2html-pngicons-2002.2.1-560.1
    texlive-2008-16.1
    gettext-runtime-0.17-40.1
    texlive-bin-2008-17.1
    gettext-tools-0.17-40.1
    texinfo-4.11-16.1

    This is not enough, since I have downloaded the 2008 version of texlive, how could I download the rest of the packages I need.

    Regards,
    Hana

  2. #2
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: latex

    I like latex as much as the next girl but never having used it, my guess would be that it might be beneficial to install the "technical_writing" pattern from zypper / YAST - it includes the following packages:

    Code:
    Information for pattern technical_writing:
    
    Repository: oss
    Name: technical_writing
    Version: 11.1-71.1
    Arch: i586
    Vendor: openSUSE
    Installed: No
    Summary: Technical Writing
    Description: 
    Authoring tools and editors for creating technical documentation.
    Contents:
    
    S | Name                      | Type    | Dependency
    --+---------------------------+---------+-----------
    i | emacs                     | package |           
      | texlive-cjk               | package |           
      | dbsplit-tools             | package |           
      | emacs-x11                 | package | Suggested 
      | texlive-context           | package |           
      | djvulibre                 | package |           
      | texlive-doc               | package |           
      | texlive-dvilj             | package |           
      | psutils                   | package |           
      | nxml-mode                 | package |           
      | texlive-latex-doc         | package |           
      | dvi2tty                   | package |           
      | texlive-metapost          | package |           
      | texlive-omega             | package |           
      | xmlformat                 | package |           
      | texlive-tools             | package |           
      | susedoc                   | package |           
      | texlive-xetex             | package |           
      | lyx                       | package |           
      | docbook-dsssl-stylesheets | package |           
      | inkscape                  | package |           
      | xslide                    | package |           
      | fop                       | package |           
      | dia                       | package |           
      | sablot                    | package |           
      | xmlstarlet                | package |           
      | TeXmacs                   | package |           
      | docbook-xml-website       | package |           
      | xmlto                     | package |           
      | svg-schema                | package |           
      | docbook-xsl-stylesheets   | package |           
      | docbook5-xsl-stylesheets  | package |           
      | batik                     | package |           
      | docbook_5                 | package |           
      | saxon                     | package |           
      | mxml                      | package |           
      | tei-roma                  | package |           
      | tei-xsl-stylesheets       | package |
    You can just go to YAST, press Filters and choose Patterns - then find the Technical Writing one and install that or alternative use the command line (as root) and issue; zypper in -t pattern technical_writing

  3. #3
    Join Date
    Jun 2008
    Location
    Oregon, US
    Posts
    109

    Default Re: latex

    I know that I helped someone with a similar problem in 11.0. I put up a list of all the tex packages I had on a working installation. Make sure you have all of these installed in YaST (might be different versions since it looks like you are using 11.1 instead of 11.0, but base package name should be the same)
    Code:
    justin@desktop:~> rpm -qa | grep tex
    texlive-bin-2007-176.1
    texlive-bin-tools-2007-176.1
    texlive-bin-latex-2007-176.1
    texlive-bin-xetex-2007-176.1
    perl-gettext-1.05-112.1
    kdegraphics3-tex-3.5.9-53.1
    texlive-context-2007-177.1
    gettext-runtime-0.17-40.1
    texlive-2007-177.1
    texlive-tools-2007-177.1
    texlive-xetex-2007-177.1
    latex2html-pngicons-2002.2.1-560.1
    texlive-latex-2007-177.1
    Reply back if you have those packages installed and it still doesn't work.

  4. #4

    Default Re: latex

    Hi,

    yes, I have read your reply to that post. The packages I have installed are as follows:

    perl-gettext-1.05-112.1
    latex2html-pngicons-2002.2.1-560.1
    texlive-2008-16.1
    gettext-runtime-0.17-40.1
    texlive-bin-2008-17.1
    gettext-tools-0.17-40.1
    texinfo-4.11-16.1

    I have two questions:
    1. In your packages, you have kdegraphics3-tex-3.5.9-53.1, I work with gnome not kde, is there a replace I should install.

    2. the packages you have are all in 2007 versions and I have texlive-2008-16.1 installed, could there be any problem if I install the rest of the packages according to what you have installed?

    Thanks again.

    Regards,

  5. #5
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: latex

    The gettext packages are not related to TeX. These are the only ones that are really required in 11.1, from a working system, and maybe not even the pngicons, so that's down to 4 packages only that are definitely required, so you may have complicated things for yourself unnecessarily:

    latex2html-pngicons-2002.2.1-604.27
    texlive-2007-219.3
    texlive-bin-2007-219.4
    texlive-bin-latex-2007-219.4
    texlive-latex-2007-219.3
    This is for stock 11.1. I'm not sure where you get the 2008 packages, maybe you are subscribed to a factory repo? If you had downloaded manually from a factory repo, you shouldn't have done that. You should have at least added the factory repo, then it would have pulled in dependencies automatically. If you had downloaded from a non-openSUSE archive, bad boy!

  6. #6

    Default Re: latex

    I should say I use opensuse 11.0 and I have downloaded the packages right from this websitehttp:"http://software.opensuse.org/search" only typing "texlive" in the get packages!!!

    I seems I have to start from the first point and go thrugh installing the packages you mentioned.

  7. #7
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,450

    Default Re: latex

    An easy workaround is to install LyX because YaST will install all the LaTeX packages you need with LyX - other than a LaTeX editor if you have a particular preference in that area.

  8. #8

    Default Re: latex

    I usually install kile (from kde) in order to install all dependences for TeX.

  9. #9

    Default Re: latex

    hi all
    I have installed Kile in openSUSE 11.1 and everything works fine but now I need to write some text in spanish and special characters need to be entered like \~ for . In a tutorial I found this solution to type it directly
    \usepackage[english,spanish, activeacute]{babel}
    \usepackage[T1]{fontenc}
    In Linux it's not working but if I try it with Miktex and WinXP it's ok.
    I think I need an actualized texlive version instead of 2007 so I download it (TeX Live 2009) now I don't know how to make Kile and texlive work together

    Regards

  10. #10
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,450

    Default Re: latex

    I suspect you have ended up with a conflict between versions. Unless you get a beta version, you get a KDE3 version of kile with 11.1. You may find that uninstalling your existing versions of kile and texlive and reinstalling the most up-to-date version from the Build Service is your easiest option.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •