Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: chmod for /mnt

  1. #1
    farzadrocks NNTP User

    Default chmod for /mnt

    Hello
    I have 2 hard-drives
    /dev/sda
    /dev/sdb
    with multiple partition on each one
    (sda1, sda2, sda3) (sdb1 ... sdb7) which some of them are in NTFS

    All of them have been mounted and I can access them ...
    However, I can't write to the drives (NTFS) other than root
    the drives have this characteristics:
    (user = root / Group = users / user=rwx,group=r-x,others=---
    I log in as root and try to use chmod so that the group can access it -- and it doesn't give me any error --
    but when I ls again there has been no effect
    Doesn't anyone know the problem ?
    Thank you in advance

  2. #2

    Default Re: chmod for /mnt

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    `man mount`

    Look for 'mode'. I believe you must set the actual mountpoint's
    permissions with the mount command and the 'mode' option.

    Good luck.





    farzadrocks wrote:
    > Hello
    > I have 2 hard-drives
    > /dev/sda
    > /dev/sdb
    > with multiple partition on each one
    > (sda1, sda2, sda3) (sdb1 ... sdb7) which some of them are in NTFS
    >
    > All of them have been mounted and I can access them ...
    > However, I can't write to the drives (NTFS) other than root
    > the drives have this characteristics:
    > (user = root / Group = users / user=rwx,group=r-x,others=---
    > I log in as root and try to use chmod so that the group can access it
    > -- and it doesn't give me any error --
    > but when I ls again there has been no effect
    > Doesn't anyone know the problem ?
    > Thank you in advance
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.9 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iQIcBAEBAgAGBQJKFhLiAAoJEF+XTK08PnB5LiYP/RXbfZM+eY1DF88OUPa6+FY4
    aCMerZjGDXgPInAuYCrHe52GrQoTI6yghp9nhQkRAYxKFdOI+pk+5x2u6BaCjGRR
    HZfGY5cfVEEbzyiLwaYsZtpyuCR+JLyQBJ4uXZAuJSf/LdXzBnLZ77dhthitpeUr
    we0ze9OVbCNOkJmjbvFDS0WYt3w01y6w0niCM8e8dt1M4xRakHrKUZeZUHfZr5bT
    e0gcuu792BjPCGRriaJrvQF2Y8ozQdA/0d+zhzvWKAO7paFMsw+3mexhVFeP+v0C
    owwWQiRa1QcLtbCU7fAbEzf9FmQ/BLipfuSQFmyqSj50kehHMBXMdTbM5HfvI9da
    HhDcaI2JyUvVMooj5zUPSIK1gIWZup7ynsrBjOxvbBay9cnLOckBoz7uou0WclBO
    LWQbRNqxN1dLi2V3zsGIkDNnOqvg4FN4a9qsWSB5rW3WwG5hOqJYLN6kBNmq3Jk/
    BM93olHsDGI0kagrk8WgvbWxwEYaczpyDNkf/9P1n5ptML6kmQYImh/ONG+4jTmY
    n7lo1A5mIoBTHHzugUA8iv9jFUNxtNwQUe5BN/0hqETehpp2//bZbfWDn78Pc65T
    TKWwbFPCB14IPNG1DpG/mAiCcTvLzxYN9IQUf1M47lIzECzZVupx+FHpdLQ1gaPi
    D1BpJEKPSFyThtgh+OoY
    =3o/q
    -----END PGP SIGNATURE-----

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,760
    Blog Entries
    20

    Default Re: chmod for /mnt

    Post the terminal output of:

    Code:
    cat /etc/fstab
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4
    farzadrocks NNTP User

    Default Re: chmod for /mnt

    this is my /etc/fstab file:

    /dev/disk/by-id/ata-ST3320620AS_9QF45KF5-part3 swap swap defaults 0 0
    /dev/disk/by-id/ata-ST3320620AS_9QF45KF5-part2 / ext3 acl,user_xattr 1 1
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    debugfs /sys/kernel/debug debugfs noauto 0 0
    usbfs /proc/bus/usb usbfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    /dev/disk/by-id/ata-ST3400832AS_5NF07BSZ-part6 /mnt/Software ntfs-3g user,users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
    /dev/disk/by-id/ata-ST3400832AS_5NF07BSZ-part4 /mnt/Document ntfs-3g user,users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
    /dev/disk/by-id/ata-ST3400832AS_5NF07BSZ-part7 /mnt/Pictures ntfs-3g user,users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
    /dev/disk/by-id/ata-ST3400832AS_5NF07BSZ-part5 /mnt/Project ntfs-3g user,users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
    /dev/disk/by-id/ata-ST3320620AS_9QF45KF5-part1 /mnt//winC ntfs-3g user,users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
    /dev/disk/by-id/ata-ST3400832AS_5NF07BSZ-part1 /mnt/winE ntfs-3g user,users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,760
    Blog Entries
    20

    Default Re: chmod for /mnt

    Code:
    /dev/disk/by-id/ata-ST3400832AS_5NF07BSZ-part6 /mnt/Software ntfs-3g defaults 0 0
    /dev/disk/by-id/ata-ST3400832AS_5NF07BSZ-part4 /mnt/Document ntfs-3g defaults 0 0
    /dev/disk/by-id/ata-ST3400832AS_5NF07BSZ-part7 /mnt/Pictures ntfs-3g defaults 0 0
    /dev/disk/by-id/ata-ST3400832AS_5NF07BSZ-part5 /mnt/Project ntfs-3g defaults 0 0
    /dev/disk/by-id/ata-ST3320620AS_9QF45KF5-part1 /mnt//winC ntfs-3g defaults 0 0
    /dev/disk/by-id/ata-ST3400832AS_5NF07BSZ-part1 /mnt/winE ntfs-3g defaults 0 0
    Change as above

    to edit do:

    kdesu kwrite /etc/fstab (in kde)

    gnomesu kwrite /etc/fstab (gnome)

    reboot when done

    http://forums.opensuse.org/how-faq-r...-manually.html
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    farzadrocks NNTP User

    Default Re: chmod for /mnt

    it worked --
    Thank you very much --
    I did the partitioning using
    Yast --> System --> Partitioner
    but it didn't have any option for doing this
    Thanks again

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,760
    Blog Entries
    20

    Default Re: chmod for /mnt

    Quote Originally Posted by farzadrocks View Post
    it worked --
    Thank you very much --
    I did the partitioning using
    Yast --> System --> Partitioner
    but it didn't have any option for doing this
    Thanks again
    Well there is actually an option in the partitioner, you have to click fstab details a button just under the mount point details. You can manually edit it there. But of course you would have to know what to put.

    Good to hear it worked, well done!
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8
    Join Date
    Mar 2008
    Location
    Vsters, Sweden ex. Highbury London UK
    Posts
    1,245

    Default Re: chmod for /mnt

    Easy way is in a console as su

    chown -R UserName /pathToDrive
    Core 2 Duo 3.16GHz, 8GB DDR2, 3.5TB, GeForce 9600 GT, Amilo LCD 26", OS 11.1 x86_64, KDE4.2.4 (2)
    My wine tips & tricks

  9. #9
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,729
    Blog Entries
    2

    Default Re: chmod for /mnt

    Quote Originally Posted by geoffro View Post
    Easy way is in a console as su

    chown -R UserName /pathToDrive
    You can't chown or chmod the windows filesystems fat and ntfs. The permissions are controlled only by the umask in the mount command and the ownership is controlled only from the mount options "-o uid=blah,gid=blah". Once these are set they flow along the entire filesystem tree. The ownerships and permissions modes are homogeneous across the partition, can't vary.

    Tricky devils those microsoft guys!
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  10. #10
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: chmod for /mnt

    The ownerships and permissions modes are homogeneous across the partition, can't vary.
    Is it not possible to set individual permission on files in NTFS?
    Just curious. (Sorry, I'm not familiar with Windo$).
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •