Results 1 to 10 of 10

Thread: Opera doesn't launch...help

  1. #1
    Join Date
    Jul 2008
    Location
    Melbourne, Australia
    Posts
    64

    Question Opera doesn't launch...help

    openSuse 11.1 gnome
    Hi, Downloaded Opera through synaptic and it instaled. However, when I click on the icon it doesn't launch. What am I doing wrong with this program?
    It also didn't launch when I was running openSuse 10.3, what am i missing?

  2. #2
    Join Date
    May 2009
    Location
    Jakarta, Beijing
    Posts
    77

    Default Re: Opera doesn't launch...help

    Open it using console , gnome-terminal
    and see the error message
    "And just as you want men to do to you, you also do to them likewise."
    Luke 6:31 NKJV

  3. #3
    heartless_bot NNTP User

    Default Re: Opera doesn't launch...help

    first: what is synaptic? (you do know this is the openSUSE forum,
    right? have you tried YaST or zypper?)

    second: when you say you installed it, what do you mean? how did you
    install it? with YaST, or manually (try fetching and installing with YaST)

    third: open a terminal and type in opera and press enter, do you
    get any error messages...anything at all??

    fourth: you ask what you are missing, and i guess it is the correct
    way to get and install a program on openSUSE...have a read here:
    http://en.opensuse.org/Concepts#Soft..._Management.29



    --
    heartless_bot

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,649
    Blog Entries
    14

    Default Re: Opera doesn't launch...help

    Synaptic? That's for Debian (Ubuntu a.o). Sure you're on openSUSE? Then do this:
    Open a terminal and type:
    zypper in opera
    That should install Opera 9.64 from the repos
    Been running Opera since 1998, apart from some weird experiences with alpha's and beta's it never failed on me. Still use it on a daily basis.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Jul 2008
    Location
    Melbourne, Australia
    Posts
    64

    Default Re: Opera doesn't launch...help

    Hi,
    * Yes am using Suse...YAST
    * Tried to install using YAST
    * Opened terminal and type Opera...this message appears
    ...Desktop> opera
    /usr/lib/opera/9.64/opera: symbol lookup error: /usr/lib/opera/9.64/opera: undefined symbol: static_QUType_varptr
    adam@linux-8gf7:~/Desktop>

    Thanks for your help, what should I do from here?

  6. #6
    Join Date
    May 2009
    Location
    Jakarta, Beijing
    Posts
    77

    Default Re: Opera doesn't launch...help

    it means that the library needed is missing,

    Type:
    Code:
    ldd /usr/lib/opera/9.64/opera
    paste the output here.

    it will tell you what libraries opera needs.
    just need to install the ones you don't have
    "And just as you want men to do to you, you also do to them likewise."
    Luke 6:31 NKJV

  7. #7
    heartless_bot NNTP User

    Default Re: Opera doesn't launch...help

    > it means that the library needed is missing,

    hmmmm, could/would YaST complete the install without noting (and
    filling) all the library requirements?

    adstaryoung typed "Tried to install using YAST" and i now wanna BOLD
    type that *TRIED* and wonder if there were YaST errors ignored,
    maybe??

    --
    heartless_bot

  8. #8
    Join Date
    Jul 2008
    Location
    Melbourne, Australia
    Posts
    64

    Question Re: Opera doesn't launch...help

    Hi,
    here is what I typed...and the information that appeared. I actually re-installed Opera through Yast with no apparent problems, and there were no ignored dependencies.
    I also did the zypper in opera thing, look below

    ldd /usr/lib/opera/9.64/opera
    linux-gate.so.1 => (0xffffe000)
    libqt-mt.so.3 => /usr/lib/libqt-mt.so.3 (0xb764e000)
    libX11.so.6 => /usr/lib/libX11.so.6 (0xb751b000)
    libXext.so.6 => /usr/lib/libXext.so.6 (0xb750a000)
    libSM.so.6 => /usr/lib/libSM.so.6 (0xb7501000)
    libICE.so.6 => /usr/lib/libICE.so.6 (0xb74e5000)
    libpthread.so.0 => /lib/libpthread.so.0 (0xb74cb000)
    libdl.so.2 => /lib/libdl.so.2 (0xb74c6000)
    libz.so.1 => /lib/libz.so.1 (0xb74b1000)
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb73bd000)
    libm.so.6 => /lib/libm.so.6 (0xb7394000)
    libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7384000)
    libc.so.6 => /lib/libc.so.6 (0xb7228000)
    libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb721e000)
    libstdc++-libc6.2-2.so.3 => /usr/lib/libstdc++-libc6.2-2.so.3 (0xb71dc000)
    libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0xb71d9000)
    libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb71ba000)
    libXau.so.6 => /usr/lib/libXau.so.6 (0xb71b6000)
    libuuid.so.1 => /lib/libuuid.so.1 (0xb71b0000)
    /lib/ld-linux.so.2 (0xb7f92000)

    ALSO...
    zypper in opera
    Loading repository data...
    Reading installed packages...
    'opera' is already installed.
    Resolving package dependencies...
    Nothing to do.

    also tried opera in terminal, here are the results...
    opera
    /usr/lib/opera/9.64/opera: symbol lookup error: /usr/lib/opera/9.64/opera: undefined symbol: static_QUType_varptr

    Where to from here?

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,726
    Blog Entries
    20

    Default Re: Opera doesn't launch...help

    Code:
    zypper rm opera
    then
    Code:
    zypper in opera
    now try
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10
    Join Date
    May 2009
    Location
    Jakarta, Beijing
    Posts
    77

    Default Re: Opera doesn't launch...help

    Quote Originally Posted by adstaryoung View Post
    Hi,

    ldd /usr/lib/opera/9.64/opera
    linux-gate.so.1 => (0xffffe000)
    libqt-mt.so.3 => /usr/lib/libqt-mt.so.3 (0xb764e000)
    ok, you have all the libraries needed,

    pls try to download & install the static build rpm directly from opera,here
    http://mirror.publicns.net/pub/opera...c-qt3.i386.rpm

    Code:
    zypper rm opera
    rpm -i opera-9.64.gcc4-static-qt3.i386.rpm
    Good luck
    "And just as you want men to do to you, you also do to them likewise."
    Luke 6:31 NKJV

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •