Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Couple KDE4 questions

  1. #1

    Question Couple KDE4 questions

    I already tried searching, but did not come up with any good results, so here we go:

    -What is the correct place to update my KDE 4.2.3 (notice I already have KDE4.2.3 but I want to update it, because the packages I installed when it became available are bit crash-happy)? It seems that the repositories have undergone some changes, and I can not currently find the up to date packages.

    -Any ideas why my KDE4 desktop takes over 1 minute to load, this used to be okay couple months ago, but now it is taking ages to load from X-server start to desktop. Any insight what logs I could tail to see what is taking the most of the time? KDE4 desktop used to start in few seconds, now it takes over minute and I don't want to delete ~/.kde4 folder.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Couple KDE4 questions

    First lets see your repos

    Code:
    zypper lr --details
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Couple KDE4 questions

    (Sorry not with the machine right now)
    Besides the normal Opensuse Updates&&OSS&NONOSS and Packman I had this for KDE4 previously:
    - Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.1 I think this was the one I installed 4.2.3 from, it does not seem to house 4.2.3 packages anymore.
    - Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.1 I tried changing to this repo, but it seems to hold older packages than my current ones.

    I think the first one (the factory repo) used to update it's packages almost daily, I would like to find that repo.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Couple KDE4 questions

    You need to disable the factory repo's
    and add these:
    Index of /repositories/KDE:/42/openSUSE_11.1

    Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE_42

    Then do Update all Unconditionally in these 2 repo's
    make sure all repos' are 99 priority
    except oss and non-oss which should be 120

    see this thread
    KDE4.2.* (How To Add) Guide. - openSUSE Forums
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Couple KDE4 questions

    Thanks for the suggestions!

    Any ideas on the second issue, is everyone else's KDE4 starting in normal time?

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Couple KDE4 questions

    I'm not sure. But my Laptop doesn't even take 60 secs from cold to a working desktop.
    .xsession-errors in your hidden /home/username
    Also hit Esc. at boot to get verbose mode


    also
    /var/log/boot.msg
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: Couple KDE4 questions

    AFAIK the esc/verbose only works before window manager startup. For me it is the WM start, ie. when KDE4 starts to load that takes over minute, during that time esc does nothing. But Ill try the logs that you suggested, thanks.

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Couple KDE4 questions

    Just for testing you could try creating a new user profile (It's easy to delete later).
    You will need to login once first before you can test it properly. Don't change any settings, just let the desktop populate itself and then logout and see how it is coming back in.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: Couple KDE4 questions

    Thanks for the suggestion, I actually tried it already. It works fine with a default .kde4 folder, which let me to believe that this could be actually cured by removing my current .kde4 folder but I do not want to do that.

    I guess I'll start narrowing the suspects by removing parts of the stuff under .kde4 and see what fixes the situation. That will be slow progress though, as it requires reboot after every change, because the KDE start is okay second time around when all the stuff is already in the memory.

  10. #10

    Default Re: Couple KDE4 questions

    I was actually wondering the same thing and came across this thread. Don't mean to hijack. Am curious about which repos should be disabled and if this will cause any problems in the future as far as suse 11.1 updates. Specifically which factory repos should be disabled.
    For example these are the ones I currently have up:
    zypper lr --details
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+------------------------+------------------------+---------+---------+----------+--------+----------------------------------------------------------------------------------------------------+--------
    1 | KDE_4.2_Extra_Apps | KDE 4.2 Extra Apps | Yes | Yes | 97 | rpm-md | Index of /repositories/KDE:/KDE4:/Factory:/Extra-Apps/openSUSE_11.1 |
    2 | KDE_4.2_Factory | KDE 4.2 Factory | Yes | Yes | 97 | rpm-md | Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.1 |
    3 | Main Update Repository | Main Update Repository | Yes | Yes | 99 | rpm-md | Index of /update/11.1 |
    4 | NVIDIA Repository | NVIDIA Repository | Yes | Yes | 99 | rpm-md | http://download.nvidia.com/opensuse/11.1 |
    5 | devel:tools:building | devel:tools:building | Yes | Yes | 99 | rpm-md | Index of /repositories/devel:/tools:/building/openSUSE_11.1 |
    6 | factory_desktop | factory desktop | Yes | Yes | 97 | rpm-md | Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE4_Factory_Desktop |
    7 | home:thomas-schraitle | home:thomas-schraitle | Yes | Yes | 99 | rpm-md | Index of /repositories/home:/thomas-schraitle/openSUSE_11.1 |
    8 | iplist_1 | iplist | Yes | Yes | 99 | rpm-md | Index of /repositories/home:/uljanow/openSUSE_11.1 |
    9 | openSUSE 11.1-0 | openSUSE 11.1-0 | No | No | 99 | yast2 | cd:///?devices=/dev/sr0,/dev/sr1 |
    10 | openSUSE:11.1 | openSUSE:11.1 | Yes | Yes | 99 | yast2 | Index of /distribution/11.1/repo/oss |
    11 | qt | qt | No | Yes | 99 | rpm-md | Index of /repositories/KDE:/Qt/openSUSE_11.1 |
    12 | qt45 | qt45 | No | Yes | 99 | rpm-md | Index of /repositories/KDE:/Qt45/openSUSE_11.1 |
    13 | repo | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.1 |
    14 | repo-debug | openSUSE-11.1-Debug | No | Yes | 100 | NONE | Index of /debug/distribution/11.1/repo/oss |
    15 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/non-oss |
    16 | repo-oss | openSUSE-11.1-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/oss |
    17 | repo-source | openSUSE-11.1-Source | No | Yes | 100 | NONE | Index of /source/distribution/11.1/repo/oss |
    18 | repo-update | openSUSE-11.1-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.1 |
    19 | repo_1 | VideoLan Repository | No | Yes | 99 | rpm-md | Index of /pub/videolan/vlc/SuSE/11.1/

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •