Page 1 of 9 123 ... LastLast
Results 1 to 10 of 88

Thread: How to turn off the X Server?

  1. #1

    Default How to turn off the X Server?

    I'm trying to install some NVIDIA Driver. It's asking me to turn off the X server. How to turn this off and then on again afterwards? Does it require a reboot?

  2. #2
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: How to turn off the X Server?

    I have a feeling you're doing it HORRIBLY wrong because there is no need to shutdown Xorg so just read this: NVIDIA - openSUSE

    and use one 1-click installer.

  3. #3

    Default Re: How to turn off the X Server?

    That won't work. Or rather it did, but didn't solve my problem with Sax2 always showing a 1024x768 resolution when testing it.

    From the NVIDIA Website...

    To download and install the drivers, follow the steps below:

    STEP 1: Review the NVIDIA Software License.

    You will need to accept this license prior to downloading any files.

    STEP 2: Download the Driver File
    Download - NVIDIA-Linux-x86_64-180.51-pkg2.run

    SuSE users: please read the SuSE NVIDIA Installer HOWTO before downloading the driver.

    STEP 3: Install
    Type "sh NVIDIA-Linux-x86_64-180.51-pkg2.run" to install the driver.
    It was after runnind Step three that I was told the NVIDIA Install didn't complete because X Server was loaded and to unload it before completing the install.

  4. #4

    Default Re: How to turn off the X Server?

    Oops. Sorry. I didn't click on the 1-click button. I'm downloading it now and will update afterwards

  5. #5

    Default Re: How to turn off the X Server?

    If you install it from the RUN file then you indeed need to turn of X. If you install it from the Yast NVIDIA repo then you don't.

    To turn off X you need to go to the first terminal (CTRL-ALT-F1), login as root and execute the command init 3.

    This will bring you to runlevel 3, which is the runlevel with multi user and network support but without an X server running.

    Hope this helps.

  6. #6

    Default Re: How to turn off the X Server?

    Ok. The Driver downloaded and installed successfully. But it's given me another problem.

    Now when using YAST/Sax2 Card & Monitor Properties and testing the configuration, it says..

    Testing Configuration Failed

    SaX: Library Success
    Xconfiguration: No Information

    So now it doesn't even go to the 1024x768 Test Screen. What I need to know now, what's going to happen if I switch off and reboot?

  7. #7
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: How to turn off the X Server?

    Well, first of all I'm going to need a little more information as to what you're trying to do, what you've done so far and what exactly is going on.

    First of all, open a terminal window and run the follow commands, then copy paste the results of those commands here:

    uname -r
    rpm -qa | grep -i kernel
    rpm -qa | grep -i nvidia

    and post your /etc/X11/xorg.conf fully in here, use the code [] tags to encase the results.

    Second of all, have you chosen a monitor in the sax2 that actually allows resolutions that you're trying to test? If in doubt, use a VESA or LCD monitor that corresponds to your physical device.

    And you of course rebooted (or at least logged out) after installing the driver, right?

  8. #8
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: How to turn off the X Server?

    stubble adjusted his/her AFDB on Tuesday 19 May 2009 12:46 to write:

    >
    > Ok. The Driver downloaded and installed successfully. But it's given me
    > another problem.
    >
    > Now when using YAST/Sax2 Card & Monitor Properties and testing the
    > configuration, it says..
    >
    > Testing Configuration Failed
    >
    > SaX: Library Success
    > Xconfiguration: No Information
    >
    > So now it doesn't even go to the 1024x768 Test Screen. What I need to
    > know now, what's going to happen if I switch off and reboot?
    >
    >


    Are you at init 3 while doing this or do you still have X running?

    If you are still in a desktop you will need to drop to init 3 and then run

    sax2 -r -m 0=nvidia

    then configure you system

    The reason is that if you still have x running it will have the old module
    loaded which needs to be rmmod1ed and then the new one modprobed, this is
    done automatically by stoppint x and runningthe sax command.

    If sax throws a wobbly (tm) with the0=nvidia param then change to 0=nv or
    vesa to get back to a default driver and lets us know if any errors are
    shown.

    HTH

    --
    Mark

    Nullus in verba
    Nil illigitimi carborundum


  9. #9
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: How to turn off the X Server?

    Note that you do not need to run sax2 merely to switch the drivers, there's a special command you can use as root: switch2nvidia or switch2nv depending on whether you want to use the binary driver (nvidia) or the open source driver (nv - nouveau)

  10. #10

    Default Re: How to turn off the X Server?

    uname -r
    2.6.25.20-0.1-default
    rpm -qa | grep -i kernel
    kernel-default-2.6.25.20-0.1
    rpm -qa | grep -i nvidia
    x11-video-nvidiaG01-173.14.18-0.1
    nvidia-gfxG02-kmp-default-180.51_2.6.25.20_0.1-1.1
    nvidia-gfxG01-kmp-default-173.14.18_2.6.25.20_0.1-0.1
    x11-video-nvidiaG02-180.51-1.1
    /etc/X11/xorg.conf (1)
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig: version 1.0 (buildmeister@builder62) Mon Mar 2 15:57:24 PST 2009

    # /.../
    # SaX generated X11 config file
    # Created on: 2009-05-19T19:33:19+0800.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "ServerLayout"
    Identifier "Layout[all]"
    Screen "Screen[0]" 0 0
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Option "Clone" "off"
    Option "Xinerama" "off"
    EndSection

    Section "Files"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    EndSection

    Section "Module"
    Load "freetype"
    Load "type1"
    Load "dbe"
    Load "glx"
    Load "extmod"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail" "on"
    Option "ZapWarning" "on"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard[0]"
    Driver "kbd"
    Option "Protocol" "Standard"
    Option "XkbLayout" "us"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    EndSection

    Section "InputDevice"
    Identifier "Mouse[1]"
    Driver "mouse"
    Option "Buttons" "5"
    Option "Device" "/dev/input/mice"
    Option "Name" "ImPS/2 Generic Wheel Mouse"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Modes"
    Identifier "Modes[0]"
    ModeLine "1360x768" 85 1360 1424 1536 1792 768 771 777 795 +hsync +vsync
    EndSection

    Section "Monitor"
    Identifier "Monitor[0]"
    VendorName "--> LCD"
    ModelName "1280X1024@75HZ"
    UseModes "Modes[0]"
    DisplaySize 410 230
    HorizSync 31.0 - 81.0
    VertRefresh 58.0 - 76.0
    Option "CalcAlgorithm" "XServerPool"
    Option "PreferredMode" "1280x1024"
    EndSection

    Section "Device"
    Identifier "Device[0]"
    Driver "nvidia"
    VendorName "NVidia"
    BoardName "GeForce 6100 nForce 430"
    Screen 0
    EndSection

    Section "Screen"
    Identifier "Screen[0]"
    Device "Device[0]"
    Monitor "Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    EndSection

    Section "Extensions"
    Option "Composite" "on"
    EndSection
    (1) this is the file which failed the test but I did notice /etc/X11/xorg.conf.nvidia-post file and so I copied that back over to xorg.conf file and I seem to have restored to where I always get 1024x768 problem. Here is the existing xorg.conf

    # /.../
    # SaX generated X11 config file
    # Created on: 2009-05-16T12:54:25+0800.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "Files"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail" "on"
    Option "ZapWarning" "on"
    EndSection

    Section "Module"
    Load "dbe"
    Load "type1"
    Load "freetype"
    Load "extmod"
    Load "glx"
    EndSection

    Section "InputDevice"
    Driver "kbd"
    Identifier "Keyboard[0]"
    Option "Protocol" "Standard"
    Option "XkbLayout" "us"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    EndSection


    Section "InputDevice"
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "Buttons" "5"
    Option "Device" "/dev/input/mice"
    Option "Name" "ImPS/2 Generic Wheel Mouse"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection


    Section "Monitor"
    Option "CalcAlgorithm" "XServerPool"
    DisplaySize 410 230
    HorizSync 30-81
    Identifier "Monitor[0]"
    ModelName "SYNCMASTER 931C (ANALOG)"
    Option "DPMS"
    Option "PreferredMode" "2800x2100"
    VendorName "SAMSUNG"
    VertRefresh 56-75
    UseModes "Modes[0]"
    EndSection


    Section "Modes"
    Identifier "Modes[0]"
    Modeline "1360x768" 85 1360 1424 1536 1792 768 771 777 795 +hsync +vsync
    EndSection


    Section "Screen"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "2800x2100" "2560x2048" "2560x1600" "2048x1536" "1920x1440" "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "2800x2100" "2560x2048" "2560x1600" "2048x1536" "1920x1440" "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "2800x2100" "2560x2048" "2560x1600" "2048x1536" "1920x1440" "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "2800x2100" "2560x2048" "2560x1600" "2048x1536" "1920x1440" "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection


    Section "Device"
    BoardName "GeForce 6100 nForce 430"
    BusID "0:13:0"
    Driver "nv"
    Identifier "Device[0]"
    Screen 0
    VendorName "NVidia"
    EndSection



    Section "ServerLayout"
    Identifier "Layout[all]"
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Option "Clone" "off"
    Option "Xinerama" "off"
    Screen "Screen[0]"
    EndSection


    Section "DRI"
    Group "video"
    Mode 0660
    EndSection

    Section "Extensions"
    Option "Composite" "off"
    EndSection
    SaX2 doesn't list my Samsung 933SN Monitor. So I tried -->LCD. but it's the same problem. SaX2 will only test at 1024x768 or lower. Anything higher defaults to 1024x768.

    No. I was afraid to logout at that point.


    Quote Originally Posted by Chrysantine View Post
    Well, first of all I'm going to need a little more information as to what you're trying to do, what you've done so far and what exactly is going on.

    First of all, open a terminal window and run the follow commands, then copy paste the results of those commands here:

    uname -r
    rpm -qa | grep -i kernel
    rpm -qa | grep -i nvidia

    and post your /etc/X11/xorg.conf fully in here, use the code [] tags to encase the results.

    Second of all, have you chosen a monitor in the sax2 that actually allows resolutions that you're trying to test? If in doubt, use a VESA or LCD monitor that corresponds to your physical device.

    And you of course rebooted (or at least logged out) after installing the driver, right?

Page 1 of 9 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •