Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: LG Monitor Problem Suse10.2 with Framebuffer

  1. #1

    Question LG Monitor Problem Suse10.2 with Framebuffer

    Hi Guys,

    I just got the opprtunity to use a very nice LG FLATRON W2252TQ monitor but when I plug it in, i get wrong graphics. It is not listed in Yast->Hardware->Graphics Card and Monitor and I also get the message that 'The configuration is Framebuffer based and your system does not support changes for resolution and/or color settings.' when opening this module.

    Some useful information to anyone who knows about that stuff:

    OS: Linux 2.6.18.8-0.9-default x86_64
    System: openSUSE 10.2 (X86-64)
    KDE: 3.5.5 "release 45.8"
    Processor (CPU): Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
    Speed: 1,600.00 MHz

    heuy:/home/anastasis # lspci
    00:00.0 Host bridge: Intel Corporation 82P965/G965 Memory Controller Hub (rev 02)
    00:02.0 VGA compatible controller: Intel Corporation 82G965 Integrated Graphics Controller (rev 02)

    display part (i think..) of saved to file hardware information:
    <6>vesafb: framebuffer at 0xe0000000, mapped to 0xffffc20010100000, using 6144k, total 7616k
    <6>vesafb: mode is 1024x768x16, linelength=2048, pages=3
    <6>vesafb: scrolling: redraw
    <6>vesafb: Truecolor: size=0:5:6:5, shift=0:11:5:0
    <6>bootsplash 3.1.6-2004/03/31: looking for picture...<6> silentjpeg size 81749 bytes,<6>...found (1024x768, 46202 bytes, v3).
    <4>Console: switching to colour frame buffer device 124x44
    <6>fb0: VESA VGA frame buffer device


    I would very much appreciate any help, I really need this monitor for my work. Thanks.

  2. #2
    Camalen NNTP User

    Default Re: LG Monitor Problem Suse10.2 with Framebuffer

    anastasisg wrote:

    > I just got the opprtunity to use a very nice LG FLATRON W2252TQ monitor
    > but when I plug it in, i get wrong graphics. It is not listed in
    > Yast->Hardware->Graphics Card and Monitor and I also get the message
    > that 'The configuration is -Framebuffer- based and your system does not
    > support changes for resolution and/or color settings.' when opening this
    > module.


    Check what driver is xorg using. If you are using an Intel integrated card,
    I think it should be using "intel" or "i810". In konsole, just run:

    ***
    cat /etc/X11/xorg.conf | grep Driver
    ***

    And tell us what it said.

    > Some useful information to anyone who knows about that stuff:
    >
    > OS: Linux 2.6.18.8-0.9-default x86_64
    > System: openSUSE 10.2 (X86-64)


    This version (10.2) is not getting security patches anymore (is
    unmaintained). You should think upgrading.

    Greetings,

    --
    Camalen

  3. #3

    Default Re: LG Monitor Problem Suse10.2 with Framebuffer

    Thank you very very much.
    This is what I get:

    anastis@heuy:~> cat /etc/X11/xorg.conf | grep Driver
    Driver "kbd"
    Driver "mouse"
    Driver "fbdev"

    Is this useful?

    Should I upgrade before installing the new monitor? I really have no time and it also took me a long time to configure the pc to work as it does now.. It has only a few small problems. I'm afraid that an upgrade will take a lot of time to reconfigure everything (all the programms i'm using everyday etc). But if I must..

  4. #4
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,937

    Default Re: LG Monitor Problem Suse10.2 with Framebuffer

    Your installation is using a generic video driver. To allow greater resolutions, 3D, etc., you have to install the correct driver for your video card, intel. This should have been done automatically during installation, as the intel drivers are opensurce and so are included in the installation DVD.

    You may want to try the DVD in repair mode to redetect *only* the video. Don't go reinstalling everything.

  5. #5
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,937

    Default Re: LG Monitor Problem Suse10.2 with Framebuffer

    Quote Originally Posted by anastasisg View Post
    Should I upgrade before installing the new monitor?
    You should, at least to 11.0/KDE3.5.9/10 which in very stable IMO. 11.1 with the latest updates seems good now, but gave me a lot of problems when it came out. About KDE4, ATM I'd consider only version 4.2.3. It's mostly usable. But is question of stability KDE3.5 is still way ahead.

    Don't upgrade, make a clean reinstall (except maybe /home). It will give you a better kernel, with improved hardware support,

    You can save your home directory (specially the hidden files) so that most configurations and application settings will work as before. Better still if your /home is in a different partition than / (root), in that case you only set it as /home in the new install without formatting it.

  6. #6
    Camalen NNTP User

    Default Re: LG Monitor Problem Suse10.2 with Framebuffer

    anastasisg wrote:

    > Thank you very very much.
    > This is what I get:
    >
    > anastis@heuy:~> cat /etc/X11/xorg.conf | grep Driver
    > Driver "kbd"
    > Driver "mouse"
    > Driver "fbdev"
    >
    > Is this useful?


    Yes. Well, that tell us your video card is not being recognized by Sax2 /
    Xorg and it defaults to VESA driver which may not delivery the best modes
    for your display.

    But I am not sure about the steps to change that O:-)

    Maybe you can first try this (if you are not afraid of the console). These
    steps involves going to init 3 (no graphical environment at all), force
    Sax2 to redetect the adapter and then going back to init 5 (kde).

    1. Going init 3 -> Press (at the same time) Ctrl + Alt + F1
    2. Login as root -> Type "su" and your root's password
    3. Reinit Sax2 -> Type "sax2 -r" to allow sax2 to rebuild its database
    4. Going back to init 5 -> Press (at the same time) Ctrl + Alt + F7

    Then go to "Yast->Hardware->Graphics Card and Monitor" and look for any
    change.

    If it remains the same (only Framebuffer option) just try again with steps
    1-4, but this time change step 3 to:

    "sax2 -r -m 0=intel" to force sax2 using "intel" driver

    or

    "sax2 -r -m 0=i810" to force sax2 using "i810" driver

    In openSUSE 10.2 I don't remember which of these ones (i810 or intel) is
    available for your card.

    > Should I upgrade before installing the new monitor? I really have no
    > time and it also took me a long time to configure the pc to work as it
    > does now.. It has only a few small problems. I'm afraid that an upgrade
    > will take a lot of time to reconfigure everything (all the programms i'm
    > using everyday etc). But if I must..


    Well, upgrading is not a "must" but a "should" :-)

    With upgrading you will get two direct benefits:

    1) Your video card and monitor will be properly detected (almost sure)
    2) You will get security patches

    I agree upgrading can be time consuming and may have some backdraws. But
    just think about it.

    Greetings,

    --
    Camalen

  7. #7
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: LG Monitor Problem Suse10.2 with Framebuffer

    Camaleón adjusted his/her AFDB on Monday 11 May 2009 09:01 to write:


    Sorry to butt in but:

    > Maybe you can first try this (if you are not afraid of the console). These
    > steps involves going to init 3 (no graphical environment at all), force
    > Sax2 to redetect the adapter and then going back to init 5 (kde).
    >
    > 1. Going init 3 -> Press (at the same time) Ctrl + Alt + F1
    > 2. Login as root -> Type "su" and your root's password


    Type:

    init 3

    > 3. Reinit Sax2 -> Type "sax2 -r" to allow sax2 to rebuild its database



    > 4. Going back to init 5 -> Press (at the same time) Ctrl + Alt + F7
    >


    Type:

    init 5

    just dropping to a terminal with the Ctrl+Alt+F1 does not put you in
    runlevel 3, you will still be in 5 and X will still be running on vt7

    > Then go to "Yast->Hardware->Graphics Card and Monitor" and look for any
    > change.
    >
    > If it remains the same (only Framebuffer option) just try again with steps
    > 1-4, but this time change step 3 to:
    >
    > "sax2 -r -m 0=intel" to force sax2 using "intel" driver
    >
    > or
    >
    > "sax2 -r -m 0=i810" to force sax2 using "i810" driver
    >
    > In openSUSE 10.2 I don't remember which of these ones (i810 or intel) is
    > available for your card.
    >
    >> Should I upgrade before installing the new monitor? I really have no
    >> time and it also took me a long time to configure the pc to work as it
    >> does now.. It has only a few small problems. I'm afraid that an upgrade
    >> will take a lot of time to reconfigure everything (all the programms i'm
    >> using everyday etc). But if I must..

    >
    > Well, upgrading is not a "must" but a "should" :-)
    >
    > With upgrading you will get two direct benefits:
    >
    > 1) Your video card and monitor will be properly detected (almost sure)
    > 2) You will get security patches
    >
    > I agree upgrading can be time consuming and may have some backdraws. But
    > just think about it.
    >
    > Greetings,
    >



    HTH

    --
    Mark

    Nullus in verba
    Nil illigitimi carborundum


  8. #8

    Default Re: LG Monitor Problem Suse10.2 with Framebuffer

    Thanks everybody. It seems that what Camaleon suggested actually worked (with i810). I did it and now I'm allowed to change the resolution, i.e. I don't get the 'The configuration is Framebuffer based..' message anymore. Although this model (FLATRON W2252TQ) is not in the list in Yast->Hardware->Graphics Card and Monitor, I chose -->LCD as monitor vendor with the correct resolution (1680x1050@60Hz) and the graphics seem ok. Small problem, I cannot choose the correct diagonal (my option are 21.3 and then 22.2, whereas the monitor is 22) and colors number (i get 16.7 Mio as the only option, whereas the monitor is 16.2 Mio) so I get two small black areas on both sides of the screen, but still much better than before.

    Thank you all very much for the valuable help.

  9. #9
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: LG Monitor Problem Suse10.2 with Framebuffer

    anastasisg adjusted his/her AFDB on Monday 11 May 2009 15:16 to write:

    >
    > Thanks everybody. It seems that what Camaleon suggested actually worked
    > (with i810). I did it and now I'm allowed to change the resolution, i.e.
    > I don't get the 'The configuration is Framebuffer based..' message
    > anymore. Although this model (FLATRON W2252TQ) is not in the list in
    > Yast->Hardware->Graphics Card and Monitor, I chose -->LCD as monitor
    > vendor with the correct resolution (1680x1050@60Hz) and the graphics
    > seem ok. Small problem, I cannot choose the correct diagonal (my option
    > are 21.3 and then 22.2, whereas the monitor is 22) and colors number (i
    > get 16.7 Mio as the only option, whereas the monitor is 16.2 Mio) so I
    > get two small black areas on both sides of the screen, but still much
    > better than before.
    >
    > Thank you all very much for the valuable help.
    >
    >


    Have you got the windows driver disk for that monitor?

    or can you d/load from the site?

    you can load the windows drivers ( which is only a text file with setting in
    ) on the monitor selection screen there should be a but to load from disk
    IIRC.

    HTH
    --
    Mark

    Nullus in verba
    Nil illigitimi carborundum


  10. #10
    Camalen NNTP User

    Default Re: LG Monitor Problem Suse10.2 with Framebuffer

    anastasisg wrote:

    > Thanks everybody. It seems that what Camaleon suggested actually worked
    > (with i810). I did it and now I'm allowed to change the resolution, i.e.
    > I don't get the 'The configuration is Framebuffer based..' message
    > anymore. Although this model (FLATRON W2252TQ) is not in the list in
    > Yast->Hardware->Graphics Card and Monitor, I chose -->LCD as monitor
    > vendor with the correct resolution (1680x1050@60Hz) and the graphics
    > seem ok.


    Glad it worked :-)

    There were missing steps, as Mark pointed.

    > Small problem, I cannot choose the correct diagonal (my option
    > are 21.3 and then 22.2, whereas the monitor is 22) and colors number (i
    > get 16.7 Mio as the only option, whereas the monitor is 16.2 Mio) so I
    > get two small black areas on both sides of the screen, but still much
    > better than before.


    Well, as per your display specs:

    http://www.lge.com/products/model/de...52tq_1_6.jhtml

    It seems 16.7 Mio is O.K.

    Just out of curiosity, what gives the following command?

    ***
    cat /etc/X11/xorg.conf | grep DisplaySize
    ***

    Greetings,

    --
    Camalen

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •