Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Applications on desktop no longer run

  1. #1

    Default Applications on desktop no longer run

    Since updating yesterday, applications on the desktop no longer work. The icon now says "Kmahjongg.desktop" instead of "Kmahjongg".
    Clicking on the icon brings up gedit instead of the game. recreating by clicking on "Add this launcher to desktop" results in the same thing.
    Running the application from "menu' works find. Home, Trash, and Drive icons are OK. Running SUSE-11.0 and Gnome-2.22.1

  2. #2

    Default Re: Applications on desktop no longer run

    I've updated the system twice since this began, and it is still happening.

  3. #3
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: Applications on desktop no longer run

    Maybe KDE is messing with you. Execute the following in gnome-terminal:
    Code:
    mw .kde4 .kde4.old
    ^^all KDE4 setting are going to be deleted!
    and relog into your Gnome session. Now try to add the icon again to your desktop.
    Hope that helps.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  4. #4

    Default Re: Applications on desktop no longer run

    Thanks very much for the reply. I can give that a try, but it's any icon (ie. Gimp, Mythtv, etc)
    I used the kde game as an example. Home, Trash, and the mounted drives are the only ones that work.

  5. #5

    Default Re: Applications on desktop no longer run

    Removing the .kde4 directory did not help.
    Here is the file .xsession-errors, I don't see anything obvious
    Code:
    don@don ~ $ more /media/disk-1/home/don/.xsession-errors
    chown: changing ownership of `/dev/xconsole': Operation not permitted
    chmod: changing permissions of `/dev/xconsole': Operation not permitted
    /etc/X11/xim: Checking whether an input method should be started.
    /etc/X11/xim: user environment variable LANG=en_US.UTF-8
    sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
    INPUT_METHOD is not set or empty (no user selected input method).
    Trying to start a default input method for the locale en_US.UTF-8 ...
    There is no default input method for the current locale.
    Warning:          No symbols defined for <SYRQ> (keycode 92)
    Warning:          No symbols defined for <II5D> (keycode 93)
    Warning:          No symbols defined for <II65> (keycode 101)
    Warning:          No symbols defined for <BRK> (keycode 114)
    Warning:          No symbols defined for <FK13> (keycode 118)
    Warning:          No symbols defined for <FK14> (keycode 119)
    Warning:          No symbols defined for <FK15> (keycode 120)
    Warning:          No symbols defined for <FK16> (keycode 121)
    Warning:          No symbols defined for <FK17> (keycode 122)
    Warning:          No symbols defined for <KPDC> (keycode 123)
    Warning:          No symbols defined for <XFER> (keycode 129)
    Warning:          No symbols defined for <I02> (keycode 130)
    Warning:          No symbols defined for <NFER> (keycode 131)
    Warning:          No symbols defined for <I04> (keycode 132)
    Warning:          No symbols defined for <AE13> (keycode 133)
    Warning:          No symbols defined for <I06> (keycode 134)
    Warning:          No symbols defined for <I07> (keycode 135)
    Warning:          No symbols defined for <I08> (keycode 136)
    Warning:          No symbols defined for <I09> (keycode 137)
    Warning:          No symbols defined for <I0A> (keycode 138)
    Warning:          No symbols defined for <I0B> (keycode 139)
    Warning:          No symbols defined for <I0C> (keycode 140)
    Warning:          No symbols defined for <I0D> (keycode 141)
    Warning:          No symbols defined for <I0E> (keycode 142)
    Warning:          No symbols defined for <I0F> (keycode 143)
    Warning:          No symbols defined for <I11> (keycode 145)
    Warning:          No symbols defined for <I12> (keycode 146)
    Warning:          No symbols defined for <I13> (keycode 147)
    Warning:          No symbols defined for <I14> (keycode 148)
    Warning:          No symbols defined for <I15> (keycode 149)
    Warning:          No symbols defined for <I16> (keycode 150)
    Warning:          No symbols defined for <I17> (keycode 151)
    Warning:          No symbols defined for <I18> (keycode 152)
    Warning:          No symbols defined for <I1A> (keycode 154)
    Warning:          No symbols defined for <I1B> (keycode 155)
    Warning:          No symbols defined for <K59> (keycode 157)
    Warning:          No symbols defined for <I1E> (keycode 158)
    Warning:          No symbols defined for <I1F> (keycode 159)
    Warning:          No symbols defined for <I23> (keycode 163)
    Warning:          No symbols defined for <I25> (keycode 165)
    Warning:          No symbols defined for <I26> (keycode 166)
    Warning:          No symbols defined for <I27> (keycode 167)
    Warning:          No symbols defined for <I28> (keycode 168)
    Warning:          No symbols defined for <I29> (keycode 169)
    Warning:          No symbols defined for <K5A> (keycode 170)
    Warning:          No symbols defined for <I2B> (keycode 171)
    Warning:          No symbols defined for <I2C> (keycode 172)
    Warning:          No symbols defined for <I2D> (keycode 173)
    Warning:          No symbols defined for <I2F> (keycode 175)
    Warning:          No symbols defined for <I31> (keycode 177)
    Warning:          No symbols defined for <I33> (keycode 179)
    Warning:          No symbols defined for <I34> (keycode 180)
    Warning:          No symbols defined for <K5B> (keycode 181)
    Warning:          No symbols defined for <K5D> (keycode 182)
    Warning:          No symbols defined for <K5E> (keycode 183)
    Warning:          No symbols defined for <K5F> (keycode 184)
    Warning:          No symbols defined for <I39> (keycode 185)
    Warning:          No symbols defined for <I3A> (keycode 186)
    Warning:          No symbols defined for <I3B> (keycode 187)
    Warning:          No symbols defined for <I3C> (keycode 188)
    Warning:          No symbols defined for <K62> (keycode 189)
    Warning:          No symbols defined for <K63> (keycode 190)
    Warning:          No symbols defined for <K64> (keycode 191)
    Warning:          No symbols defined for <K65> (keycode 192)
    Warning:          No symbols defined for <K66> (keycode 193)
    Warning:          No symbols defined for <I42> (keycode 194)
    Warning:          No symbols defined for <I43> (keycode 195)
    Warning:          No symbols defined for <I44> (keycode 196)
    Warning:          No symbols defined for <I45> (keycode 197)
    Warning:          No symbols defined for <K67> (keycode 198)
    Warning:          No symbols defined for <K68> (keycode 199)
    Warning:          No symbols defined for <K69> (keycode 200)
    Warning:          No symbols defined for <K6A> (keycode 201)
    Warning:          No symbols defined for <I4A> (keycode 202)
    Warning:          No symbols defined for <K6B> (keycode 203)
    Warning:          No symbols defined for <K6C> (keycode 204)
    Warning:          No symbols defined for <K6D> (keycode 205)
    Warning:          No symbols defined for <K6E> (keycode 206)
    Warning:          No symbols defined for <K6F> (keycode 207)
    Warning:          No symbols defined for <HKTG> (keycode 208)
    Warning:          No symbols defined for <KANA> (keycode 209)
    Warning:          No symbols defined for <EISU> (keycode 210)
    Warning:          No symbols defined for <AB11> (keycode 211)
    Warning:          No symbols defined for <I54> (keycode 212)
    Warning:          No symbols defined for <I55> (keycode 213)
    Warning:          No symbols defined for <I5A> (keycode 218)
    Warning:          No symbols defined for <K74> (keycode 219)
    Warning:          No symbols defined for <K75> (keycode 220)
    Warning:          No symbols defined for <K76> (keycode 221)
    Warning:          No symbols defined for <I5E> (keycode 222)
    Warning:          No symbols defined for <I60> (keycode 224)
    Warning:          No symbols defined for <I61> (keycode 225)
    Warning:          No symbols defined for <I62> (keycode 226)
    Warning:          No symbols defined for <I63> (keycode 227)
    Warning:          No symbols defined for <I64> (keycode 228)
    Warning:          No symbols defined for <I6E> (keycode 238)
    Warning:          No symbols defined for <I6F> (keycode 239)
    Warning:          No symbols defined for <I70> (keycode 240)
    Warning:          No symbols defined for <I71> (keycode 241)
    Warning:          No symbols defined for <I72> (keycode 242)
    Warning:          No symbols defined for <I73> (keycode 243)
    Warning:          No symbols defined for <I74> (keycode 244)
    Warning:          No symbols defined for <I75> (keycode 245)
    Warning:          No symbols defined for <I76> (keycode 246)
    Warning:          No symbols defined for <I77> (keycode 247)
    Warning:          No symbols defined for <I78> (keycode 248)
    Warning:          No symbols defined for <I79> (keycode 249)
    Warning:          No symbols defined for <I7A> (keycode 250)
    Warning:          No symbols defined for <I7B> (keycode 251)
    Warning:          No symbols defined for <I7C> (keycode 252)
    Warning:          No symbols defined for <I7D> (keycode 253)
    Warning:          No symbols defined for <I7E> (keycode 254)
    Warning:          No symbols defined for <I7F> (keycode 255)
    
    (gnome-session:2838): atk-bridge-WARNING **: AT_SPI_REGISTRY was not started at 
    session startup.
    
    (gnome-session:2838): atk-bridge-WARNING **: IOR not set.
    
    (gnome-session:2838): atk-bridge-WARNING **: Could not locate registry
    SESSION_MANAGER=local/linux-nocz:@/tmp/.ICE-unix/2838,unix/linux-nocz:/tmp/.ICE-
    unix/2838
    ** Message: another SSH agent is running at: /tmp/ssh-ukuXB2838/agent.2838
    Xlib:  extension "XEVIE" missing on display ":0.0".
    seahorse nautilus module initialized
    Initializing nautilus-share extension
    Initializing nautilus-open-terminal extension
    W: core-util.c: setpriority(): Permission denied
    E: main.c: daemon startup failed.
    GSynaptics couldn't initialize.
    You have to set 'SHMConfig' 'true' in xorg.conf or XFree86.conf to use GSynaptic
    s
    11
    Failed to connect to cupsd
    Failed to connect to cupsd
    
    ** (nautilus:2983): WARNING **: Unable to add monitor: Not supported
    evolution-alarm-notify-Message: Setting timeout for 56316 1242878400 1242822084
    evolution-alarm-notify-Message:  Thu May 21 00:00:00 2009
    
    evolution-alarm-notify-Message:  Wed May 20 08:21:24 2009
    
    Window manager warning: CurrentTime used to choose focus window; focus window ma
    y not be correct.
    alarm-notify.c:239 (alarm_notify_init) - Initing Alarm Notify
    alarm-queue.c:1859 (alarm_queue_init)
    alarm-queue.c:232 (queue_midnight_refresh) - Refresh at Thu May 21 00:00:00 2009
     
    alarm-notify.c:216 (load_calendars) - Loading Calendar file:///home/don/.evoluti
    on/calendar/local/system 
    alarm-notify.c:388 (alarm_notify_add_calendar) file:///home/don/.evolution/calen
    dar/local/system - Calendar Open Async... 0x689200
    alarm-notify.c:216 (load_calendars) - Loading Calendar contacts:/// 
    alarm-notify.c:388 (alarm_notify_add_calendar) contacts:/// - Calendar Open Asyn
    c... 0x689240
    alarm-notify.c:216 (load_calendars) - Loading Calendar file:///home/don/.evoluti
    on/tasks/local/system 
    alarm-notify.c:388 (alarm_notify_add_calendar) file:///home/don/.evolution/tasks
    /local/system - Calendar Open Async... 0x713e00
    alarm-notify.c:216 (load_calendars) - Loading Calendar file:///home/don/.evoluti
    on/memos/local/system 
    alarm-notify.c:388 (alarm_notify_add_calendar) file:///home/don/.evolution/memos
    /local/system - Calendar Open Async... 0x7f4e10001200
    alarm-notify.c:316 (cal_opened_cb) file:///home/don/.evolution/calendar/local/sy
    stem - Calendar Status 0
    alarm-notify.c:316 (cal_opened_cb) file:///home/don/.evolution/tasks/local/syste
    m - Calendar Status 0
    alarm-notify.c:316 (cal_opened_cb) contacts:/// - Calendar Status 0
    alarm-queue.c:1993 (alarm_queue_add_async) - 0x689200
    alarm-notify.c:316 (cal_opened_cb) file:///home/don/.evolution/memos/local/syste
    m - Calendar Status 0
    alarm-queue.c:607 (load_alarms_for_today) - From Wed May 20 08:21:28 2009
     to Wed May 20 08:21:28 2009
    
    alarm-queue.c:544 (load_alarms) 
    alarm-queue.c:573 (load_alarms) - Setting Call backs 
    alarm-queue.c:1993 (alarm_queue_add_async) - 0x713e00
    alarm-queue.c:607 (load_alarms_for_today) - From Wed May 20 08:21:29 2009
     to Wed May 20 08:21:29 2009
    
    alarm-queue.c:544 (load_alarms) 
    alarm-queue.c:573 (load_alarms) - Setting Call backs 
    alarm-queue.c:1993 (alarm_queue_add_async) - 0x689240
    alarm-queue.c:607 (load_alarms_for_today) - From Wed May 20 08:21:29 2009
     to Wed May 20 08:21:29 2009
    
    alarm-queue.c:544 (load_alarms) 
    alarm-queue.c:573 (load_alarms) - Setting Call backs 
    alarm-queue.c:1993 (alarm_queue_add_async) - 0x7f4e10001200
    alarm-queue.c:607 (load_alarms_for_today) - From Wed May 20 08:21:29 2009
     to Wed May 20 08:21:29 2009
    
    alarm-queue.c:544 (load_alarms) 
    alarm-queue.c:573 (load_alarms) - Setting Call backs 
    alarm-notify.c:270 (alarm_notify_finalize) - Finalize 
     alarm-notify.c:255 (dequeue_client) - Removing client 0x689240
     alarm-queue.c:2102 (alarm_queue_remove_async) 
    alarm-queue.c:2075 (remove_client_alarms) - size 0 
    alarm-queue.c:2107 (alarm_queue_remove_async) - Disconnecting Client 
    alarm-queue.c:2116 (alarm_queue_remove_async) - Disconnecting Query 
    alarm-notify.c:255 (dequeue_client) - Removing client 0x689200
     alarm-queue.c:2102 (alarm_queue_remove_async) 
    alarm-queue.c:2075 (remove_client_alarms) - size 0 
    alarm-queue.c:2107 (alarm_queue_remove_async) - Disconnecting Client 
    alarm-queue.c:2116 (alarm_queue_remove_async) - Disconnecting Query 
    alarm-notify.c:255 (dequeue_client) - Removing client 0x713e00
     alarm-queue.c:2102 (alarm_queue_remove_async) 
    alarm-queue.c:2075 (remove_client_alarms) - size 0 
    alarm-queue.c:2107 (alarm_queue_remove_async) - Disconnecting Client 
    alarm-queue.c:2116 (alarm_queue_remove_async) - Disconnecting Query 
    alarm-notify.c:255 (dequeue_client) - Removing client 0x7f4e10001200
     alarm-queue.c:2102 (alarm_queue_remove_async) 
    alarm-queue.c:2075 (remove_client_alarms) - size 0 
    alarm-queue.c:2107 (alarm_queue_remove_async) - Disconnecting Client 
    alarm-queue.c:2116 (alarm_queue_remove_async) - Disconnecting Query 
    alarm-queue.c:1930 (alarm_queue_done)
    Window manager warning: Got a request to focus the no_focus_window with a timest
    amp of 0.  This shouldn't happen!
    Shutting down nautilus-open-terminal extension
    seahorse nautilus module shutdown
    
    (resapplet:2997): GLib-GObject-CRITICAL **: g_object_notify: assertion `G_IS_OBJ
    ECT (object)' failed
    
    (resapplet:2997): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJE
    CT (object)' failed

  6. #6

    Default Re: Applications on desktop no longer run

    As you said gnome I wonder whether this is the same as for a few other DE's.

    Try running nautilus, if I got this correctly nautilus isn't running therefore the desktop is behaving strangely.

    Here I think they're trying to replicate the behaviour you've got. i.e desktop is desktop.

    Run Nautilus file manager sans GNOME desktop Linux and Friends

    I say this as I noticed this which is similar to what I encounter in lxde.. So if you start nautilus does it behave properly then?
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

  7. #7

    Default Re: Applications on desktop no longer run

    Nautilus would appear to be running.
    Code:
    don@linux-nocz:~> ps -e |grep nautilus
     2981 ?        00:00:00 nautilus
    Running nautilus brings up the file manager in my home directory, same as clicking on the Home icon on the Desktop,
    which as I said is one of them that works.

  8. #8

    Default Re: Applications on desktop no longer run

    Ok what happens if you run gnomevfs-info on the file? Also does it match the one that works extracting the info from here as I'm not a gnome user.
    Modifying MIME types
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

  9. #9

    Default Re: Applications on desktop no longer run

    I just updated as well, and the first time I logged in, all my desktop icons looked disabled with a "gear" icon. The first time I clicked them, I got a popup basically asking "Are you sure you want to run this?", after clicking OK it worked just fine and the icon went back to normal.

    Is your Desktop Folder a "Folder View" widget?

  10. #10

    Default Re: Applications on desktop no longer run

    Thanks for all the replies. Some progress is being made. Here is gnomevfs-info run on the SuSe system.
    Code:
    don@linux-nocz:~/Desktop> gnomevfs-info mythfrontend.desktop
    Name              : mythfrontend.desktop
    Type              : Regular
    MIME type         : application/octet-stream
    Size              : 198
    Blocks            : 16
    I/O block size    : 4096
    Local             : YES
    SUID              : NO
    SGID              : NO
    Sticky            : NO
    Permissions       : 600644
    Link count        : 1
    UID               : 1000
    GID               : 100
    Access time       : Thu May 21 07:58:50 2009
    Modification time : Fri Nov 21 16:23:51 2008
    Change time       : Fri Nov 21 16:23:52 2008
    Device #          : 2054
    Inode #           : 944109
    Readable          : YES
    Writable          : YES
    Executable        : NO
    Notice MIME-type

    Now here is gnomevfs-info run on the same file from my Gentoo system.
    Code:
    don@don /media/disk/home/don/Desktop $ gnomevfs-info mythfrontend.desktop
    Name              : mythfrontend.desktop
    Type              : Regular
    MIME type         : application/x-desktop
    Size              : 198
    Blocks            : 16
    I/O block size    : 4096
    Local             : YES
    SUID              : NO
    SGID              : NO
    Sticky            : NO
    Permissions       : 600644
    Link count        : 1
    UID               : 1000
    GID               : 100
    Access time       : Thu May 21 08:24:19 2009
    Modification time : Fri Nov 21 16:23:51 2008
    Change time       : Fri Nov 21 16:23:52 2008
    Device #          : 2054
    Inode #           : 944109
    Readable          : YES
    Writable          : YES
    Executable        : NO
    It appears that the file itself is ok and the problem is in gnome. Any ideas where to look? There have been
    no errors on any of the updates. I did run a mime-update-database, but it did not seem to do anything.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •