Results 1 to 7 of 7

Thread: windows 7 overwritten my opensuse bootloader

  1. #1

    Default windows 7 overwritten my opensuse bootloader

    Hi.
    i was using opensuse 11.1 and yesterday i installed windows 7 RC 7100 and it has overwritten grub loader.now i can not boot into opensuse. what should i do?

    thanks

  2. #2
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: windows 7 overwritten my opensuse bootloader

    autofocus adjusted his/her AFDB on Monday 18 May 2009 00:56 to write:

    >
    > Hi.
    > i was using opensuse 11.1 and yesterday i installed windows 7 RC 7100
    > and it has overwritten grub loader.now i can not boot into opensuse.
    > what should i do?
    >
    > thanks
    >
    >



    Boot with the SuSE cd/dvd and either see if the repair section will fix it
    or boot the installed system with it and use YaST to re-install the
    bootloader.

    HTH
    --
    Mark

    Nullus in verba
    Nil illigitimi carborundum


  3. #3
    Join Date
    Aug 2008
    Location
    Allentown, PA
    Posts
    22

    Default Re: windows 7 overwritten my opensuse bootloader

    I had the same issue and I could never get the repaired grub to work correctly. It has been frustrating because it was working fine till I upgraded my beta to the release candidate and got the grub written over.

    -Marc

  4. #4
    Join Date
    Dec 2008
    Location
    (Canada)
    Posts
    773

    Smile Re: windows 7 overwritten my opensuse bootloader

    Ooh boy you should install first win7,winxp or win2000 and after linux(suse,mandriva....) that should be the way.

    autofocus,
    you have no choice to reinstall win7 first and after wards Linux (Suse)

    Good Luck

    Mike
    Motherboard MSI X58 Eclipse,320GB intern.HD,400GB Ext.HD,1.5TB intern.HD,6GB ram.Dual ViewSonic VX1962WM Monitor,Zip drive 250MB,HPpsc 2410 printer and Logitech G51 speakers

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,424
    Blog Entries
    14

    Default Re: windows 7 overwritten my opensuse bootloader

    NOT TRUE !!! You can install in any order, just be aware that you will have to repair GRUB.
    You could say it's less tricky, but it's definitely not true, that you annot install anything after a openSUSE install. More easy does not mean the only way.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6

    Default Re: windows 7 overwritten my opensuse bootloader

    I had the same problem, but I put in the suse cd. I clicked repair, then expert, then bootloader, It re-installed the grub. Now the grub loads but theres no option to load to windows(xp). My question is after that how do u configure bootloader to load windows
    ?

  7. #7
    Join Date
    Aug 2008
    Location
    Allentown, PA
    Posts
    22

    Default Re: windows 7 overwritten my opensuse bootloader

    OK this is done fairly painlessly. FAIRLY Since you have OpenSUSE working in grub you can use these steps.

    First you need to know the partitions:
    Code:
    fdisk -l
    Then with the partitions listed out edit your /boot/grub/menu.lst

    Code:
    >su -
    # kwrite /boot/grub/menu.lst
    Now my example will be differnt then yours. I have Windows 7 on partitions 1 and 2
    OpenSUSE is on partition 6
    Swap is on partition 5
    Home is on partition 7

    Code:
    # Modified by YaST2. Last modification on Mon Jun  1 03:21:24 EDT 2009
    default 0
    timeout 8
    gfxmenu (hd0,5)/boot/message
    ##YaST - activate
    
    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title SUSE LINUX 
        root (hd0,5)
        kernel /boot/vmlinuz root=/dev/disk/by-id/ata-ST3500410AS_5VM0TB2D-part6    repair=1 resume=/dev/disk/by-id/ata-ST3500410AS_5VM0TB2D-part5 splash=silent showopts vga=0x31a
        initrd /boot/initrd
    
    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- SUSE LINUX 
        root (hd0,5)
        kernel /boot/vmlinuz root=/dev/disk/by-id/ata-ST3500410AS_5VM0TB2D-part6 showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x31a
        initrd /boot/initrd
    
    title Windows 7 RC
        rootnoverify (hd0,1)
        chainloader +1
    Change only the Windows section (Bold for emphasis. Since Windows is on partition 1 and 2 I pointed to the second one by the (hd0, 1) This should be the only variable you will have to mess with.

    Save your menu.lst and you should be fine for Windows.

    Hope this helps.

    -Marc

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •