I installed openSUSE 11.1 with KDE4. The initial login was normal and I then set up my detailed video options from within KDE. After restarting the xserver everything was fine. However when I now log in to KDE the keyboard doesn't work at all.
It seems to be a KDE4 issue because if I log out using the mouse (which is absolutely fine) the keyboard still works on the logon screen so kdm isn't a problem, and if I drop to a tty logon all is completely normal as well.
I'm using a usb keyboard so I tried a ps2 keyboard which gives identical results.
As the keyboard worked in KDE4 on the initial installation login I copied the original xorg.conf back, but that also results in a completely non-functioning keyboard.
I've tried removing all detail from the input devices sections in xorg.conf, removing the keyboard and mouse devices (keyboard is /dev/gpmdata which doesn't seem to exist), and putting in an option in the keyboard section to stop evdev. None made any difference - all fine on a tty and kdm logon screen, and keyboard completely unresponsive in KDE4 with the mouse normal.
If I log on to icewm instead of KDE4 the keyboard is fine.
When in KDE4 the keyboard is recognised, using an event character device in /dev/input, with the keyboard name/type linked to it in /dev/input/by-id
My mobo is an ASUS G43/ICH10 with an Intel core2duo 7400 cpu and 4GB memory. I'm using the onboard Intel GMA4500 graphics with the intel driver.
I could remove KDE4 and install KDE 3.5 (which works perfectly on Debian on this machine), but taking a look at KDE4 was part of the reason for installing openSUSE so I'd like to sort this if I can.

Thanks

Barrie