Results 1 to 10 of 10

Thread: Update and repo problems!!!!!!!!!!!!!!1

  1. #1

    Default Update and repo problems!!!!!!!!!!!!!!1

    Every time I try to install a program my Yast loads, and I get the message:

    - 'repo2solv.sh' '-o' '/var/cache/zypp/solv/repo-update/solv' '/var/cache/zypp/raw/repo-update'

    gzip: deltainfo.xml.gz: invalid compressed data--format violated
    repo_updateinfoxml: not well-formed (invalid token) at line 3494:33


    I have no idea what is wrong, and I need Nvidia drivers and it says they are unavailable, even though I had them with my previous installation of SUSE.
    Please help.

  2. #2
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    921

    Default Re: Update and repo problems!!!!!!!!!!!!!!1

    Need more info. Which version of openSUSE and are you using KDE or Gnome?

  3. #3

    Default

    Using 11.1 w/ KDE 4

  4. #4

    Default Re: Update and repo problems!!!!!!!!!!!!!!1

    !!!!!!!!!!!!!!1


    (SCNR)

  5. #5
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    921

    Default Re: Update and repo problems!!!!!!!!!!!!!!1

    Code:
    zypper ref
    Code:
    zypper verify
    Type these commands one at a time in a terminal as root. This will tell you if you have any dependency problems, and it will offer to install the needed packages.

  6. #6

    Default Re: Update and repo problems!!!!!!!!!!!!!!1

    zypper ref
    Repository '11.1 - VideoLan' is up to date.
    Download (curl) error for 'http://download.nvidia.com/opensuse/11.1/repodata/repomd.xml':
    Error code: Connection failed
    Error message: Couldn't resolve host 'http.download.nvidia.com'

    Abort, retry, ignore? [A/r/i]: i
    Error retrieving metadata for 'NVIDIA Repository':
    Download (curl) error for 'http://download.nvidia.com/opensuse/11.1/repodata/repomd.xml':
    Error code: Connection failed
    Error message: Couldn't resolve host 'http.download.nvidia.com'

    Skipping repository 'NVIDIA Repository' because of the above error.
    Repository 'openSUSE-11.1-Non-Oss' is up to date.
    Repository 'openSUSE-11.1-Oss' is up to date.
    Repository 'openSUSE-11.1-Update' is up to date.
    Building repository 'openSUSE-11.1-Update' cache [done]
    Error building the cache:
    'repo2solv.sh' '-o' '/var/cache/zypp/solv/repo-update/solv' '/var/cache/zypp/raw/repo-update'

    gzip: deltainfo.xml.gz: invalid compressed data--format violated
    repo_updateinfoxml: not well-formed (invalid token) at line 3494:33

    Skipping repository 'openSUSE-11.1-Update' because of the above error.
    Some of the repositories have not been refreshed because of an error.

  7. #7

    Default Re: Update and repo problems!!!!!!!!!!!!!!1

    zypper verify
    Download (curl) error for 'http://download.nvidia.com/opensuse/11.1/repodata/repomd.xml':
    Error code: Connection failed
    Error message: Couldn't resolve host 'http.download.nvidia.com'

    Abort, retry, ignore? [A/r/i]: i
    Error retrieving metadata for 'NVIDIA Repository':
    Download (curl) error for 'http://download.nvidia.com/opensuse/11.1/repodata/repomd.xml':
    Error code: Connection failed
    Error message: Couldn't resolve host 'http.download.nvidia.com'

    Warning: Disabling repository 'NVIDIA Repository' because of the above error.
    Building repository 'openSUSE-11.1-Update' cache [done]
    Error building the cache:
    'repo2solv.sh' '-o' '/var/cache/zypp/solv/repo-update/solv' '/var/cache/zypp/raw/repo-update'

    gzip: deltainfo.xml.gz: invalid compressed data--format violated
    repo_updateinfoxml: not well-formed (invalid token) at line 3494:33

    Warning: Disabling repository 'openSUSE-11.1-Update' because of the above error.
    Loading repository data...
    Reading installed packages...
    Dependencies of all installed packages are satisfied.

  8. #8
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    921

    Default Re: Update and repo problems!!!!!!!!!!!!!!1

    There's another poster in this forum who is getting the same error with the update server. Looks like you're going to have to wait for the nvidia and update servers to come back up.

  9. #9
    Join Date
    Jan 2009
    Location
    MA
    Posts
    48

    Default Re: Update and repo problems!!!!!!!!!!!!!!1

    Ha that cracked me up.

    Quote Originally Posted by Akoellh View Post


    (SCNR)

  10. #10
    Join Date
    Jan 2009
    Location
    MA
    Posts
    48

    Default Re: Update and repo problems!!!!!!!!!!!!!!1

    Well that explains why I haven't been able to get any updates recently over the past couple of weeks.

    Quote Originally Posted by pilotgi View Post
    There's another poster in this forum who is getting the same error with the update server. Looks like you're going to have to wait for the nvidia and update servers to come back up.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •