Every time I try to install a program my Yast loads, and I get the message:

- 'repo2solv.sh' '-o' '/var/cache/zypp/solv/repo-update/solv' '/var/cache/zypp/raw/repo-update'

gzip: deltainfo.xml.gz: invalid compressed data--format violated
repo_updateinfoxml: not well-formed (invalid token) at line 3494:33


I have no idea what is wrong, and I need Nvidia drivers and it says they are unavailable, even though I had them with my previous installation of SUSE.
Please help.