Results 1 to 2 of 2

Thread: Dependency problems for KDE4.2 (one click install)

  1. #1

    Default Dependency problems for KDE4.2 (one click install)

    I have a new installation of opensuse11.1 from live cd.
    I get the following problems when trying to upgrade to kde 4.2 via one click installation found at opensuse.org.

    There are a lot i'll post what i can...
    Tell me what should i do.. what should i ignore what should i pre-install before going for kde4.2 and make it work fine...
    Thanks.

    #### YaST2 conflicts list - generated 2009-05-28 20:27:13 ####

    kde4-kget-4.2.3-1.7.x86_64 requires libplasma.so.3()(64bit), but this requirement cannot be provided
    uninstallable providers: libkde4-4.2.3.1-1.5.x86_64[KDE:42]
    [ ] install libkde4-4.2.3.1-1.5.x86_64 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service

    [ ] do not install kde4-kget-4.2.3-1.7.x86_64

    [ ] Ignore some dependencies of kde4-kget



    kde4-plasmoid-quickaccess-0.7.1-4.18.x86_64 requires libplasma.so.2()(64bit), but this requirement cannot be provided
    uninstallable providers: kdebase4-workspace-4.1.3-10.2.1.x86_64[repo-update]
    kdebase4-workspace-4.1.3-10.3.7.x86_64[repo-update]
    [ ] Following actions will be done:
    do not install kdebase4-workspace-4.2.3-1.5.x86_64
    do not install kde4-kfloppy-4.2.3-1.5.x86_64
    do not install kde4-keditbookmarks-4.2.3-2.6.x86_64
    do not install kde4-kdessh-4.2.3-1.5.x86_64
    do not install kde4-kcalc-4.2.3-1.5.x86_64
    do not install kde4-ark-4.2.3-1.5.x86_64
    do not install kde4-kdf-4.2.3-1.5.x86_64
    [ ] install kde4-plasmoid-quickaccess-0.8-3.7.x86_64 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service

    [ ] Ignore some dependencies of kde4-plasmoid-quickaccess



    kdelibs4-4.1.3-4.9.x86_64 requires libkde4 = 4.1.3, but this requirement cannot be provided
    uninstallable providers: libkde4-4.1.3-4.10.4.i586[repo-update]
    libkde4-4.1.3-4.10.4.x86_64[repo-update]
    [ ] Following actions will be done:
    do not install kde4-kate-4.2.3-1.6.x86_64
    do not install kde4-kdf-4.2.3-1.5.x86_64
    do not install kde4-ark-4.2.3-1.5.x86_64
    do not install kde4-kcalc-4.2.3-1.5.x86_64
    do not install kde4-kdessh-4.2.3-1.5.x86_64
    do not install kde4-keditbookmarks-4.2.3-2.6.x86_64
    do not install kde4-kfloppy-4.2.3-1.5.x86_64
    do not install kde4-kgpg-4.2.3-1.5.x86_64
    do not install kde4-kmix-4.2.3-1.6.x86_64
    do not install kde4-kdepasswd-4.2.3-2.6.x86_64
    [ ] install kdelibs4-4.2.3.1-1.5.x86_64 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service

    [ ] Ignore some dependencies of kdelibs4



    compiz-kde4-0.7.8-9.1.x86_64 requires libplasma.so.2()(64bit), but this requirement cannot be provided
    uninstallable providers: kdebase4-workspace-4.1.3-10.2.1.x86_64[repo-update]
    kdebase4-workspace-4.1.3-10.3.7.x86_64[repo-update]
    [ ] Following actions will be done:
    do not install kde4-kwin-4.2.3-1.5.x86_64
    do not install kde4-kdepasswd-4.2.3-2.6.x86_64
    do not install kde4-kfloppy-4.2.3-1.5.x86_64
    do not install kde4-keditbookmarks-4.2.3-2.6.x86_64
    do not install kde4-kdessh-4.2.3-1.5.x86_64
    do not install kde4-kcalc-4.2.3-1.5.x86_64
    do not install kde4-ark-4.2.3-1.5.x86_64
    do not install kde4-kdf-4.2.3-1.5.x86_64
    [ ] Following actions will be done:
    downgrade of compiz-kde4-0.7.8-9.1.x86_64 to compiz-kde4-0.7.8-8.7.x86_64
    install compiz-kde4-0.7.8-8.7.x86_64 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service
    [ ] Ignore some dependencies of compiz-kde4



    kde4-korganizer-4.2.3-2.6.x86_64 requires libkdepim4 = 4.2.3, but this requirement cannot be provided
    uninstallable providers: libkdepim4-4.2.3-2.6.x86_64[KDE:42]
    libkdepim4-4.2.3-2.6.i586[KDE:42]
    [ ] install libkdepim4-4.2.3-2.6.x86_64 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service

    [ ] do not install kde4-korganizer-4.2.3-2.6.x86_64

    [ ] Ignore some dependencies of kde4-korganizer



    kde4-korganizer-4.1.3-3.11.x86_64 requires kdepimlibs4 < 4.1.60, but this requirement cannot be provided
    uninstallable providers: kdepimlibs4-4.1.3-5.2.6.x86_64[repo-update]
    kdepimlibs4-4.1.3-5.2.6.i586[repo-update]
    [ ] install kdepim4-4.2.3-2.6.x86_64 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service

    [ ] Ignore some dependencies of kde4-korganizer



    kde4-kreversi-4.2.3-1.5.x86_64 requires kdegames4 >= 4.2.3, but this requirement cannot be provided
    uninstallable providers: kdegames4-4.2.3-1.5.x86_64[KDE:42]
    kdegames4-4.2.3-1.5.i586[KDE:42]
    [ ] do not install kde4-kreversi-4.2.3-1.5.x86_64

    [ ] install kdegames4-carddecks-default-4.2.3-3.1.noarch (with vendor change)
    openSUSE
    -->
    openSUSE Build Service

    [ ] Ignore some dependencies of kde4-kreversi



    libkdegames4-4.1.3-3.9.x86_64 requires kdegames4-carddecks-default = 4.1.3, but this requirement cannot be provided

    [ ] Ignore some dependencies of libkdegames4

    [ ] do not install kde4-kpat-4.2.3-1.5.x86_64

    [ ] install libkdegames4-4.2.3-1.5.x86_64 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service



    kde4-kopete-4.2.3-1.7.x86_64 requires kdepimlibs4 >= 4.2.3, but this requirement cannot be provided
    uninstallable providers: kdepimlibs4-4.2.3-1.6.x86_64[KDE:42]
    kdepimlibs4-4.2.3-1.6.i586[KDE:42]
    [ ] Ignore some dependencies of kde4-kopete

    [ ] do not install kde4-kopete-4.2.3-1.7.x86_64

    [ ] install libical0-0.43-3.1.x86_64 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service



    kde4-kscd-4.2.3-1.6.x86_64 requires libkcddb4 = 4.2.3, but this requirement cannot be provided
    uninstallable providers: libkcddb4-4.2.3-1.6.x86_64[KDE:42]
    libkcddb4-4.2.3-1.6.i586[KDE:42]
    [ ] install libkcddb4-4.2.3-1.6.x86_64 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service

    [ ] do not install kde4-kscd-4.2.3-1.6.x86_64

    [ ] Ignore some dependencies of kde4-kscd



    kde4-kio_audiocd-4.2.3-1.6.x86_64 requires libkcompactdisc4 = 4.2.3, but this requirement cannot be provided
    uninstallable providers: libkcompactdisc4-4.2.3-1.6.x86_64[KDE:42]
    libkcompactdisc4-4.2.3-1.6.i586[KDE:42]
    [ ] install libkcompactdisc4-4.2.3-1.6.x86_64 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service

    [ ] do not install kde4-kio_audiocd-4.2.3-1.6.x86_64

    [ ] Ignore some dependencies of kde4-kio_audiocd



    kdelibs4-4.2.3.1-1.5.x86_64 requires soprano >= 2.2.2, but this requirement cannot be provided
    uninstallable providers: soprano-2.2.2-3.2.x86_64[KDE:42]
    soprano-2.2.2-3.2.i586[KDE:42]
    [ ] Ignore some dependencies of kdelibs4



    kdelibs4-4.1.3-4.9.x86_64 requires libkde4 = 4.1.3, but this requirement cannot be provided
    uninstallable providers: libkde4-4.1.3-4.10.4.i586[repo-update]
    libkde4-4.1.3-4.10.4.x86_64[repo-update]
    [ ] install libsoprano4-2.2.2-3.2.x86_64 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service

    [ ] Ignore some dependencies of kdelibs4



    kdelibs4-4.2.3.1-1.5.i586 requires libenchant.so.1, but this requirement cannot be provided
    uninstallable providers: libenchant1-1.4.2-16.55.i586[repo-oss]
    [ ] Following actions will be done:
    do not install kdenetwork4-filesharing-4.2.3-1.7.x86_64
    do not install kde4-ark-4.2.3-1.5.x86_64
    do not install kde4-kcalc-4.2.3-1.5.x86_64
    do not install kde4-kdessh-4.2.3-1.5.x86_64
    do not install kde4-keditbookmarks-4.2.3-2.6.x86_64
    do not install kde4-kfloppy-4.2.3-1.5.x86_64
    do not install kde4-kgpg-4.2.3-1.5.x86_64
    do not install kde4-kmix-4.2.3-1.6.x86_64
    do not install kde4-kdepasswd-4.2.3-2.6.x86_64
    [ ] install libstrigi0-0.6.4-3.3.x86_64 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service

    [ ] Ignore some dependencies of kdelibs4



    kde4-kwikdisk-4.2.3-1.5.x86_64 requires kdebase4-runtime >= 4.2.3, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.2.3-2.6.x86_64[KDE:42]
    kdebase4-runtime-4.2.3-2.6.i586[KDE:42]
    [ ] Following actions will be done:
    do not install kde4-kwikdisk-4.2.3-1.5.x86_64
    do not install kde4-kgpg-4.2.3-1.5.x86_64
    do not install kde4-kdepasswd-4.2.3-2.6.x86_64
    do not install kde4-kmix-4.2.3-1.6.x86_64
    do not install kde4-kfloppy-4.2.3-1.5.x86_64
    do not install kde4-keditbookmarks-4.2.3-2.6.x86_64
    do not install kde4-kdessh-4.2.3-1.5.x86_64
    do not install kde4-kcalc-4.2.3-1.5.x86_64
    do not install kde4-ark-4.2.3-1.5.x86_64
    do not install kde4-kdf-4.2.3-1.5.x86_64
    [ ] install oxygen-icon-theme-4.2.3-4.1.noarch (with vendor change)
    openSUSE
    -->
    openSUSE Build Service

    [ ] Ignore some dependencies of kde4-kwikdisk



    kdebase4-workspace-4.1.3-10.1.x86_64 requires kdebase4-workspace-ksysguardd = 4.1.3, but this requirement cannot be provided
    uninstallable providers: kdebase4-workspace-ksysguardd-4.1.3-10.2.1.i586[repo-update]
    kdebase4-workspace-ksysguardd-4.1.3-10.2.1.x86_64[repo-update]
    kdebase4-workspace-ksysguardd-4.1.3-10.3.7.i586[repo-update]
    kdebase4-workspace-ksysguardd-4.1.3-10.3.7.x86_64[repo-update]
    [ ] Following actions will be done:
    do not install kdebase4-workspace-ksysguardd-4.2.3-1.5.x86_64
    do not install kde4-keditbookmarks-4.2.3-2.6.x86_64
    do not install kde4-kdessh-4.2.3-1.5.x86_64
    do not install kde4-kcalc-4.2.3-1.5.x86_64
    do not install kde4-ark-4.2.3-1.5.x86_64
    do not install kde4-kdf-4.2.3-1.5.x86_64
    [ ] Ignore some dependencies of kdebase4-workspace

    [ ] install kde4-kgreeter-plugins-4.2.3-1.5.x86_64 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service



    kde4-konqueror-4.2.3-2.6.x86_64 requires kdebase4-libkonq = 4.2.3, but this requirement cannot be provided
    uninstallable providers: kdebase4-libkonq-4.2.3-2.6.x86_64[KDE:42]
    kdebase4-libkonq-4.2.3-2.6.i586[KDE:42]
    [ ] install kdebase4-libkonq-4.2.3-2.6.x86_64 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service

    [ ] do not install kde4-konqueror-4.2.3-2.6.x86_64

    [ ] Ignore some dependencies of kde4-konqueror



    enchant-1.4.2-16.55.x86_64 requires libenchant.so.1()(64bit), but this requirement cannot be provided

    [ ] Following actions will be done:
    do not install kde4-kmail-4.2.3-2.6.x86_64
    do not install kde4-kdf-4.2.3-1.5.x86_64
    do not install kde4-ark-4.2.3-1.5.x86_64
    do not install kde4-kcalc-4.2.3-1.5.x86_64
    do not install kde4-kdessh-4.2.3-1.5.x86_64
    do not install kde4-keditbookmarks-4.2.3-2.6.x86_64
    do not install kde4-kfloppy-4.2.3-1.5.x86_64
    do not install kde4-kgpg-4.2.3-1.5.x86_64
    do not install kde4-kmix-4.2.3-1.6.x86_64
    do not install kde4-kdepasswd-4.2.3-2.6.x86_64
    [ ] Ignore some dependencies of enchant

    [ ] install kdelibs4-core-4.2.3.1-1.5.x86_64 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service



    kdelibs4-4.2.3.1-1.5.i586 requires kdelibs4-core = 4.2.3.1, but this requirement cannot be provided
    uninstallable providers: kdelibs4-core-4.2.3.1-1.5.x86_64[KDE:42]
    kdelibs4-core-4.2.3.1-1.5.i586[KDE:42]
    [ ] Following actions will be done:
    do not install kde4-akregator-4.2.3-2.6.x86_64
    do not install kde4-kdf-4.2.3-1.5.x86_64
    do not install kde4-ark-4.2.3-1.5.x86_64
    do not install kde4-kcalc-4.2.3-1.5.x86_64
    do not install kde4-kdessh-4.2.3-1.5.x86_64
    do not install kde4-keditbookmarks-4.2.3-2.6.x86_64
    do not install kde4-kfloppy-4.2.3-1.5.x86_64
    do not install kde4-kgpg-4.2.3-1.5.x86_64
    do not install kde4-kmix-4.2.3-1.6.x86_64
    do not install kde4-kdepasswd-4.2.3-2.6.x86_64
    [ ] Ignore some dependencies of kdelibs4

    [ ] install libkdecore4-4.2.3.1-1.5.x86_64 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service



    kde4-dolphin-4.2.3-2.6.x86_64 requires kdebase4-libkonq = 4.2.3, but this requirement cannot be provided
    uninstallable providers: kdebase4-libkonq-4.2.3-2.6.x86_64[KDE:42]
    kdebase4-libkonq-4.2.3-2.6.i586[KDE:42]
    [ ] install libkonq5-4.2.3-2.6.x86_64 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service

    [ ] do not install kde4-dolphin-4.2.3-2.6.x86_64

    [ ] Ignore some dependencies of kde4-dolphin



    kdepim4-4.1.3-3.11.x86_64 requires libkleopatraclientcore.so.0.2.0()(64bit), but this requirement cannot be provided
    uninstallable providers: libkdepim4-4.1.3-3.14.9.x86_64[repo-update]
    [ ] install skanlite-0.3.kde4.2.3-7.7.x86_64 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service

    [ ] Ignore some dependencies of kdepim4



    ktorrent-3.1.5-1.15.x86_64 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.1.3-4.2.9.x86_64[repo-update]
    kdebase4-runtime-4.1.3-4.2.9.i586[repo-update]
    [ ] install ktorrent-3.2.1-4.7.x86_64 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service

    [ ] Ignore some dependencies of ktorrent



    kdeartwork4-screensaver-4.1.3-1.22.x86_64 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.1.3-4.2.9.x86_64[repo-update]
    kdebase4-runtime-4.1.3-4.2.9.i586[repo-update]
    [ ] Following actions will be done:
    do not install kde4-krdc-4.2.3-1.7.x86_64
    do not install kde4-keditbookmarks-4.2.3-2.6.x86_64
    [ ] install kdeartwork4-screensaver-4.2.3-2.6.x86_64 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service

    [ ] Ignore some dependencies of kdeartwork4-screensaver



    kde4-okular-4.2.3-1.6.x86_64 requires libqimageblitz.so.4()(64bit), but this requirement cannot be provided

    [ ] install kde4-konqueror-plugins-4.2.3-6.4.x86_64 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service

    [ ] Ignore some dependencies of kde4-okular



    kde4-kio_sysinfo-11.1-66.4.x86_64 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.1.3-4.2.9.x86_64[repo-update]
    kdebase4-runtime-4.1.3-4.2.9.i586[repo-update]
    [ ] install kde4-kio_sysinfo-11.1.1-67.2.x86_64 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service

    [ ] do not install kde4-kwalletmanager-4.2.3-1.5.x86_64

    [ ] Ignore some dependencies of kde4-kio_sysinfo


    And many more like that... Whats actually missing here???

  2. #2
    Join Date
    Jun 2008
    Location
    Stoney Stanton - England
    Posts
    1,102

    Default Re: Dependency problems for KDE4.2 (one click install)

    if you agree to the vendor change should all install fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •