Results 1 to 7 of 7

Thread: 11.1 keeps freezing

  1. #1

    Default 11.1 keeps freezing

    ok i have a fresh install of opensuse 11.1, and it would SEEM that under a little bit of cpu load the OS freezes and i have to hard reboot the computer...

    i was under the impression that linux was rock solid, ive had it for a couple of days now and im already thinking of going back to windows lol

    any ideas of how to solve this issue?

    cheers

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: 11.1 keeps freezing

    Did you disable or remove beagle?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,527
    Blog Entries
    37

    Default Re: 11.1 keeps freezing

    Quote Originally Posted by vorticon View Post
    ok i have a fresh install of opensuse 11.1, and it would SEEM that under a little bit of cpu load the OS freezes and i have to hard reboot the computer...

    i was under the impression that linux was rock solid, ive had it for a couple of days now and im already thinking of going back to windows lol

    any ideas of how to solve this issue?
    Hi Vorticon.

    Sorry to read of your troubles. ... I note you also had Ubuntu installed for a while. ... Did it also have the same problems?

    IMHO, a PC freeze can be caused by either hardware or software. If its hardware, you will possibly observe the same behaviour in WinXP and Ubuntu, in addition to openSUSE. If its software, it might be specific to openSUSE (although if it is a specific version of a graphic or other driver, then Ubuntu may have the same problem).

    My experience, is the things that can cause a freeze in a user's PC, because of Software, are :
    • graphic driver problems
    • ethernet / wireless card problems
    • software application that dynamically consumes all RAM
    Typically, if an application steals one's available RAM, then there is a gradual slow down to a freeze, and not an abrupt freeze. In such a case, one can often run "top" constantly, and watch memory consumption, to get a flavour as to what may be causing the freeze.

    In the case of the graphics driver or ethernet device causing a freeze, sometimes (but not always) , a user's log files under /var/log will provide an indication as to what caused the freeze.

    If the problem is the ethernet card kernel module, it can be a pain to confirm, to understand, and to fix. But if it is the graphic card driver, then one can typically change the graphic card driver. What graphic card driver are you using? If you type (when your PC is working):
    grep -i driver /etc/X11/xorg.conf
    and post here the output, we will be able to see what graphic card driver you are using, and we "might" be able to suggest a different graphic card driver. The idea being if the freeze does not occur with a different graphic card driver, then the problem has been localized.

  4. #4

    Default Re: 11.1 keeps freezing

    thanks for the great reply

    no i didnt have any issue with ubuntu infact the only reason im still not using it is because my intel graphics card dosent work with it.

    it is an abrupted freeze as i can even induce it by loading the cpu from opening programs, i just opened alot of windows and bam it froze

    as for that command, the output i get is

    Driver "kbd"
    Driver "Mouse"
    Driver "synaptics"
    Driver "synaptics"
    Driver "intel"

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,663
    Blog Entries
    14

    Default Re: 11.1 keeps freezing

    Does it realy freeze or does it come back after 15 minutes?
    Which Intel GMA ?
    Do you have drivers installed for that?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,527
    Blog Entries
    37

    Default Re: 11.1 keeps freezing

    Quote Originally Posted by vorticon View Post
    Code:
    Driver "kbd"
    Driver "Mouse"
    Driver "synaptics"
    Driver "synaptics"
    Driver "intel"
    I'm surprised to see 3 mouse drivers ... Did you have trouble installing a driver for your mouse?

    Reference your Intel, you could type:
    Code:
    su -c 'sax2 -p'
    (enter root password when prompted for a password) to find out what sax2 thinks your graphic driver is.

    If your intel graphics is PCI interface related, you may be able to find out more about it by typing:
    /sbin/lspci

    If you see your graphic card there, to get a more 'verbous' print out, you could type:
    /sbin/lspci -v
    and take note of the graphic card.

    But DON'T paste that entire output here. Its much too long.

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,527
    Blog Entries
    37

    Default Re: 11.1 keeps freezing

    Quote Originally Posted by vorticon View Post
    Code:
    Driver "intel"
    As an interim, to hopefully get some limited stability, until you sort your freezing problem, you could check to see if you have more stability with the "vesa" graphic driver. Its performance will be significantly less than the "intel" driver, but if you get stability with the "vesa" graphic driver, then that will point the finger at the "intel" graphic driver.

    You can do that by booting to run level 3, and configure for the vesa graphic driver.

    To do that, reboot your PC, and when the green grub boot selection menu appears, press the key "3" which will enter "3" into the options line of the grub menu.

    That will boot your PC to an ascii/text log in. Login as a regular user, and use the regular user password. Then type 'su' (no quotes - enter root password) to get root permissions. Then backup your /etc/X11/xorg.conf file (this is IMPORTANT !! ) so that we can go back to the Intel driver later, if need be. You can back up that file by typing:
    cp /etc/X11/xorg.conf /etc/X11/xorg.conf.intel.backup

    Once that is backed up, try configuring for the VESA driver. Do that by tying:
    sax2 -r -m 0=vesa
    Note that is "zero" equals vesa.

    And then configure your graphics. If you don't like the resolution offered, you should select the option indicating you don't like the suggested configuration, and it should give you the choice for a higher resolution. Be certain you test this !! This sax2 program will re-write the /etc/X11/Xorg.conf file. Once you are happy, then exit sax2. You will be back in a text mode.

    Type:
    shutdown -r now
    to reboot (this time do not press "3") and test your graphics. If that doesn't work, you will be back at a black screen. In which case hit <CTR><ALT><Delete> twice, very close together in time, and that will reboot your PC. And that time, again type "3" in the grub menu so to boot to run level3, type "su" to get root permissions, and restore your xorg.conf configured for the Intel driver with:
    cp /etc/X11/xorg.conf.intel.backup /etc/X11/xorg.conf
    and then restart your PC. And this will take you back to where you are now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •