Results 1 to 7 of 7

Thread: Software Management error

  1. #1
    Join Date
    Jun 2008
    Location
    Belgium
    Posts
    46

    Default Software Management error

    YaST got signal 11 at YCP file /usr/share/YaST2/clients/inst_packages.ycp:36
    /sbin/yast2: line 421: 9504 Segmentation fault $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

    This is the error i get when i try to use the Yast Software Management tool. Anyone knows how to fix this?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Software Management error

    Have you add some QT repos recently?

    Code:
    zypper lr --details
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Belgium
    Posts
    46

    Default Re: Software Management error

    Nope, but I do remember yast having some problems updating the packman repository

  4. #4

    Default Re: Software Management error

    They didn't post the code snippet for the fun of it..

    Tends to take the guess work out of it and lessen the need for the crystal ball.
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

  5. #5
    Join Date
    Jun 2008
    Location
    Belgium
    Posts
    46

    Default Re: Software Management error

    # | Alias | Name | Enabled | Refresh | Priority | Type | URI
    ---+--------------------------------------------------------------------------------------+-----------------------------------------------------+---------+---------+----------+--------+-------------------------------------------------------------------------------------
    1 | openSUSE_BuildService_-_GCC_1 | openSUSE BuildService - GCC | Yes | Yes | 99 | rpm-md | Index of /repositories/devel:/gcc/openSUSE_11.0
    2 | Index of /repositories/games/openSUSE_11.0 | openSUSE BuildService - Games | Yes | Yes | 99 | rpm-md | Index of /repositories/games/openSUSE_11.0
    3 | Index of /repositories/server:/database/openSUSE_11.0 | openSUSE BuildService - Database | Yes | Yes | 99 | rpm-md | Index of /repositories/server:/database/openSUSE_11.0
    4 | http://download.nvidia.com/opensuse/11.0 | NVIDIA Repository | Yes | Yes | 99 | rpm-md | http://download.nvidia.com/opensuse/11.0
    5 | repo-debug | openSUSE-11.0-Debug | Yes | No | 120 | yast2 | Index of /distribution/11.0/repo/debug
    6 | Index of /repositories/GNOME:/STABLE/openSUSE_11.0 | openSUSE BuildService - GNOME:STABLE | Yes | Yes | 99 | rpm-md | Index of /repositories/GNOME:/STABLE/openSUSE_11.0
    7 | repo-non-oss | openSUSE-11.0-Non-Oss | Yes | No | 120 | yast2 | Index of /distribution/11.0/repo/non-oss
    8 | Index of /repositories/mozilla/openSUSE_11.0 | openSUSE BuildService - Mozilla | Yes | Yes | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.0
    9 | openSUSE-DVD 11.0 | openSUSE-DVD 11.0 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0
    10 | Index of /update/11.0 | Main Update Repository | Yes | Yes | 99 | rpm-md | Index of /update/11.0
    11 | Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.0 | openSUSE BuildService - KDE4:Factoryesktop | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.0
    12 | Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.0 | openSUSE BuildService - OpenOffice.org | Yes | Yes | 99 | rpm-md | Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.0
    13 | repo-oss | openSUSE-11.0-Oss | Yes | No | 120 | yast2 | Index of /distribution/11.0/repo/oss
    14 | Index of /download/repo/1.0/11.0 | openSUSE Education | Yes | Yes | 99 | yast2 | Index of /download/repo/1.0/11.0
    15 | Index of /repositories/Emulators:/Wine/openSUSE_11.0 | openSUSE BuildService - Wine CVS Builds | Yes | Yes | 99 | rpm-md | Index of /repositories/Emulators:/Wine/openSUSE_11.0
    16 | openSUSE_BuildService_-_Games:Tools | openSUSE BuildService - Games:Tools | Yes | Yes | 99 | rpm-md | Index of /repositories/games:/tools/openSUSE_11.0
    17 | b | openSUSE BuildService - CrossTool | Yes | Yes | 99 | rpm-md | Index of /repositories/CrossToolchain:/mingw/openSUSE_11.0
    18 | Index of /repositories/X11:/XGL/openSUSE_11.0 | openSUSE BuildService - X11GL | Yes | Yes | 99 | rpm-md | Index of /repositories/X11:/XGL/openSUSE_11.0
    19 | Education | openSUSE BuildService - Education | Yes | Yes | 99 | rpm-md | Index of /repositories/Education/openSUSE_11.0
    20 | Index of /repositories/KDE:/Community/openSUSE_11.0 | openSUSE BuildService - KDE:Community | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Community/openSUSE_11.0
    21 | Index of /pub/packman/suse/11.0 | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.0
    22 | Index of /repositories/GNOME:/Community/openSUSE_11.0 | openSUSE BuildService - GNOME:Community | Yes | Yes | 99 | rpm-md | Index of /repositories/GNOME:/Community/openSUSE_11.0
    23 | Index of /repositories/Virtualization:/VirtualBox/openSUSE_11.0 | openSUSE BuildService - Virtualization (VirtualBox) | Yes | Yes | 99 | rpm-md | Index of /repositories/Virtualization:/VirtualBox/openSUSE_11.0
    24 | Index of /repositories/KDE:/Backports/openSUSE_11.0 | openSUSE BuildService - KDE:Backports | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Backports/openSUSE_11.0

  6. #6

    Default Re: Software Management error

    The problem stems from factory it includes qt4.5 I'll presume you know what you're doing with all those repos.. The fix seems to be rolling back qt it has been cropping up a little bit recently.

    I can only presume that you're running factory for a reason if not then the 42 repo isn't having this problem if going to 4.2.3 isn't a problem.

    I've not looked I would hope there is a bug report for this. But being factory and so earlier on I doubt bug reports are taken to seriously against factory just yet..

    Edit
    zypper dup might be worth a go but I doubt it
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Software Management error

    remove or disable repo #11

    add in place
    Index of /repositories/KDE:/42/openSUSE_11.0
    and
    Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.0_KDE_42

    follow the principles here
    KDE4.2.* (How To Add) Guide. - openSUSE Forums

    ==========
    FYI: With all those repo's - expect trouble
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •