Results 1 to 4 of 4

Thread: How to enable slovenian characters support?

  1. #1
    Join Date
    Sep 2008
    Location
    Slovenia
    Posts
    335

    Default How to enable slovenian characters support?

    Hi everyone. When I installed suse 11.1 I didn't care much about the selected language, since english is ok for me,but would like however be able see special slovenian characters,they are čšžđČŠŽĐ( if you can see them ). When I work in oppen office I have no problem using them, but I encountered problem when trying to use movie subtitles in mplayer, they are simply replaced with some gibberish. Also if I open the subtitle files in gedit or kate I have to select code page win 1250 to get them display correctly, but still don't know how to make them display in mplayer correctly. Any suggestion welcome, thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,432

    Default Re: How to enable slovenian characters support?

    The problem is that most Linux programs now use utf-8 but, if the file was created in Windows, it will use a different encoding. As you have found OO generally does a good job of detecting foreign encodings and adjusting them because that is essential to reading doc files.

    But other programs do not do this or assume, as I suspect the Kate authors do, that it is better to leave you to make the change. Kate has many options for changing the encodings, line endings of files and so on; so you should be able to select the input encoding and then change to utf-8 before you save so that other Linux programs can read the files.

    I'm not sure about MPlayer but with Digikam and other programs that hold metadata, you can normally edit the metadata.

    Others may have found more elegant solutions to your difficulties.

  3. #3

    Default Re: How to enable slovenian characters support?

    Quote Originally Posted by john_hudson View Post
    select the input encoding and then change to utf-8 before you save so that other Linux programs can read the files.
    I would do exactly it: open the subtitle file re-save as utf-8 (dont forget to make a backup!) and see, if the display is correct.

  4. #4
    Join Date
    Sep 2008
    Location
    Slovenia
    Posts
    335

    Default Re: How to enable slovenian characters support?

    Thanks for suggestions but resaving file in different code page (cp 1250 or utf 8) didn't help. However I found the solution to my problem if anyone will need it, in mplayer settings->Subtitles & OSD you can select the encoding type, so I selected CP 1250 and slovenian characters now display properly.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •