Results 1 to 3 of 3

Thread: kio-rar on KDE 4

  1. #1

    Question kio-rar on KDE 4

    First, some background info. I have recently purchased a new laptop. It came with Vista on it. After some finagling with Vista and a bit of work I now have OpenSuSE 11.1 on it using KDE 4.2. I also have an old laptop which is running OpenSuSE 11.0 and KDE 3.

    On the old laptop I was able to successfully compile and install the kio-rar software which allows me to open and browse through rar files through any number of KDE apps, Gwenview being the one most used.

    I now want to get it working with my new laptop but have come up against a bit of a wall. During the ./configure script I receive the following error:
    Code:
    checking for Qt... libraries /usr/lib/qt3/lib, headers /usr/lib/qt3/include using -mt
    checking for moc... /usr/lib/qt3/bin/moc
    checking for uic... /usr/lib/qt3/bin/uic
    checking whether uic supports -L ... yes
    checking whether uic supports -nounload ... yes
    checking if Qt needs -ljpeg... no
    checking for rpath... yes
    checking for KDE... configure: error:
    in the prefix, you've chosen, are no KDE libraries installed. This will fail.
    So, check this please and use another prefix!
    Can anyone tell me what the prefix should be?
    I have already tried /usr with no success.

  2. #2
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: kio-rar on KDE 4

    cwoelkers adjusted his/her AFDB on Thursday 14 May 2009 19:56 to write:

    > checking for KDE... configure: error:
    > in the prefix, you've chosen, are no KDE libraries installed. This will
    > fail. So, check this please and use another prefix!
    > --------------------
    >
    >
    > Can anyone tell me what the prefix should be?
    > I have already tried /usr with no success.
    >
    >


    You probably need the dev files for KDE ( which ones are not stated )

    If you have oodles of space and a good connection then just install as many
    as you think is needed :-)


    Unless there is more info in the install file or readme as to what deps are
    exactly is needed.


    HTH


    --
    Mark

    Nullus in verba
    Nil illigitimi carborundum


  3. #3

    Default Re: kio-rar on KDE 4

    And even if you manage to compile/install kio_rar, it will still be a KDE3-application (which you can see clearly from your output) and most certainly not work with KDE4 unless somebody provides a port to KDE4 for it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •