Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: can't type character "x" in a terminal

  1. #1
    Join Date
    May 2009
    Location
    Belgium
    Posts
    12

    Default can't type character "x" in a terminal

    Hi everyone,

    Since today I suddenly cannot type in the character "x" in a gnome-terminal or xterm, except as root (su -). So I even cannot close the terminal window by eXit

    I run opensuse 11.1, kernel 2.6.27.21-0.1-default, on a Dell E6500.

    I tried searching the fora and google, but didn't find anything useful. So thanks a lot in advance for any help! This makes my daily work kind of impossible...

  2. #2
    somebody_else NNTP User

    Default Re: can't type character "x" in a terminal

    paarnoutse wrote:
    > Hi everyone,
    >
    > Since today I suddenly cannot type in the character "x" in a
    > gnome-terminal or xterm, except as root (su -). So I even cannot close
    > the terminal window by eXit
    >
    > I run opensuse 11.1, kernel 2.6.27.21-0.1-default, on a Dell E6500.
    >
    > I tried searching the fora and google, but didn't find anything useful.
    > So thanks a lot in advance for any help! This makes my daily work kind
    > of impossible...


    OH, that is a strange one!!

    i don't think i can help, but have some questions:

    -are you running KDE3, KDE4, GNOME, or what? (yes, i see you say
    gnome-terminal, but i can run gnome-terminal in KDE)

    -how often do you log into KDE/Gnome/etc as root

    -running compiz or desktop effects? turn both off and try again

    -what kind of graphics card?
    --running 3D enabled?
    --if yes, what happens if you turn that off

    -is your system fully updated?

    -have you set up some keyboard shortcuts? (set up any yesterday or
    since the last time you used gnome-terminal

    -you say "suddenly today" if that means it worked yesterday, then what
    did you do yesterday (OR, what have you done since the last time the x
    worked ok in gnome-terminal???):

    --any updates applied by YaST

    --did you run YaST, zypper, Smart, etc

    --you add any programs, RPM?

    --you edit any config files?

    --you run sax2?

    --you change ANYthing at all, what?

    --did you shutdown or reboot yesterday (or since the last time it
    worked ok)?

    -what did you do TODAY before you saw this strange behavior? any of
    those things above???

    -if you shutdown X (ctrl+alt+backspace TWICE), switch users or etc and
    then log in again is it still broke?

    -if you shutdown your machine now, and reboot, is it still broke?

    -that X key on your keyboard, does the Fn key shift it to something
    else? in the terminal:

    --press Fn and then the X and see if anything happens

    --how about Shift+x, Ctrl+x, Alt+x

    --does your keyboard have AltGr? if so, what about AltGr+x

    --MS-Win Keys+x?

    -is this problem seen ONLY in gnome-terminal? that is

    --launch an xterm this way: Alt+F2 type in xterm and hit enter

    --press Ctrl+Alt+F3, log in and try 'exit' does that x work? (get
    back to your GUI with Ctrl+Alt+F7

    --use the GUI, go to the menu and pick System > Terminal > System >
    Terminal, and pick any/all of the terminals listed there (except
    gnome-terminal)

    there is probably other stuff i've not though of yet...but, do that first

    --
    somebody_else

  3. #3
    Join Date
    May 2009
    Location
    Belgium
    Posts
    12

    Default Re: can't type character "x" in a terminal

    Thank you so much for helping me!

    I tried to answer you questions:

    I use GNOME.

    I never logon in GNOME as root, I always use sudo or su-, whenever I need root privileges. So that's mainly for zypper.

    I run Compiz, but switching off did not do the trick.

    Videocard: Quadro NVS 160M, nVidia driver 180.51. This was updated yesterday. How do I switch off 3D?

    The system is up to date.

    What I changed just before I noticed the problem:
    - applied updates using zypper up.
    (this included a nvidia update)
    - tried to get rid of the system bell through the soundcard;
    -- I put in .profile "xset b off", but removed it later since it didn't work
    -- rmmod pcspkr (no effect so I didn't blacklist it)
    - Installed Eclipse (plus dependencies)

    I did not run sax2.

    I did reboot a couple of times to check if my bell was gone after reboot (which was not the case).

    When I noticed the problem I was not changing any system settings.

    The x-key is not mapped as something else using Fn. In xterm, the problem is also there. In every other program I can use it. Even when I try to copy-paste for example the exit command within the gnome-terminal (doubbleclick - middlemouseclick), "exit" appears as "eit".

    I can't find any shortkey with 'x' in it, I tried all the modifier keys (Ctrl, Fn, Alt, Meta (win). I did not play with my keyboard layout settings, because the problem is only in gnome-terminal and xterm and is not there as root.

    Just discovered: in the terminal, capital X works, x still doesnt.

    If I login after Ctrl-Alt-F3, still the x won't work, X does.

    Gnome-terminal and xterm are the only terminals I can use. There's also a Linux 32-bit terminal -entry, with "xterm -e linux32 $SHELL" behind it, but that doesn't start (error message, file not found).


    Further I found someone else describing the same problem, but there were no replies.
    Can t type x character in console while beeing non-root | debianHELP


    Hope you can use my answers. Thanks again!

  4. #4
    Join Date
    Oct 2008
    Location
    Sunny Arizona
    Posts
    251

    Default Re: can't type character "x" in a terminal

    This guy had a similar problem with "v" instead of "x":

    https://www.linuxquestions.org/quest...orking-104755/

    Worth a look...

    Also, can you type "x" as root? (IE after doing an su command?)

    If so, you should try logging in as a different user to see if the problem persists. If it doesn't, it's probably a key-binding issue saved in your user preferences somewhere.

  5. #5
    Join Date
    May 2009
    Location
    Belgium
    Posts
    12

    Default Re: can't type character "x" in a terminal

    Thanks queequeg.

    I created a new user, logged in as this user, and was able to type the x again... so I guess I have a bad setting somewhere in a per-user config file.

    As root I was also able to use the x (after su -).

    Have to go now, when I find it I'll let you know. Any hints on which files I should check are very welcome (I'm not that experienced with all those config files in Linux)!

    Thanks!

  6. #6
    somebody_else NNTP User

    Default Re: can't type character "x" in a terminal


    > Any hints on which
    > files I should check are very welcome (I'm not that experienced with all
    > those config files in Linux)!


    i'd BEGIN with *all* those files you opened in your quest to 'fix'
    your system bell..

    you can use YaST to search for and install "beedif" which is an easy
    way to compare two files...one known good (the new user one) and one
    suspected of being broken (the one in YOUR home folder)..

    so, you look at the (probably hidden) files in the two different /home
    folders..

    beginning with .profile

    --
    somebody_else

  7. #7
    Join Date
    May 2009
    Location
    Belgium
    Posts
    12

    Default Re: can't type character "x" in a terminal

    Solved! Thank you both so much!

    The problem was indeed caused by my attempt to get rid of the beep sound. I had put into ~/.inputrc the line "xset b off", which I found somewhere on the net. I removed the line (didn't work anyway, just forgot to remove it), rebooted and the problem is gone! Fantastic! Many thanks!

  8. #8
    somebody_else NNTP User

    Default Re: can't type character "x" in a terminal

    can we learn something from this experience?

    1. when something in Linux is "suddenly" broken always assume that
    something was changed by YOU or an update....so, the FIRST thing to do
    is think about what you did, and undo it..

    2. finding stuff on the net and sticking it into a system is FUN...it
    also can cause strange problems...always weigh the risks of
    experimentation and take steps to minimize the risks (like BACKUP
    files BEFORE changing them....EASY to do, just make a copy of
    ~/.inputrc and name it (say) ~/.inputrc.ORIGINAL

    THEN, when/if you have sudden strange stuff you have an EASY path back
    to "it works"

    3. and please note: when something in Redmond's software is "suddenly
    broke" you always have to wonder if you got a new virus, root kit, or
    just what....AND, there is very little likelihood you have a chance to
    actually fix it anyway..

    --
    somebody_else

  9. #9
    Join Date
    May 2009
    Location
    Belgium
    Posts
    12

    Default Re: can't type character "x" in a terminal

    Well, that's how you learn stuff I suppose... Next time I know how to approach a problem like this. I always try to get my software environment configured as I want it. That was my main reason to quit using the Microsoft OS!

    Thanks again

  10. #10

    Default Re: can't type character "x" in a terminal

    If you just want to turn off the annoying beep, edit /etc/modules.d/blacklist as root, add "blacklist pcspkr" to the end of the file. This is the first thing everytime I installed a new system.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •