Results 1 to 8 of 8

Thread: System tray icons problem after update to KDE4.2.3

  1. #1

    Default System tray icons problem after update to KDE4.2.3

    I am using 32bit openSUSE 10.3 running KDE4. I upgraded from KDE4.2.2 to KDE4.2.3 and suddenly Kopete system tray icon goes missing. I mean just the icon is missing, all the functionality is there. And also kmix is using KBasket's icon, again all functionality intact just the icon is off.
    I searched the forums to see if anyone faced a similar issue but did not find anything helpful. Any pointers?

    Ban

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: System tray icons problem after update to KDE4.2.3

    Post your repo's
    Code:
    zypper lr -u -p
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: System tray icons problem after update to KDE4.2.3

    @caf4926
    I am not able to use online repos from behind my company's firewall. Since I cannot do a direct online update, I use a script to get the required RPMs into my local yast2 reporsitory and update from there.
    I used the following repos to manually get the RPMs:
    * KDE4:Factory: Desktop
    * KDE4:STABLE: Desktop

    A list of some key kde4 related packages I have installed might help:
    * libkde4-4.2.3-116.5
    * libkdecore4-4.2.3-116.5
    * kde4-kwin-4.2.3-230.2
    * kdebase4-session-4.2.3-32.14
    * kdebase4-workspace-ksysguardd-4.2.3-230.2
    * kdebase4-runtime-4.2.3-100.3
    * kdebase4-workspace-4.2.3-230.2
    * kdebase4-workspace-branding-openSUSE-11.1-83.39
    * kdebase4-libkonq-4.2.3-81.2
    * kdebase4-4.2.3-81.2
    * kdebase4-openSUSE-11.1-83.39
    * libqt4-4.5.1-44.1
    * libqt4-x11-4.5.1-44.1
    * libqt4-qt3support-4.5.1-44.1

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: System tray icons problem after update to KDE4.2.3

    My advice is not to use those repos but switch to these

    Index of /repositories/KDE:/42/openSUSE_11.1

    Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE_42

    and you should not mix stable and factory
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: System tray icons problem after update to KDE4.2.3

    @caf4926
    Hey, thanks I did not know that the new KDE:42 repository was the recommended one. I will try installing packages from there ans see how it goes.

    BTW, is it that the packages from KDE:42 use Qt44? Cause it seems the packages from KDE:KDE4:Factory: Desktop use Qt45.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: System tray icons problem after update to KDE4.2.3

    Yes. The repo's you used are being used for packages under heavy development and use QT45
    The ones I gave are QT44

    Some have been adding a separate repo for QT44 and sometimes even QT45, to the repo setup I gave you. But this is not necessary.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: System tray icons problem after update to KDE4.2.3

    That worked like a charm. Thanks a lot mate!

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: System tray icons problem after update to KDE4.2.3

    Quote Originally Posted by BanMido View Post
    That worked like a charm. Thanks a lot mate!
    You are welcome
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •