Results 1 to 3 of 3

Thread: Why does yast proposes to downgrade packages for some RPM's?

  1. #1

    Default Why does yast proposes to downgrade packages for some RPM's?



    In the above screenshot you see that I try to upgrade some KDE packages and it came to my attention that in some cases yast is still proposing to downgrade some packages to version 4.1.3 while I'm running KDE 4.2.2.

    Most packages are now 4.2.3 so I want to update those. But why are some packages marked as downgradable to version 4.1.3 which I'm no longer running ??

    These are my repos (KDE has priority 99), Gnome 2.26 has 18 and 19, opensuse 11.1 update repo has 20.

    # | Alias | Name | Enabled | Refresh
    ---+----------------------------+-----------------------------------------------------+---------+--------
    1 | GNOME:Factory | GNOME:Factory | Yes | Yes
    2 | Gnome_2.26 | Gnome 2.26 | Yes | Yes
    3 | Gnome_2.26_Backports | Gnome 2.26 Backports | Yes | Yes
    4 | Java | Java | Yes | Yes
    5 | KDE_4.2_Community_Packages | KDE 4.2 Community Packages | Yes | Yes
    6 | KDE_4.2_Core_Packages | KDE 4.2 Core Packages | Yes | Yes
    7 | KDE_4.2_Extras | KDE 4.2 Extras | Yes | Yes
    8 | KDE_4.2_QT_Packages | KDE 4.2 QT Packages | Yes | Yes
    9 | X11GL | X11GL | Yes | Yes
    10 | devel:tools:building | devel:tools:building | Yes | Yes
    11 | openSUSE 11.1-0 | openSUSE 11.1-0 | Yes | No
    12 | repo | NVIDIA Repository | Yes | Yes
    13 | repo-source | openSUSE-11.1-Source | Yes | Yes
    14 | repo-update | openSUSE-11.1-Update | Yes | Yes
    15 | repo_1 | Main Repository (NON-OSS) | Yes | Yes
    16 | repo_10 | openSUSE BuildService - Drivers for webcams | Yes | Yes
    17 | repo_11 | openSUSE BuildService - Mozilla | Yes | Yes
    18 | repo_12 | VideoLan Repository | Yes | Yes
    19 | repo_13 | Packman Repository | Yes | Yes
    20 | repo_2 | Main Repository (OSS) | Yes | Yes
    21 | repo_3 | openSUSE BuildService - Wine CVS Builds | Yes | Yes
    22 | repo_4 | openSUSE BuildService - GNOME:Community | Yes | Yes
    23 | repo_5 | openSUSE BuildService - GNOME:STABLE | Yes | Yes
    24 | repo_6 | openSUSE BuildService - KDE:Backports | Yes | Yes
    25 | repo_7 | openSUSE BuildService - KDE:Community | Yes | Yes
    26 | repo_8 | openSUSE BuildService - Virtualization (VirtualBox) | Yes | Yes




    Any advice is welcome.
    Thanks.

  2. #2

    Default Re: Why does yast proposes to downgrade packages for some RP

    opensuse 11.1 update repo has 20. <= Its this I fought this on an X less install with just the kde42 repo spent half an hour with that one..

    Kept telling me nothing provided runtime x.x.x only x.x.x I solved it by making it the same as 42 in my case they all became 99.
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

  3. #3

    Default Re: Why does yast proposes to downgrade packages for some RP

    Sweeeeeet....

    I changed the priority to 100 and now all other packages included the ones above install without issue.

    Thanks mate.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •