Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Software Manager on v10.3 Issues

  1. #1
    illyawilliams NNTP User

    Exclamation Software Manager on v10.3 Issues

    Hi Folks

    I'm running Opensuse v10.3 on an Ibm Netfinity 4000r (couldn't get the Live 11.1 to work).

    I'm having a problem with the Software Manager application

    1.) Regardless of what external repositories with packages that I define, it seems that I can never get them to show up in the window. I have a limited list of applications, however it never seems to change. It's almost as if it's cache the application from the install CD. I've done all of the obvious things, such as ran the update application which works, deleted the repository reference to the Cd, tried different repositories. I'm about to wit's end on this issue, and as always I'm under a deadline.

    I am aware that I can install the applications by manually downloading the rpm's however I'm not sure of all the dependancies I will need. That's the nice thing about the Software Manager is that it will also include any dependancies.

    2.) It crashes

    3.) It crashes

    Any help would be much appreciated, it may be something small.. I'm relatively new to Opensuse, so maybe I'm missing something obvious.

    Has anyone else seen his behavior ?

    Thanks,

    IAW

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Software Manager on v10.3 Issues

    Open a terminal and post result of

    Code:
    zypper lr
    this will show the repo's you actually have

    If you want to familiarize yourself with zypper for 10.3, look: Zypper/Usage/10.3 - openSUSE

    For eg:
    Code:
    zypper lu
    will list available updates
    Code:
    zypper up
    will run the updates

    Code:
    zypper install 'packagename'
    should install
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Software Manager on v10.3 Issues

    Hi, the other day i was using the command

    zypper sa <URL> to add a bunch of repo.

    However, now.. whenever I do any command with zypper

    I get an error saying...

    Code:
    Restoring system sources...
    Parsing metadata for 20090512-142824...
    Parsing metadata for SUSE Linux Enterprise Server 10 SP1...
    Parsing metadata for http://download.opensuse.org/update/10.3/...
    Parsing metadata for http://packman.unixheads.com/suse/10.3/...
    Parsing metadata for http://download.opensuse.org/distribution/10.3/repo/non-oss/...
    Invalid object: Can't open /var/lib/zypp/cache/Source.KGDHsW/DATA/descr/packages
    Unexpected exception.
    Can't parse packages file: Can't open /var/lib/zypp/cache/Source.KGDHsW/DATA/descr/packages
    Please file a bug report about this.
    See http://en.opensuse.org/Zypper#Troubleshooting for instructions.
    However, the troubleshooting site doesn't seem to provide info to help in resolving my problem and I am now stuck.


    *Ultimately I was trying to install FreeNx*

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Software Manager on v10.3 Issues

    OK
    What version of SUSE is this, I see a ref to SLES the server edition?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Software Manager on v10.3 Issues

    Looks like the OP is trying to use openSUSE with a SLES repo. Bad boy! openSUSE != SLES or SLED

  6. #6

    Default Re: Software Manager on v10.3 Issues

    Hello all,

    Sorry that I forgot to include my SUSE info.

    Code:
    SUSE Linux Enterprise Server 10 (i586)
    VERSION = 10
    PATCHLEVEL = 1
    can you guys please tell me what I can do to fix my zypper? i tried using sudo zypper rm <URL> to remove my repo it did not seem to work.


    And also, since openSUSE != SLES or SLED, is there a website where I can find the repo for SLES?

    Thanks alot,

    A confused penguin

  7. #7
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Software Manager on v10.3 Issues

    Well you sure confused us talking about v10.3 when what you have is SLES 10 SP1, and not even SP3.

    I don't run SLES but some other people around here do. But if did then the first thing I would go over to the SLES forums and look for stickies about the SLES repos. Also you would have got some standard repos when you registered, no?

  8. #8
    illyawilliams NNTP User

    Default Re: Software Manager on v10.3 Issues

    Hey ALL

    For some reason the user 'ahhlun' started posting on my thread about a subsequent issue regarding a work-around that user 'caf4926' posted response to my original/inital problem. I'm not sure why he posted his questions on my thread, but it has only caused confusion. My issues that still remain are outlined in my original/starting thread. The user 'ahhlunn' has no connection or affliation with me, my company or orginal issue.

    Not trying to be mean, but this is to USER 'ahhlun', please start a new thread if you have issues, as you have completely confused everyone, with your subsequent postings on my issue.

    Now back to my ORIGINAL issue, I will try this zypper utility, however I would still like to know if anyone has seen the issues I have experienced with OPENSUSE 10.3 and Software Manager (please refer to original post).

    Thanks in advance folks

  9. #9
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Software Manager on v10.3 Issues

    Run the zypper utility as caf4926 says and we'll go from there. It could be that the zypper caches are corrupted. There are commands to clear the cache and start again.

  10. #10
    somebody_else NNTP User

    Default Re: Software Manager on v10.3 Issues

    ken yap wrote:
    > Well you sure confused us talking about v10.3 when what you have is SLES
    > 10 SP1, and not even SP3.


    please notice who posted what..

    --
    somebody_else

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •